summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2020-07-28 10:10:44 -0700
committerMaximilian Weiss2020-07-28 10:10:44 -0700
commitcbd810c2396c74762f21b330d6484c394749725f (patch)
tree9b0ab89b22f2677a0deac3e82948ba5f64a23d5b
parent18040bb939082ebb7768c15acafbc73138e6611b (diff)
downloadaur-vcsteg.tar.gz
Fix crash issue with -p option
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--fix.patch11
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eb36a9df9fe..308291e4f8a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vcsteg
pkgdesc = Real Steganography with TrueCrypt
pkgver = 3.0
- pkgrel = 1
+ pkgrel = 2
url = https://keyj.emphy.de/real-steganography-with-truecrypt/
arch = any
license = custom:FOSS
@@ -23,7 +23,9 @@ pkgbase = vcsteg
conflicts = tcsteg3
conflicts = tcsteg3.py
source = https://keyj.emphy.de/files/tcsteg3.py
+ source = fix.patch
sha256sums = d6b506865c8cb15d081c8fe77e4e18ec1f9e89cef1f9c400bf6a47a6447e0784
+ sha256sums = 59229ffb0c562ae0573abde247a4a891b6cac7f62f60dc3d2207ba321df70a94
pkgname = vcsteg
diff --git a/PKGBUILD b/PKGBUILD
index d51ae7fc5217..6823479a88ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=vcsteg
pkgver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc='Real Steganography with TrueCrypt'
arch=('any')
url='https://keyj.emphy.de/real-steganography-with-truecrypt/'
@@ -16,8 +16,14 @@ depends=('python')
provides=('vcsteg' 'tcsteg' 'vcsteg3' 'tcsteg3')
conflicts=('tcsteg' 'tcsteg2' 'tcsteg.py' 'tcsteg2.py' 'vcsteg' 'vcsteg2' 'vcsteg.py' 'vcsteg2.py' 'vcsteg3' 'vcsteg3.py' 'tcsteg3' 'tcsteg3.py')
-source=('https://keyj.emphy.de/files/tcsteg3.py')
-sha256sums=('d6b506865c8cb15d081c8fe77e4e18ec1f9e89cef1f9c400bf6a47a6447e0784')
+source=('https://keyj.emphy.de/files/tcsteg3.py' 'fix.patch')
+sha256sums=('d6b506865c8cb15d081c8fe77e4e18ec1f9e89cef1f9c400bf6a47a6447e0784'
+ '59229ffb0c562ae0573abde247a4a891b6cac7f62f60dc3d2207ba321df70a94')
+
+build() {
+ cd "$srcdir/"
+ patch -p0 --follow-symlinks -i fix.patch
+}
package() {
cd "$srcdir/"
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..a5f9430814d3
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,11 @@
+--- tcsteg3.py 2019-06-18 11:51:40.000000000 -0000
++++ tcsteg3.py 2019-06-18 11:51:40.000000000 -0000
+@@ -125,7 +125,7 @@
+ f_dest.seek(bodySize - 1, 1)
+ byte = f_dest.read(1)
+ if not byte:
+- f_dest.write("\0")
++ f_dest.write(b"\0")
+ else:
+ f_dest.seek(-1, 1)
+ f_dest.write(byte)