summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorknedlyk2015-06-23 23:30:27 +0200
committerknedlyk2015-06-23 23:30:27 +0200
commit35c9c1e7e93688dbed12df8f66a67a3333afe17e (patch)
tree4e3ed149365d4c21069d042fcd2d82ee0a436bfa
downloadaur-vdr-plugin-actuator.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--plugin.actuator.conf2
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5d6f50b0a79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vdr-plugin-actuator
+ pkgdesc = For archvdr project!!! VDR-Plugin to control a linear or an horizon to horizon actuator and use as a channelscanner
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://ventoso.org/luca/vdr/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = vdr
+ makedepends = unzip
+ depends = vdr>=1.7.27
+ backup = etc/vdr/plugins/plugin.actuator.conf
+ source = http://ventoso.org/luca/vdr/vdr-actuator-1.2.1.tgz
+ source = plugin.actuator.conf
+ md5sums = 88b87846b86a5130afa46e39d0d1d88f
+ md5sums = 89ba2f74cb03d8855599bf3a846bcceb
+
+pkgname = vdr-plugin-actuator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f73adc06378e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer : Edgar Hucek <gimli at dark-green dot com>
+
+_pkgname=actuator
+pkgname=vdr-plugin-$_pkgname
+pkgver=1.2.1
+revision=3
+pkgrel=1
+arch=(i686 x86_64)
+pkgdesc="For archvdr project!!! VDR-Plugin to control a linear or an horizon to horizon actuator and use as a channelscanner"
+url="http://ventoso.org/luca/vdr/"
+license="GPL"
+makedepends=('vdr' 'unzip')
+depends=('vdr>=1.7.27')
+source=(http://ventoso.org/luca/vdr/vdr-actuator-$pkgver.tgz
+ plugin.actuator.conf)
+md5sums=('88b87846b86a5130afa46e39d0d1d88f'
+ '89ba2f74cb03d8855599bf3a846bcceb')
+backup=('etc/vdr/plugins/plugin.actuator.conf')
+
+build() {
+ unset CXXFLAGS
+
+ cd ${srcdir}/$_pkgname-${pkgver}
+
+ mkdir -p $pkgdir/usr/lib/vdr/plugins/ || return 1
+ mkdir -p $pkgdir/var/lib/vdr/plugins/transponders/ || return 1
+ mkdir -p $pkgdir/etc/vdr/plugins/transponders/ || return 1
+ sed -i -e "s/SystemValues/SystemValuesSat/" actuator.c
+ sed -i -e "s/const\ cDevice\ \*Device\,\ int\ ChannelNumber/const\ cDevice\ \*Device\,\ int\ ChannelNumber\,bool\ LiveView/" actuator.c
+ make VDRDIR=/usr/include/vdr \
+ LIBDIR=. \
+ INCLUDES=-I/usr/include/vdr \
+ LOCALEDIR="$startdir/pkg/usr/share/locale/" all || return 1
+
+ install -m 755 libvdr-*.so.* $pkgdir/usr/lib/vdr/plugins/ || return 1
+ install -m 664 $startdir/plugin.actuator.conf $pkgdir/etc/vdr/plugins/ || return 1
+ wget http://www.fastsatfinder.com/bin/Transponders.zip -O $pkgdir/var/lib/vdr/plugins/transponders/Transponders.zip
+ cd $pkgdir/var/lib/vdr/plugins/transponders/
+ unzip Transponders.zip
+
+}
+
diff --git a/plugin.actuator.conf b/plugin.actuator.conf
new file mode 100644
index 000000000000..5336ba8d7d3d
--- /dev/null
+++ b/plugin.actuator.conf
@@ -0,0 +1,2 @@
+#Use plugin as channel scanner
+-s \ No newline at end of file