summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevorster2020-06-15 22:56:54 +0200
committerevorster2020-06-15 22:56:54 +0200
commit18082110ba1a40339e265672ddba065450870e41 (patch)
treeaa8f416306e923a97f41869e537bc0b2d0033633
downloadaur-18082110ba1a40339e265672ddba065450870e41.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--python3_compile.patch11
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..834f3ded6e02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = vegastrike-git
+ pkgdesc = A spaceflight simulator in massive universe
+ pkgver = 1
+ pkgrel = 1
+ url = www.vega-strike.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = boost-libs
+ depends = python
+ depends = freeglut
+ depends = gtk2
+ depends = openal
+ depends = sdl
+ depends = glu
+ depends = vegastrike-data
+ provides = vegastrike
+ conflicts = vegastrike
+ source = git+https://github.com/vegastrike/Vega-Strike-Engine-Source
+ sha1sums = SKIP
+
+pkgname = vegastrike-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bf90db02336
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+#Maintainer: Evert Vorster <evorster@gmail.com>
+pkgname=vegastrike-git
+pkgver=1
+pkgrel=1
+pkgdesc="A spaceflight simulator in massive universe"
+arch=('i686' 'x86_64')
+url="www.vega-strike.org"
+license=('GPL')
+depends=('boost-libs' 'python' 'freeglut' 'gtk2' 'openal' 'sdl' 'glu' 'vegastrike-data')
+#optdepends=('vegastrike-data: original dataset')
+makedepends=('git' 'cmake')
+provides=('vegastrike')
+conflicts=('vegastrike')
+#install=$pkgname.install
+#options=(!makeflags debug !strip)
+
+source=('git+https://github.com/vegastrike/Vega-Strike-Engine-Source')
+sha1sums=('SKIP')
+
+prepare(){
+mkdir -p build
+patch -Np1 -i ../python3_compile.patch
+}
+
+build(){
+ cd build
+ cmake ../Vega-Strike-Engine-Source/engine/ \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_PIE=ON \
+ -DUSE_PYTHON_3=ON
+ make
+}
+
+package() {
+mkdir -p "${pkgdir}"/usr/bin
+ cd build
+ cp -vp {vegastrike,setup/vegasettings,objconv/mesh_tool} "${pkgdir}"/usr/bin
+}
diff --git a/python3_compile.patch b/python3_compile.patch
new file mode 100644
index 000000000000..7ddf30236c7e
--- /dev/null
+++ b/python3_compile.patch
@@ -0,0 +1,11 @@
+--- src/Vega-Strike-Engine-Source/engine/CMakeLists.txt_backup 2020-06-15 18:54:51.819058797 +0200
++++ src/Vega-Strike-Engine-Source/engine/CMakeLists.txt 2020-06-15 18:55:43.456681085 +0200
+@@ -720,7 +720,7 @@
+ UNSET(Boost_python_FOUND CACHE)
+ IF (USE_PYTHON_3)
+ MESSAGE("++ Looking for System Boost::python3")
+- FIND_PACKAGE(Boost COMPONENTS python3 log log_setup REQUIRED)
++ FIND_PACKAGE(Boost COMPONENTS python log log_setup REQUIRED)
+ ELSE (USE_PYTHON_3)
+ MESSAGE("++ Looking for System Boost::python (py2)")
+ FIND_PACKAGE(Boost COMPONENTS python log log_setup REQUIRED)