summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brand2023-05-28 01:27:52 +0000
committerSimon Brand2023-05-28 01:27:52 +0000
commit45fa981770666ad5b635faab2ac16a56eedcc6fd (patch)
tree8346aaf2c9016809c514cf3f5ccb681415fbc417
parentbb8ffc4ba55367c43160e0f3dcc18fb25604bf80 (diff)
downloadaur-45fa981770666ad5b635faab2ac16a56eedcc6fd.tar.gz
Update to 0.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d68c88a0bb2..ad9397b78a08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = verity-squash-root
pkgdesc = Build signed efi files which mount a verified squashfs image as rootfs on boot
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/brandsimon/verity-squash-root/
arch = any
@@ -22,8 +22,8 @@ pkgbase = verity-squash-root
depends = squashfs-tools
depends = tar
backup = etc/verity_squash_root/config.ini
- source = verity-squash-root-0.3.0.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/0.3.0.tar.gz
- sha512sums = 1b9db016a652a799b757efe036076cfad3c37ddbb9196ff1895814edd1c85610d2dafdb64351a959f3a5a6080cf250e659294128072871bce4a0b62941f4976e
- b2sums = 1846f086043b4dc5a82e08987df6bc749b43a18a4bc7b024faa3d1199f4d2f2d7c3808367b9fbb58e22ee675aed7e7f44a6046b5be29b257bfc60d88339b52fe
+ source = verity-squash-root-0.3.1.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/v0.3.1.tar.gz
+ sha512sums = 28bc535fe0c89c20b2e4b2d3f69c2ffd08603186e5a83612a81554ebae506939271a3bf31d1a60002196e87ac33c3b0f83e6717449673bb3eb65c4932ff14758
+ b2sums = 7936a97613870f84596d98399ccbbde074e434214247135e9f24dbd15e144589d635d6fe3fe9097b855058f07c9a22d68b357627fa685c37673bd2794b3f3b13
pkgname = verity-squash-root
diff --git a/PKGBUILD b/PKGBUILD
index 983a0b5e6ce3..f68689922334 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simon Brand <simon.brand@postadigitale.de>
pkgname=verity-squash-root
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc='Build signed efi files which mount a verified squashfs image as rootfs on boot'
arch=(any)
@@ -11,9 +11,9 @@ depends=(age bash python binutils cryptsetup efitools sbsigntools squashfs-tools
makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(flake8 mypy shellcheck)
backup=(etc/verity_squash_root/config.ini)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/${pkgver}.tar.gz")
-sha512sums=('1b9db016a652a799b757efe036076cfad3c37ddbb9196ff1895814edd1c85610d2dafdb64351a959f3a5a6080cf250e659294128072871bce4a0b62941f4976e')
-b2sums=('1846f086043b4dc5a82e08987df6bc749b43a18a4bc7b024faa3d1199f4d2f2d7c3808367b9fbb58e22ee675aed7e7f44a6046b5be29b257bfc60d88339b52fe')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('28bc535fe0c89c20b2e4b2d3f69c2ffd08603186e5a83612a81554ebae506939271a3bf31d1a60002196e87ac33c3b0f83e6717449673bb3eb65c4932ff14758')
+b2sums=('7936a97613870f84596d98399ccbbde074e434214247135e9f24dbd15e144589d635d6fe3fe9097b855058f07c9a22d68b357627fa685c37673bd2794b3f3b13')
build() {
cd "${pkgname}-${pkgver}"
@@ -42,10 +42,15 @@ package() {
install -dm 755 "${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root"
install -Dm 755 usr/lib/dracut/modules.d/99verity-squash-root/module-setup.sh \
"${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root/"
- install -Dm 644 usr/lib/dracut/modules.d/99verity-squash-root/verity_squash_root.conf \
+ install -Dm 644 usr/lib/dracut/modules.d/99verity-squash-root/cryptsetup_overlay.conf \
+ "${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root/"
+ install -Dm 644 usr/lib/dracut/modules.d/99verity-squash-root/dracut_mount_overlay.conf \
"${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root/"
install -Dm 644 usr/lib/initcpio/install/verity-squash-root "${pkgdir}/usr/lib/initcpio/install"
install -Dm 755 usr/share/bash-completion/completions/verity-squash-root \
"${pkgdir}/usr/share/bash-completion/completions/"
+ install -dm 755 "${pkgdir}/verity-squash-root/usr/lib/systemd/system"
+ install -Dm 644 usr/lib/systemd/system/verity-squash-root-notifiy.service \
+ "${pkgdir}/usr/lib/systemd/system/verity-squash-root-notifiy.service"
install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/verity-squash-root"
}