summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brand2023-08-02 19:25:00 +0000
committerSimon Brand2023-08-02 19:25:00 +0000
commit8b5b853fb03172e3eff3d2b562da334d6e8cc552 (patch)
treefd45889fe00a7bb6474fb6d1fb68f13ea8125fbd
parent7f2dbf513615f2cfbfa0f010bf0cdae35dc745ff (diff)
downloadaur-8b5b853fb03172e3eff3d2b562da334d6e8cc552.tar.gz
Update to 0.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 9 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad9397b78a08..5895c7514561 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = verity-squash-root
pkgdesc = Build signed efi files which mount a verified squashfs image as rootfs on boot
- pkgver = 0.3.1
+ pkgver = 0.3.2
pkgrel = 1
url = https://github.com/brandsimon/verity-squash-root/
arch = any
@@ -22,8 +22,8 @@ pkgbase = verity-squash-root
depends = squashfs-tools
depends = tar
backup = etc/verity_squash_root/config.ini
- source = verity-squash-root-0.3.1.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/v0.3.1.tar.gz
- sha512sums = 28bc535fe0c89c20b2e4b2d3f69c2ffd08603186e5a83612a81554ebae506939271a3bf31d1a60002196e87ac33c3b0f83e6717449673bb3eb65c4932ff14758
- b2sums = 7936a97613870f84596d98399ccbbde074e434214247135e9f24dbd15e144589d635d6fe3fe9097b855058f07c9a22d68b357627fa685c37673bd2794b3f3b13
+ source = verity-squash-root-0.3.2.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/v0.3.2.tar.gz
+ sha512sums = 09d583f71906975aaf1bd18b274e809ace8a81fa42b4023de0c4f5052126536233079db31f7248df127c33672e686564be9966db38892b7b31854dd4afda654d
+ b2sums = 6b7fb9d411e15874edc3c6220f9993d813d250143c0aae74f140d0b2a463604bdbc3557d2e9889229fb198c0ff1052745c6c903b3e72b9d10afd03649da01e27
pkgname = verity-squash-root
diff --git a/PKGBUILD b/PKGBUILD
index 55207d6f24b4..965383f1f936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Simon Brand <simon.brand@postadigitale.de>
pkgname=verity-squash-root
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=1
pkgdesc='Build signed efi files which mount a verified squashfs image as rootfs on boot'
arch=(any)
@@ -12,11 +12,12 @@ makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(flake8 mypy shellcheck)
backup=(etc/verity_squash_root/config.ini)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brandsimon/verity-squash-root/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('28bc535fe0c89c20b2e4b2d3f69c2ffd08603186e5a83612a81554ebae506939271a3bf31d1a60002196e87ac33c3b0f83e6717449673bb3eb65c4932ff14758')
-b2sums=('7936a97613870f84596d98399ccbbde074e434214247135e9f24dbd15e144589d635d6fe3fe9097b855058f07c9a22d68b357627fa685c37673bd2794b3f3b13')
+sha512sums=('09d583f71906975aaf1bd18b274e809ace8a81fa42b4023de0c4f5052126536233079db31f7248df127c33672e686564be9966db38892b7b31854dd4afda654d')
+b2sums=('6b7fb9d411e15874edc3c6220f9993d813d250143c0aae74f140d0b2a463604bdbc3557d2e9889229fb198c0ff1052745c6c903b3e72b9d10afd03649da01e27')
build() {
cd "${pkgname}-${pkgver}"
+ make
python -m build --wheel --no-isolation
}
@@ -30,27 +31,5 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
install -dm 755 "${pkgdir}"
- python -m installer --destdir="${pkgdir}" dist/*.whl
- install -dm 755 "${pkgdir}/usr/lib/"{initcpio,verity-squash-root}
- install -dm 755 "${pkgdir}/usr/lib/initcpio/install"
- install -dm 755 "${pkgdir}/usr/share/bash-completion/completions"
- install -dm 755 "${pkgdir}/usr/share/licenses/verity-squash-root"
- install -dm 755 "${pkgdir}/usr/share/verity_squash_root/" "${pkgdir}/etc/verity_squash_root/"
- install -Dm 644 src/verity_squash_root/default_config.ini "${pkgdir}/usr/share/verity_squash_root/default.ini"
- install -Dm 600 src/verity_squash_root/default_config.ini "${pkgdir}/etc/verity_squash_root/config.ini"
- install -Dm 755 usr/lib/verity-squash-root/* "${pkgdir}/usr/lib/verity-squash-root"
- install -dm 755 "${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root"
- install -Dm 755 usr/lib/dracut/modules.d/99verity-squash-root/module-setup.sh \
- "${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root/"
- install -Dm 644 usr/lib/dracut/modules.d/99verity-squash-root/cryptsetup_overlay.conf \
- "${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root/"
- install -Dm 644 usr/lib/dracut/modules.d/99verity-squash-root/dracut_mount_overlay.conf \
- "${pkgdir}/usr/lib/dracut/modules.d/99verity-squash-root/"
- install -Dm 644 usr/lib/initcpio/install/verity-squash-root "${pkgdir}/usr/lib/initcpio/install"
- install -Dm 755 usr/share/bash-completion/completions/verity-squash-root \
- "${pkgdir}/usr/share/bash-completion/completions/"
- install -dm 755 "${pkgdir}/usr/lib/systemd/system"
- install -Dm 644 usr/lib/systemd/system/verity-squash-root-notifiy.service \
- "${pkgdir}/usr/lib/systemd/system/verity-squash-root-notifiy.service"
- install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/verity-squash-root"
+ make install DESTDIR="${pkgdir}"
}