summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fettouhi2015-06-08 22:00:02 +0200
committerAndré Fettouhi2015-06-08 22:00:02 +0200
commit1673714e9eb431f439b93cdb4f53b30bc7f9a40f (patch)
tree54655b7349a7513d40702fde173fb53cd7d85fa6
downloadaur-vessel.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD72
-rw-r--r--vessel.desktop12
3 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18ce83459d78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vessel
+ pkgdesc = A physics-based, steampunk puzzle-platform game
+ pkgver = 20130222
+ pkgrel = 1
+ url = http://www.strangeloopgames.com/
+ arch = i686
+ arch = x86_64
+ groups = humble-indie-bundle6
+ groups = games
+ license = custom
+ makedepends = unzip
+ makedepends = imagemagick
+ depends = sdl
+ depends = openal
+ depends = bash
+ depends = gcc-libs
+ optdepends = libtxc_dxtn: texture decoding support for open source graphics drivers
+ source = hib://vessel-02222013-bin
+ source = vessel.desktop
+ sha256sums = be96e670a51fc27176b31ed88a1a1a4447d113595eceeac9727bb03743465c73
+ sha256sums = 941c7534f8a557f5cdbbec0f19a4e13c76d393006bdb6e1dafd5529b5c9b6697
+
+pkgname = vessel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4594b8054dee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: afettouhi <A.Fettouhi@gmail.com>
+# Contributor: David Miller <moebius282 e4at gmail D0_T com>
+
+pkgname=vessel
+pkgver=20130222
+_binver=02222013
+pkgrel=1
+pkgdesc="A physics-based, steampunk puzzle-platform game"
+url="http://www.strangeloopgames.com/"
+license=('custom')
+arch=('i686' 'x86_64')
+groups=("humble-indie-bundle6" "games")
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-sdl' 'lib32-openal' 'bash' 'lib32-gcc-libs')
+ optdepends=('lib32-libtxc_dxtn: texture decoding support for open source graphics drivers')
+else
+ depends=('sdl' 'openal' 'bash' 'gcc-libs')
+ optdepends=('libtxc_dxtn: texture decoding support for open source graphics drivers')
+fi
+
+source=("hib://${pkgname}-${_binver}-bin"
+# 'http://www.flibitijibibo.com/patch/vessel/linux-12192012.tar.gz'
+ "${pkgname}.desktop")
+sha256sums=('be96e670a51fc27176b31ed88a1a1a4447d113595eceeac9727bb03743465c73'
+# 'bf7708a195ef3546c8c3b30b74ff427d5fe5e1548991b4f291264bbd275fe17e'
+ '941c7534f8a557f5cdbbec0f19a4e13c76d393006bdb6e1dafd5529b5c9b6697')
+makedepends=('unzip' 'imagemagick')
+#options=('!strip')
+PKGEXT=".pkg.tar"
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+
+package() {
+
+ mkdir -p "${pkgdir}/opt/${pkgname}/"
+
+# unzip is stupid..
+ unzip -qq "${srcdir}/${pkgname}-${_binver}-bin" -d "${pkgdir}/opt/tmp/" 'data/*' || true
+
+ mv "${pkgdir}/opt/tmp/data/"* "${pkgdir}/opt/${pkgname}/"
+ rm -r "${pkgdir}/opt/tmp/"
+
+# tar --overwrite -zxf "${srcdir}/linux-12192012.tar.gz" -C "${pkgdir}/opt/${pkgname}/"
+
+ for i in 'libSDL-1.2.so.0' 'libstdc++.so.6'; do
+ rm "${pkgdir}/opt/${pkgname}/x86/${i}"*
+ done
+
+#the spec only specifies png, svg and xpm..
+ convert "${pkgdir}/opt/${pkgname}/Vessel.bmp" "${pkgdir}/opt/${pkgname}/${pkgname}.png"
+ rm "${pkgdir}/opt/${pkgname}/Vessel.bmp"
+
+ chown -R root:root "${pkgdir}/opt/${pkgname}/"
+
+ sed -i -e 's|`dirname "$0"`|$(dirname \"$(readlink -f \"$0\")\")|' "${pkgdir}/opt/${pkgname}/Vessel"
+
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "${pkgdir}/opt/${pkgname}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ mkdir "${pkgdir}/usr/bin/"
+ ln -s "/opt/${pkgname}/Vessel" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/vessel.desktop b/vessel.desktop
new file mode 100644
index 000000000000..53754f68d517
--- /dev/null
+++ b/vessel.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Vessel
+GenericName=Vessel
+Comment=A physics-based, steampunk puzzle-platform game
+Icon=vessel.png
+Exec=vessel
+Categories=Game;
+Path=/opt/vessel
+