summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-30 10:41:20 +0800
committerzxp198210052024-04-30 10:41:20 +0800
commit75fe0fffef1a8ff101e03dcfe08e7729b8a9e283 (patch)
treed9c9e7117b2f398f6921f88a139d9ac8dd2db79c
parentc6b08b8e135c92fa6701d786a017c8babe025fb8 (diff)
downloadaur-video-hub-app-bin.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--video-hub-app.sh13
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e35a6869345..f15f82e38d91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = video-hub-app-bin
pkgdesc = The fastest way to browse and search for videos on your computer. Think of it like YouTube for videos on your computer: browse, search, and preview.
pkgver = 3.2.0
- pkgrel = 6
+ pkgrel = 7
url = https://videohubapp.com/
arch = x86_64
license = MIT
depends = electron22
+ depends = nodejs
provides = video-hub-app=3.2.0
conflicts = video-hub-app
source = video-hub-app-3.2.0.AppImage::https://github.com/whyboris/Video-Hub-App/releases/download/v3.2.0/Video.Hub.App.3.Demo-3.2.0.AppImage
@@ -13,6 +14,6 @@ pkgbase = video-hub-app-bin
source = video-hub-app.sh
sha256sums = 5264acfd9d4e3ca0ce7332acaeb74431c49b48e9f50f01bd9f45074ea323577b
sha256sums = 096d751c3b4fea8ec7f2c8600137020ac6d1ab74b27a6353d1a3dca4271bc9f0
- sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ sha256sums = 61d56055897e9d71d68e185ac2de7c4cb2fbca16eb3fb0091703612c113441f3
pkgname = video-hub-app-bin
diff --git a/PKGBUILD b/PKGBUILD
index bed0f1219138..ec637e5d489d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=video-hub-app-bin
_pkgname=Video.Hub.App
pkgver=3.2.0
_electronversion=22
-pkgrel=6
+pkgrel=7
pkgdesc="The fastest way to browse and search for videos on your computer. Think of it like YouTube for videos on your computer: browse, search, and preview."
arch=('x86_64')
url="https://videohubapp.com/"
@@ -13,6 +13,7 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
+ 'nodejs'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${_ghurl}/releases/download/v${pkgver}/${_pkgname}.3.Demo-${pkgver}.AppImage"
@@ -21,7 +22,7 @@ source=(
)
sha256sums=('5264acfd9d4e3ca0ce7332acaeb74431c49b48e9f50f01bd9f45074ea323577b'
'096d751c3b4fea8ec7f2c8600137020ac6d1ab74b27a6353d1a3dca4271bc9f0'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '61d56055897e9d71d68e185ac2de7c4cb2fbca16eb3fb0091703612c113441f3')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/video-hub-app.sh b/video-hub-app.sh
index f9ced1432cfc..842c77e19b1d 100644
--- a/video-hub-app.sh
+++ b/video-hub-app.sh
@@ -1,14 +1,21 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
+export XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-$HOME/.config}"
+_FLAGS_FILE="${XDG_CONFIG_HOME}/@appname@-flags.conf"
+if [ -r "${_FLAGS_FILE}" ]; then
+ _USER_FLAGS="$(cat "${_FLAGS_FILE}")"
+fi
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "${_USER_FLAGS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "${_USER_FLAGS}" "$@" || exit $?
fi \ No newline at end of file