summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2022-09-26 00:01:53 -0400
committerChris Severance2022-09-26 00:01:53 -0400
commit4a5cda2334d72dc7dc8f0c6cb36b1eb5e0ed7051 (patch)
tree1e64bbc4e1629e69af120a86bc0cda9454db8160
parent2e8873de04bb1458b591dd85866b2c343fd728a6 (diff)
downloadaur-viewvc.tar.gz
autu: Update to 1.3.0.dev.r2596.gc22eb71b-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 36 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0a3e99a9331..b10c8a9b38d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Sep 26 04:01:53 UTC 2022
pkgbase = viewvc
pkgdesc = web-based vcs version control repository browsing, formerly viewcvs
- pkgver = 1.2.1
+ pkgver = 1.3.0.dev.r2596.gc22eb71b
pkgrel = 1
url = https://github.com/viewvc/viewvc
install = viewvc.install
@@ -10,12 +12,12 @@ pkgbase = viewvc
makedepends = cvs
makedepends = rcs
depends = subversion
- depends = python2
+ depends = python
depends = diffutils
backup = usr/share/viewvc/viewvc.conf
- source = viewvc-1.2.1.tar.gz::https://github.com/viewvc/viewvc/archive/1.2.1.tar.gz
- md5sums = 4c1bd8b7b54c0d994d58c7073d1c3e1f
- sha256sums = 5fe1e16f986b51a2800d908683673b880684e90ae1611d98744187f0649634f5
+ source = git+https://github.com/viewvc/viewvc.git#commit=c22eb71b192f82bb5fb28c251fce14d2aee6bd42
+ md5sums = SKIP
+ sha256sums = SKIP
pkgname = viewvc
diff --git a/PKGBUILD b/PKGBUILD
index 0f2a31effccf..b76db9894c86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: Claudio Riva <firetux83@gmail.com>
+_commit='#commit=c22eb71b192f82bb5fb28c251fce14d2aee6bd42' # python3
+
set -u
+_pyver='python'
pkgname='viewvc'
#_pkgno='49241'; pkgver='1.0.13'
#_pkgno='49392'; pkgver='1.1.23'
#_pkgno='49471'; pkgver='1.1.24'
#pkgver='1.1.27'
-pkgver='1.2.1'
-pkgrel='1'
+#pkgver=1.2.1; _pyver='python2'
+pkgver=1.3.0.dev.r2596.gc22eb71b
+pkgrel=1
pkgdesc='web-based vcs version control repository browsing, formerly viewcvs'
arch=('i686' 'x86_64')
#url='http://viewvc.tigris.org/'
url='https://github.com/viewvc/viewvc'
license=('custom:ViewVC')
-depends=('subversion' 'python2' 'diffutils')
+depends=('subversion' "${_pyver}" 'diffutils')
makedepends=('cvs' 'rcs')
backup=('usr/share/viewvc/viewvc.conf')
install="${pkgname}.install"
@@ -26,15 +30,34 @@ source=("${_srcdir}.tar.gz::${url}/archive/${pkgver}.tar.gz")
md5sums=('4c1bd8b7b54c0d994d58c7073d1c3e1f')
sha256sums=('5fe1e16f986b51a2800d908683673b880684e90ae1611d98744187f0649634f5')
+if [ ! -z "${_commit:-}" ]; then
+ source[0]="git+${url}.git${_commit}"
+ md5sums[0]='SKIP'
+ sha256sums[0]='SKIP'
+ _srcdir="${pkgname}"
+pkgver() {
+ set -u
+ cd "${_srcdir}"
+ local _ver="$(sed -n -E -e 's:^__version__ = "([^"]+)".*$:\1:p' 'lib/viewvc.py')" # '
+ printf '%s.r%s.g%s' "${_ver//-/.}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ set +u
+}
+elif [ "${pkgver}" != "${pkgver%.r*}" ]; then
+pkgver() {
+ set -u
+ printf '%s' "${pkgver%.r*}"
+ set +u
+}
+fi
+
package() {
set -u
- set -x
- cd "${pkgname}-${pkgver}"
+ cd "${_srcdir}"
sed -e "s@DESTDIR = None@DESTDIR = \"${pkgdir}/\"@g" \
-e "s@ROOT_DIR = None@ROOT_DIR = \"/usr/share/${pkgname}\"@g" \
-i 'viewvc-install'
- python2 viewvc-install
+ "${_pyver}" 'viewvc-install'
install -Dpm755 "${pkgdir}/usr/share/${pkgname}/bin/cgi"/viewvc.cgi -t "${pkgdir}/srv/httpd/cgi-bin/"
sed -e "s@#rcs_path = /usr/bin/@rcs_path = /usr/bin/@g" \
-e "s@mime_types_file = /usr/local/apache/conf/mime.types@mime_types_file = /etc/httpd/conf/mime.types@g" \