summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-14 18:59:37 -0500
committerLuis Martinez2021-10-14 18:59:37 -0500
commit62b531781b157e597e6b6c03f9ac2e3c47f414a0 (patch)
treec22d42fcfdbf9fb869043ae33b8c98d5654293f5
parent1b1a0980c63aa9bec42726cdbd113d67e55e7235 (diff)
downloadaur-vim-endwise.tar.gz
another package cleanup
* added vim-plugin-runtime as dependency instead of just vim for neovim compatibility
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 303dd444fa17..25848b6e11b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Sun Mar 5 23:13:22 UTC 2017
pkgbase = vim-endwise
- pkgdesc = A simple plugin that helps to end certain structures automatically.
+ pkgdesc = Vim plugin for ending structures automatically in Ruby
pkgver = 1.2
- pkgrel = 3
- url = https://github.com/tpope/${pkgname}
+ pkgrel = 4
+ url = https://github.com/tpope/vim-endwise
arch = any
groups = vim-plugins
license = custom:vim
- depends = vim
- source = vim-endwise-1.2.tar.gz::https://github.com/tpope/vim-endwise/archive/v1.2.tar.gz
+ makedepends = git
+ depends = vim-plugin-runtime
+ source = vim-endwise::git+https://github.com/tpope/vim-endwise#tag=v1.2?signed
source = license.txt
- sha256sums = 365f0624fbe69beaedbdca5c6fae4e428e66b217bb59d3bba60d5aef0ada1b7b
+ validpgpkeys = 881804A5DA541152FA12C105E09E474A404A3A45
+ sha256sums = SKIP
sha256sums = 5f96d0bf57942212b6117ac4e6eb9b6ad704c1758511333dd5785cedf3281b8d
pkgname = vim-endwise
-
diff --git a/PKGBUILD b/PKGBUILD
index 2fc4b08a3046..8dae5ced30b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: revel <revelΘmuub·net>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: revel <revelΘmuub·net>
pkgname=vim-endwise
pkgver=1.2
-pkgrel=3
-pkgdesc='A simple plugin that helps to end certain structures automatically.'
+pkgrel=4
+pkgdesc='Vim plugin for ending structures automatically in Ruby'
arch=('any')
-#url='http://www.vim.org/scripts/script.php?script_id=2386'
-url='https://github.com/tpope/${pkgname}'
+url='https://github.com/tpope/vim-endwise'
license=('custom:vim')
-depends=('vim')
groups=('vim-plugins')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tpope/${pkgname}/archive/v${pkgver}.tar.gz"
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("$pkgname::git+$url#tag=v$pkgver?signed"
'license.txt')
-sha256sums=('365f0624fbe69beaedbdca5c6fae4e428e66b217bb59d3bba60d5aef0ada1b7b'
+sha256sums=('SKIP'
'5f96d0bf57942212b6117ac4e6eb9b6ad704c1758511333dd5785cedf3281b8d')
+validpgpkeys=('881804A5DA541152FA12C105E09E474A404A3A45')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- local installpath="${pkgdir}/usr/share/vim/vimfiles"
-
- install -D -m644 "plugin/endwise.vim" "${installpath}/plugin/endwise.vim"
- install -D -m644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgname"
+ install -Dm 644 plugin/endwise.vim -t "$pkgdir/usr/share/vim/vimfiles/plugin/"
}