summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Chen2017-10-21 22:15:32 +0800
committerJohn Chen2017-10-21 22:15:32 +0800
commitf576c840fadee18a511f0548fd16a6f06127fb8c (patch)
tree099687e55b4dab317b7a614b5425909fb19ab9d2
downloadaur-vim-html5-git.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b566d5ee1a05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-html5-git
+ pkgdesc = Vim HTML5 omnicomplete and syntax
+ pkgver = 0.27.r176.g916085d
+ pkgrel = 1
+ url = https://github.com/othree/html5.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim
+ provides = vim-html5
+ conflicts = vim-html5
+ source = git+https://github.com/othree/html5.vim.git
+ md5sums = SKIP
+
+pkgname = vim-html5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0fc651929ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Pochang Chen <johnchen902@gmail.com>
+
+pkgname=vim-html5-git
+pkgver=0.27.r176.g916085d
+pkgrel=1
+pkgdesc="Vim HTML5 omnicomplete and syntax"
+arch=('any')
+url="https://github.com/othree/html5.vim"
+license=('MIT')
+depends=('vim')
+makedepends=('git')
+groups=('vim-plugins')
+conflicts=('vim-html5')
+provides=('vim-html5')
+source=('git+https://github.com/othree/html5.vim.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/html5.vim"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/html5.vim"
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ mkdir -p ${installpath}
+ cp -r after autoload ftplugin indent syntax ${installpath}
+
+ #just in case... make sure it's all 644
+ find ${installpath} -type f -exec chmod 644 {} \;
+}