summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2015-08-03 15:28:09 +0200
committerMaxim Andersson2015-08-03 15:28:09 +0200
commitaf48dcfa3e244479cd7bc33560bf8a664ecd259a (patch)
tree3afccf3ec1840286ee8579804a3f0478dfc07dd3
downloadaur-vim-lighttpd.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5412b5320027
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-lighttpd
+ pkgdesc = Syntax highlighting for lighttpd config files
+ pkgver = 1.19
+ pkgrel = 1
+ url = https://github.com/glensc/vim-syntax-lighttpd
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ depends = vim
+ source = https://github.com/glensc/vim-syntax-lighttpd/archive/v1.19.tar.gz
+ sha256sums = 6e954a1597a5136c7e5469a838c134eb52640dfd9eacd2342c85e41e83740f60
+
+pkgname = vim-lighttpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9b93305593a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+
+pkgname=vim-lighttpd
+_gitname=vim-syntax-lighttpd
+pkgver=1.19
+pkgrel=1
+pkgdesc="Syntax highlighting for lighttpd config files"
+arch=('any')
+url="https://github.com/glensc/vim-syntax-lighttpd"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim')
+source=("https://github.com/glensc/${_gitname}/archive/v${pkgver}.tar.gz")
+sha256sums=('6e954a1597a5136c7e5469a838c134eb52640dfd9eacd2342c85e41e83740f60')
+
+package() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+
+ install -Dm644 syntax/lighttpd.vim -t "${pkgdir}/usr/share/vim/vimfiles/syntax"
+ install -Dm644 ftdetect/lighttpd.vim -t "${pkgdir}/usr/share/vim/vimfiles/ftdetect"
+}
+
+# vim:set ts=2 sw=2 et: