summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven-Hendrik Haase2020-07-14 01:25:11 +0200
committerSven-Hendrik Haase2020-07-14 01:25:11 +0200
commitc12379a69adf58c961f9c4565dd59583438f18db (patch)
treefec072671650ca196d9653184a436937fd503573
downloadaur-vim-minibufexpl.tar.gz
Moved from [community]
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE8
-rw-r--r--PKGBUILD25
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c8525abc8d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-minibufexpl
+ pkgdesc = An elegant buffer explorer for vim
+ pkgver = 6.5.2
+ pkgrel = 3
+ url = http://fholgado.com/minibufexpl
+ arch = any
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = vim-minibufexpl-6.5.2.tar.gz::https://github.com/fholgado/minibufexpl.vim/archive/v6.5.2.tar.gz
+ source = LICENSE
+ sha512sums = 325fb58b025392c5484574c4988ec95eb7374a10b67a4abe28857a0ae8d768316ef4d477b51bf442ffc1bcfb5f68dfd0c924731291b155192731055fed3569d1
+ sha512sums = 12c8ea4338901bfd174cf9154850d683ed24656627f28423692ebd64ea79e0949bf4aef3778cf61deca4f7a2159f56872e86d6e4c9c404264c4da94e4770d588
+
+pkgname = vim-minibufexpl
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..24dff8fff8ef
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,8 @@
+" Copyright: Copyright (C) 2002 & 2003 Bindu Wavell
+" Permission is hereby granted to use and distribute this code,
+" with or without modifications, provided that this copyright
+" notice is copied with it. Like anything else that's free,
+" minibufexplorer.vim is provided *as is* and comes with no
+" warranty of any kind, either expressed or implied. In no
+" event will the copyright holder be liable for any damamges
+" resulting from the use of this software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89aaaceeeae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=vim-minibufexpl
+pkgver=6.5.2
+pkgrel=3
+pkgdesc="An elegant buffer explorer for vim"
+arch=('any')
+url="http://fholgado.com/minibufexpl"
+license=('custom')
+depends=('vim')
+groups=('vim-plugins')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fholgado/minibufexpl.vim/archive/v${pkgver}.tar.gz"
+ 'LICENSE')
+sha512sums=('325fb58b025392c5484574c4988ec95eb7374a10b67a4abe28857a0ae8d768316ef4d477b51bf442ffc1bcfb5f68dfd0c924731291b155192731055fed3569d1'
+ '12c8ea4338901bfd174cf9154850d683ed24656627f28423692ebd64ea79e0949bf4aef3778cf61deca4f7a2159f56872e86d6e4c9c404264c4da94e4770d588')
+
+package() {
+ cd ${srcdir}/minibufexpl.vim-${pkgver}
+ installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ install -D -m644 plugin/minibufexpl.vim $installpath/plugin/minibufexpl.vim
+ install -D -m644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}