summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Seghers2015-09-05 20:23:19 +0200
committerStijn Seghers2015-09-05 20:23:19 +0200
commitec9a89bb6f6bdf885e80f9226ac1ed320bcc8bc0 (patch)
tree67fb80a5a177c191e6d9df20dd25c8ae6ecca492
downloadaur-vim-oz.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..039a50161744
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Wed Apr 15 20:27:52 UTC 2015
+pkgbase = vim-oz
+ pkgdesc = Oz syntax highlighting and formatting for Vim
+ pkgver = 1.3.r6.g4a04881
+ pkgrel = 1
+ url = https://github.com/Procrat/oz.vim
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = vim
+ source = vim-oz::git+https://github.com/Procrat/oz.vim.git
+ md5sums = SKIP
+
+pkgname = vim-oz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75b9877727bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Stijn Seghers <stijnseghers at gmail dot com>
+
+pkgname=vim-oz
+pkgver=1.3.r6.g4a04881
+pkgrel=1
+pkgdesc='Oz syntax highlighting and formatting for Vim'
+arch=('any')
+url='https://github.com/Procrat/oz.vim'
+license=('unknown')
+depends=('vim')
+makedepends=('git')
+
+source=("$pkgname"::'git+https://github.com/Procrat/oz.vim.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package(){
+ cd "$srcdir/$pkgname"
+
+ _vim_dir="${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 ftdetect/oz.vim "${_vim_dir}/ftdetect/oz.vim"
+ install -Dm644 ftplugin/oz.vim "${_vim_dir}/ftplugin/oz.vim"
+ install -Dm644 syntax/oz.vim "${_vim_dir}/syntax/oz.vim"
+}