summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:55:26 +0000
committerOtto Sabart2015-06-30 09:55:26 +0000
commit637f411d246c2ce3408543ee1f0cf6a96aa34275 (patch)
treeda8217a18d5447877486d65021e4f41ebcdeaba0
downloadaur-vim-phpcomplete.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rwxr-xr-xvimdoc.install19
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9661f178080f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-phpcomplete
+ pkgdesc = Omni completition for PHP
+ pkgver = 1.3.3
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=3171
+ install = vimdoc.install
+ arch = i686
+ arch = x86_64
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = phpcomplete.vim::http://www.vim.org/scripts/download_script.php?src_id=14129
+ md5sums = d6568ed0a154819ab897f17b71785d2a
+
+pkgname = vim-phpcomplete
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cd694a2f769
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot]com>
+
+pkgname=vim-phpcomplete
+pkgver=1.3.3
+pkgrel=1
+pkgdesc="Omni completition for PHP"
+url="http://www.vim.org/scripts/script.php?script_id=3171"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('vim')
+optdepends=()
+groups=('vim-plugins')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install='vimdoc.install'
+
+_scriptid=14129
+source=(phpcomplete.vim::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+
+
+md5sums=('d6568ed0a154819ab897f17b71785d2a')
+
+
+build() {
+
+ install -Dm755 ${srcdir}/phpcomplete.vim ${pkgdir}/usr/share/vim/vimfiles/autoload/phpcomplete.vim || return 1
+}
+
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100755
index 000000000000..5246e5c21134
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*