summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:37:58 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:37:58 -0700
commit6606b3844d4435effa42660f4e7f32d1d639e345 (patch)
tree6cb3c09e05f3a4c401d806130b886d4d5ab54072
downloadaur-vim-promptline-git.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cd3b778c1b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-promptline-git
+ pkgdesc = Generate a fast shell prompt with powerline symbols and airline colors
+ pkgver = 1416082879
+ pkgrel = 1
+ url = https://github.com/edkolev/promptline.vim
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = vim
+ provides = vim-promptline
+ conflicts = vim-promptline
+ source = git://github.com/edkolev/promptline.vim.git
+ sha512sums = SKIP
+
+pkgname = vim-promptline-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf00b30674f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: John Jenkins twodopeshaggy@gmail.com
+_pkgname=promptline.vim
+pkgname=vim-promptline-git
+pkgver=1416082879
+pkgrel=1
+pkgdesc="Generate a fast shell prompt with powerline symbols and airline colors"
+arch=('any')
+url='https://github.com/edkolev/promptline.vim'
+license=('MIT')
+depends=('vim')
+makedepends=('git')
+provides=('vim-promptline')
+conflicts=('vim-promptline')
+
+source=('git://github.com/edkolev/promptline.vim.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd -- "$srcdir/$_pkgname"
+ git log -n1 --pretty=format:%ct
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/vim/vimfiles"
+ find * -maxdepth 0 -type d -exec cp -R -t "$pkgdir/usr/share/vim/vimfiles" '{}' \+
+}
+