summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Onn2017-02-11 00:25:29 +0100
committerAmos Onn2017-02-11 00:27:17 +0100
commit0f626bcc0d3def13d1bb51ca893b3d1eef0e02c4 (patch)
treee5528f5f3546bde4812f16f1012b8d7b98e386eb
downloadaur-vim-racer-git.tar.gz
First addition.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
-rw-r--r--vimdoc.install12
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2f1e12ca689
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Feb 10 23:27:08 UTC 2017
+pkgbase = vim-racer-git
+ pkgdesc = Vim plugin for using Racer for Rust code completion and navigation.
+ pkgver = r148.34f806e
+ pkgrel = 1
+ url = https://github.com/racer-rust/vim-racer
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = none
+ depends = vim>=7.3
+ depends = rust-racer
+ provides = vim-racer
+ replaces = vim-racer
+ source = git+https://github.com/racer-rust/vim-racer.git
+ md5sums = SKIP
+
+pkgname = vim-racer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d89c4305776b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Amos Onn <https://aur.archlinux.org/account/amosonn>
+
+pkgname=vim-racer-git
+_pkgname=vim-racer
+pkgver=r148.34f806e
+pkgrel=1
+pkgdesc='Vim plugin for using Racer for Rust code completion and navigation.'
+arch=('any')
+url='https://github.com/racer-rust/vim-racer'
+license=('none')
+depends=('vim>=7.3' 'rust-racer')
+provides=('vim-racer')
+replaces=('vim-racer')
+groups=('vim-plugins')
+install=vimdoc.install
+source=("git+https://github.com/racer-rust/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ local _vimdir="$pkgdir/usr/share/vim/vimfiles"
+ install -D -m644 {,"$_vimdir/"}"ftplugin/rust_racer.vim"
+ install -D -m644 {,"$_vimdir/"}"rplugin/python3/deoplete/sources/racer.py"
+ install -D -m644 {,"$_vimdir/"}"syntax/rustdoc.vim"
+ install -D -m644 {,"$_vimdir/"}"autoload/racer.vim"
+}
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..81700b023f84
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}