summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-04-28 18:34:13 -0500
committerLuis Martinez2021-04-28 18:34:13 -0500
commit5f76ff4e710f6fdbc666c0aacbbf884e6a4ee065 (patch)
tree48b63c8264657a91b172b9ce51e981b1cb7ff0b8
downloadaur-vim-splitjoin-git.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bf7cb7da724
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vim-splitjoin-git
+ pkgdesc = Vim plugin for switching between single-line and multi-line forms of code
+ pkgver = 1.0.0.r144.gf4773c0
+ pkgrel = 1
+ url = https://github.com/andrewradev/splitjoin.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = ruby
+ depends = vim-plugin-runtime
+ source = vim-splitjoin-git::git+https://github.com/andrewradev/splitjoin.vim
+ sha256sums = SKIP
+
+pkgname = vim-splitjoin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bba712f83b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-splitjoin-git
+pkgver=1.0.0.r144.gf4773c0
+pkgrel=1
+pkgdesc="Vim plugin for switching between single-line and multi-line forms of code"
+arch=('any')
+url="https://github.com/andrewradev/splitjoin.vim"
+license=('MIT')
+groups=('vim-plugins')
+depends=('ruby' 'vim-plugin-runtime')
+makedepends=('git')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc ftplugin plugin spec \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}