summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-07 16:55:26 -0500
committerLuis Martinez2021-05-07 16:59:00 -0500
commit62e986c6d42406d733d62d371d86c0b160e1e087 (patch)
tree86ddf3456d2cd4b457eadb3a5f19713004475c9c
downloadaur-vim-yoink-git.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04aa7d7b69ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-yoink-git
+ pkgdesc = Vim plugin that maintains a yank history to cycle between when pasting
+ pkgver = r91.440d939
+ pkgrel = 1
+ url = https://github.com/svermeulen/vim-yoink
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ optdepends = vim-cutlass
+ provides = vim-yoink
+ conflicts = vim-yoink
+ source = vim-yoink-git::git+https://github.com/svermeulen/vim-yoink
+ sha256sums = SKIP
+
+pkgname = vim-yoink-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6db020232ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-yoink-git
+pkgver=r91.440d939
+pkgrel=1
+pkgdesc="Vim plugin that maintains a yank history to cycle between when pasting"
+arch=('any')
+url="https://github.com/svermeulen/vim-yoink"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+makedepends=('git')
+optdepends=('vim-cutlass')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find autoload doc plugin \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 License.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}