summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2018-05-31 22:41:03 +0200
committerPiotr Rogoża2018-05-31 22:41:03 +0200
commit28381c17af6d9690dd680f8df0d877476c9c58e4 (patch)
treed55412ed3ff985cf030c24454184a8b5045b36f0
parentbbe4c6dc038adce21b0d23b1b780cc4e228e63dc (diff)
downloadaur-vimpdb.tar.gz
Fixed URLs
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c9fa97bea28..7d58dc749fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Tue May 3 21:42:58 UTC 2016
+# Thu May 31 20:40:44 UTC 2018
pkgbase = vimpdb
pkgdesc = A vim script for debugging python.
- pkgver = 0.beta
- pkgrel = 3
- url = http://code.google.com/p/vimpdb/
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/vim-scripts/VimPdb
arch = any
license = GPL3
depends = vim-runtime
depends = python
- source = http://vimpdb.googlecode.com/files/VimPdb.tar
- md5sums = ba777bb3f8f2dd991958f3011779c082
+ source = vimpdb-0.1.tar.gz::https://github.com/vim-scripts/VimPdb/archive/0.1.tar.gz
+ sha256sums = b56c1c320f71a76c9144aceb9b498755b67c3b90475c96d32864dcc9050d38ad
pkgname = vimpdb
diff --git a/PKGBUILD b/PKGBUILD
index c9279359b8e2..a0199021e836 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,30 @@
# Contributor: Tim Diels <limyreth[at]gmail.com>
pkgname=vimpdb
-pkgver='0.beta'
-pkgrel=4
+_pkgname=VimPdb
+pkgver='0.1'
+pkgrel=1
pkgdesc="A vim script for debugging python."
arch=(any)
-url="http://code.google.com/p/vimpdb/"
+# url="http://code.google.com/p/vimpdb/"
+url='https://github.com/vim-scripts/VimPdb'
license=('GPL3')
depends=(vim-runtime python)
-source=('http://vimpdb.googlecode.com/files/VimPdb.tar')
-md5sums=('ba777bb3f8f2dd991958f3011779c082')
+# source=('http://vimpdb.googlecode.com/files/VimPdb.tar')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vim-scripts/VimPdb/archive/$pkgver.tar.gz")
+sha256sums=('b56c1c320f71a76c9144aceb9b498755b67c3b90475c96d32864dcc9050d38ad')
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ sed 's/\r//' -i VimPdb.py plugin/VimPdb.vim doc/readme.txt
+}
package() {
- cd "$srcdir"
- sed 's/\r//' -i VimPdb.vim VimPdb.py
+ cd "$srcdir/$_pkgname-$pkgver"
install -Dm644 VimPdb.py \
"$pkgdir"/usr/share/vim/vimfiles/plugin/VimPdb.py
- install -Dm644 VimPdb.vim \
+ install -Dm644 plugin/VimPdb.vim \
"$pkgdir"/usr/share/vim/vimfiles/plugin/VimPdb.vim
- install -Dm644 readme.txt \
+ install -Dm644 doc/readme.txt \
"$pkgdir"/usr/share/doc/vimpdb/readme.txt
}