summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Old2016-02-14 04:17:19 -0800
committerMark Old2016-02-14 04:28:02 -0800
commit25e0ccaa00ea44a17c96c38e7180397a81a81969 (patch)
treec49cc2fc0f17c1e77a7c9ee3f6f1fbefd319548e
downloadaur-virtualhere-server-bin.tar.gz
add virtualhere-bin
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--virtualhere.service9
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9121a2f9f1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = virtualhere-server-bin
+ pkgdesc = VirtualHere USB Server for Linux Desktop
+ pkgver = 2.7.2
+ pkgrel = 1
+ url = https://www.virtualhere.com/usb_server_software
+ arch = i686
+ arch = x86_64
+ license = custom
+ optdepends = avahi: systemd unit support
+ provides = virtualhere
+ conflicts = virtualhere
+ source = virtualhere.service
+ md5sums = b317ad221de44c968d2368825e1682fe
+ source_i686 = https://www.virtualhere.com/sites/default/files/usbserver/vhusbdi386
+ md5sums_i686 = 60109f2782f31494017b217e595f8bdc
+ source_x86_64 = https://www.virtualhere.com/sites/default/files/usbserver/vhusbdx86_64
+ md5sums_x86_64 = ccdcd1a9fb5ca8c5bbbe34e175172568
+
+pkgname = virtualhere-server-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35cb257886b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mark Old <dlom234@gmail.com>
+
+pkgname=virtualhere-server-bin
+pkgver=2.7.2
+pkgrel=1
+pkgdesc="VirtualHere USB Server for Linux Desktop"
+arch=("i686" "x86_64")
+url="https://www.virtualhere.com/usb_server_software"
+license=("custom")
+optdepends=("avahi: systemd unit support")
+provides=("virtualhere")
+conflicts=("virtualhere")
+source=("virtualhere.service")
+source_i686=("https://www.virtualhere.com/sites/default/files/usbserver/vhusbdi386")
+source_x86_64=("https://www.virtualhere.com/sites/default/files/usbserver/vhusbdx86_64")
+md5sums=('b317ad221de44c968d2368825e1682fe')
+md5sums_i686=('60109f2782f31494017b217e595f8bdc')
+md5sums_x86_64=('ccdcd1a9fb5ca8c5bbbe34e175172568')
+
+build() {
+ mv vhusbd* vhusbd
+ chmod +x vhusbd
+ ./vhusbd -l > LICENSE
+}
+
+package() {
+ install -Dm755 vhusbd "${pkgdir}/usr/bin/vhusbd"
+ install -Dm644 virtualhere.service "${pkgdir}/etc/systemd/system/virtualhere.service"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/virtualhere.service b/virtualhere.service
new file mode 100644
index 000000000000..87a07ed56a0b
--- /dev/null
+++ b/virtualhere.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=VirtualHere USB Sharing
+Requires=avahi-daemon.service
+After=avahi-daemon.service
+[Service]
+ExecStart=/usr/bin/vhusbd
+Type=idle
+[Install]
+WantedBy=multi-user.target