summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2020-03-13 13:34:52 +0100
committerJean-Marc Lenoir2020-03-13 13:34:52 +0100
commit13aca7afd5c8ec0394448324ce5d60f95f84939d (patch)
tree0a46cb3e2871d40683d51b6e4917fdbfccc40d1b
parentc68579f7e0e14de796bcc0b4bc2f81b3ae961122 (diff)
downloadaur-13aca7afd5c8ec0394448324ce5d60f95f84939d.tar.gz
Compatibility with Linux 5.6
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD6
-rw-r--r--vmmon.patch27
-rw-r--r--vmnet.patch42
4 files changed, 75 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0c2c07e8da..39f1ec299f9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.1
- pkgrel = 3
+ pkgrel = 4
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
license = custom
makedepends = sqlite
- makedepends = python
- makedepends = unzip
- makedepends = uefitool-git
depends = dkms
depends = fuse2
depends = gtkmm3
@@ -61,9 +58,6 @@ pkgbase = vmware-workstation
source = Makefile
source = vmmon.patch
source = vmnet.patch
- source = VMware-Fusion-11.5.1-15018442.zip.tar::https://softwareupdate.vmware.com/cds/vmw-desktop/fusion/11.5.1/15018442/core/com.vmware.fusion.zip.tar
- source = unlocker-3.0.3.py::https://raw.githubusercontent.com/paolo-projects/unlocker/3.0.3/unlocker.py
- source = efi-unlocker-patch-1.0.0.txt
sha256sums = 490f8fe8d874c27601c155c1b2c0055ad0d4f14feb32fa9f18643659a147d3c6
sha256sums = 12e7b16abf8d7e858532edabb8868919c678063c566a6535855b194aac72d55e
sha256sums = da1698bf4e73ae466c1c7fc93891eba4b9c4581856649635e6532275dbfea141
@@ -84,11 +78,8 @@ pkgbase = vmware-workstation
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487
sha256sums = 6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d
- sha256sums = 1060b5d45caeda5119b220fab4e1ece398af34d75131139a5dc6f74ee06672c3
- sha256sums = 22d1f23c272dd2f7d4644dfffe051503cf62311886f67d57de3b7502615ceec1
- sha256sums = c36048a42c03988068aab7474b6c48ebc5054b8c6324cb93f009aec45aa899f0
- sha256sums = 1c27547dcf6fb2f436c96ee62ae8c7f5cfd14b40d8bbd35dc385e247c4fb7e0f
- sha256sums = 392c1effcdec516000e9f8ffc97f2586524d8953d3e7d6f2c5f93f2acd809d91
+ sha256sums = 9745f7628932fb74d7eec36cfd40fd268d1df4bbdcdb7e858726a25881905f06
+ sha256sums = 02baa12b97e58be0b820d1a6c5a120c5b523dea35456a7e0fd25a33cb75d30c4
pkgname = vmware-workstation
diff --git a/PKGBUILD b/PKGBUILD
index 7b762aa74856..df9542922b4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=vmware-workstation
pkgver=15.5.1
_buildver=15018445
_pkgver=${pkgver}_${_buildver}
-pkgrel=3
+pkgrel=4
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -116,8 +116,8 @@ sha256sums=(
'05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487'
'6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d'
- '1060b5d45caeda5119b220fab4e1ece398af34d75131139a5dc6f74ee06672c3'
- '22d1f23c272dd2f7d4644dfffe051503cf62311886f67d57de3b7502615ceec1'
+ '9745f7628932fb74d7eec36cfd40fd268d1df4bbdcdb7e858726a25881905f06'
+ '02baa12b97e58be0b820d1a6c5a120c5b523dea35456a7e0fd25a33cb75d30c4'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index f2e32d6d0270..1e8d0dbdff0f 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -12,3 +12,30 @@
# Header directory for the running kernel
ifdef LINUXINCLUDE
+From d74ce8b7b4e734140235f219ccd87eff3c6fedae Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Tue, 28 Jan 2020 07:16:30 +0100
+Subject: [PATCH] vmmon: replace ioremap_nocache() with ioremap()
+
+Mainline commit 4bdc0d676a64 ("remove ioremap_nocache and
+devm_ioremap_nocache") in v5.6-rc1 removes ioremap_nocache() and replaces
+all uses with ioremap(). As the commit message says that "ioremap has
+provided non-cached semantics by default since the Linux 2.6", do the same
+unconditionally.
+---
+ vmmon-only/linux/hostif.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 1e1be1a..6f51cad 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -2323,7 +2323,7 @@ SetVMAPICAddr(VMDriver *vm, // IN/OUT: driver state
+ volatile void *hostapic;
+
+ ASSERT_ON_COMPILE(APICR_SIZE <= PAGE_SIZE);
+- hostapic = (volatile void *) ioremap_nocache(ma, PAGE_SIZE);
++ hostapic = (volatile void *) ioremap(ma, PAGE_SIZE);
+ if (hostapic) {
+ if ((APIC_VERSIONREG(hostapic) & 0xF0) == 0x10) {
+ vm->hostAPIC.base = (volatile uint32 (*)[4]) hostapic;
diff --git a/vmnet.patch b/vmnet.patch
index 4e38598ab7ff..4bfb6c58c075 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -97,3 +97,45 @@ index d385088..aab9478 100644
}
}
+From d8e6c50b735f95af01ddfe8b9d2775ed68aaa625 Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Wed, 5 Feb 2020 07:29:14 +0100
+Subject: [PATCH] vmnet: convert from file_operations to proc_ops
+
+Manline commit 97a32539b956 ("proc: convert everything to "struct
+proc_ops"") in v5.6-rc1 introduces struct proc_ops and converts procfs file
+operations to it. Convert vmnet to do the same.
+
+As the same commit also introduces DEFINE_PROC_SHOW_ATTRIBUTE macro, we can
+use it for detection rather than rely on version comparison.
+---
+ vmnet-only/procfs.c | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/vmnet-only/procfs.c b/vmnet-only/procfs.c
+index 165cda0..58e1c4e 100644
+--- a/vmnet-only/procfs.c
++++ b/vmnet-only/procfs.c
+@@ -161,6 +161,14 @@ VNetProcOpen(struct inode *inode, // IN:
+ }
+
+ /* Our procfs callbacks. We only need to specialize open. */
++#ifdef DEFINE_PROC_SHOW_ATTRIBUTE
++static const struct proc_ops fops = {
++ .proc_open = VNetProcOpen,
++ .proc_read = seq_read,
++ .proc_lseek = seq_lseek,
++ .proc_release = single_release,
++};
++#else
+ static struct file_operations fops = {
+ .open = VNetProcOpen,
+ .read = seq_read,
+@@ -168,6 +176,7 @@ static struct file_operations fops = {
+ .release = single_release,
+ };
+ #endif
++#endif
+
+
+ /*