summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2020-09-06 18:34:43 +0200
committerJean-Marc Lenoir2020-09-06 18:34:43 +0200
commit1a4314214a25c17a106e6f923cb1dd85d08f30de (patch)
treece8f016f7f39b71fef8aa21f4949bced6a7c1d90
parent4e3b3542caf3d3b7fea7f791c965261efaae029b (diff)
downloadaur-1a4314214a25c17a106e6f923cb1dd85d08f30de.tar.gz
Compatibility with Linux 5.9-rc3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--vmmon.patch58
3 files changed, 62 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f4f60effdaf..54bd77a0a814 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 15.5.6
- pkgrel = 3
+ pkgrel = 4
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -78,7 +78,7 @@ pkgbase = vmware-workstation
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487
sha256sums = 6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d
- sha256sums = 3915c3a8a5e1b472cf2b2ecf06da04ab67e41d6a0cd8dd77a9a5296743453b18
+ sha256sums = 18b8258ec674c4a8c32114a4984baf1a00d62dbe750e877fd1e4dfa83bf51293
sha256sums = c1302d45008865537583b99d53ed0ea4a1d672227f190177fc63fc0c2f980151
pkgname = vmware-workstation
diff --git a/PKGBUILD b/PKGBUILD
index fab9edc21fd8..2e67a232c430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=vmware-workstation
pkgver=15.5.6
_buildver=16341506
_pkgver=${pkgver}_${_buildver}
-pkgrel=3
+pkgrel=4
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -116,7 +116,7 @@ sha256sums=(
'05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487'
'6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d'
- '3915c3a8a5e1b472cf2b2ecf06da04ab67e41d6a0cd8dd77a9a5296743453b18'
+ '18b8258ec674c4a8c32114a4984baf1a00d62dbe750e877fd1e4dfa83bf51293'
'c1302d45008865537583b99d53ed0ea4a1d672227f190177fc63fc0c2f980151'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index d435cee23c6e..b764fabbfa31 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -114,3 +114,61 @@ index ec6856a..4a7afb1 100644
if (res == sizeof value) {
res = MX_WAITNORMAL;
+From 1c4c297ddd28f430037efc972b77639f8bdc3ff1 Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Sat, 8 Aug 2020 22:53:50 +0200
+Subject: [PATCH] vmmon: handle change of vmstat slab counters to bytes
+
+Mainline commit d42f3245c7e2 ("mm: memcg: convert vmstat slab counters to
+bytes") in kernel 5.9-rc1 changed vmstat accounting of slab to byte
+counters. Unfortunately there doesn't seem to be any obvious way to check
+for this change except version check.
+---
+ vmmon-only/linux/hostif.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 9b179a8..107e11f 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -1756,8 +1756,11 @@ HostIF_EstimateLockedPageLimit(const VMDriver* vm, // IN
+ #else
+ lockedPages += global_page_state(NR_PAGETABLE);
+ #endif
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 9, 0)
++ /* NR_SLAB_* converted to byte counters in 5.9 */
++ lockedPages += global_node_page_state_pages(NR_SLAB_UNRECLAIMABLE_B);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 13, 0)
+ /* NR_SLAB_* moved from zone to node in 4.13. */
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 13, 0)
+ lockedPages += global_node_page_state(NR_SLAB_UNRECLAIMABLE);
+ #else
+ lockedPages += global_page_state(NR_SLAB_UNRECLAIMABLE);
+From 505c6b8967d2b14223e8ba482acffe020a93782f Mon Sep 17 00:00:00 2001
+From: Michal Kubecek <mkubecek@suse.cz>
+Date: Thu, 20 Aug 2020 10:39:56 +0200
+Subject: [PATCH] vmmon: include <asm/irq_vectors.h> explicitly
+
+After mainline commit 13c01139b171 ("x86/headers: Remove APIC headers from
+<asm/smp.h>") in 5.9-rc1, APIC headers are no longer included via
+<asm/smp.h> so that linux/hostif.c will use incorrect fallback definitions
+of SPURIOUS_APIC_VECTOR, POSTED_INTR_VECTOR and ERROR_APIC_VECTOR even if
+built against kernel where these are defined.
+
+Include <asm/irq_vectors.h> in linux/hostif.c explicitly to avoid that.
+---
+ vmmon-only/linux/hostif.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/vmmon-only/linux/hostif.c b/vmmon-only/linux/hostif.c
+index 107e11f..a42a034 100644
+--- a/vmmon-only/linux/hostif.c
++++ b/vmmon-only/linux/hostif.c
+@@ -49,6 +49,7 @@
+ #include <asm/page.h>
+ #include <asm/tlbflush.h>
+ #include <asm/uaccess.h>
++#include <asm/irq_vectors.h>
+ #include <linux/capability.h>
+ #include <linux/kthread.h>
+ #include <linux/wait.h>