summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2018-02-03 13:22:45 +0100
committerJean-Marc Lenoir2018-02-03 13:22:45 +0100
commitb30b0899395c3977857900ab89b47d3c2ee175e4 (patch)
treea24a3715368f36d2576ae4eca9928080c3dbc7ee
parentfe7e26e5a1757f64867a1fbce456d9f6f07e8bd3 (diff)
downloadaur-b30b0899395c3977857900ab89b47d3c2ee175e4.tar.gz
Cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--vmmon.patch126
-rw-r--r--vmnet.patch85
4 files changed, 6 insertions, 217 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f06a7c261f7..16043a1374c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 14.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -78,8 +78,8 @@ pkgbase = vmware-workstation
sha256sums = d7a9fbf39a0345ae2f14f7f389f30b1110f605d187e0c241e99bbb18993c250d
sha256sums = 05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487
sha256sums = 6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d
- sha256sums = 770dba99484b70eba0461441a8d122f183616c408a544a98499e443a6ee8fd05
- sha256sums = 11304179df067e1e75f8268dd218f27db5a502f52b79b642f64f464d06bc3f7b
+ sha256sums = 368b14c99a340b39f11af7534faa59da53837c3572c7f4e90544bc9434ec5029
+ sha256sums = c2e981d5d6a4fab4d33d4e3df394bdb597834fae14ebb535a40271c3f2677f0d
sha256sums = 0cdf4279a48ea915c796c0a230a3483dc9095bbd00fe4287889f0403ead93165
sha256sums = 9365045b6116f76bcc46436ad73439ee89893c7c5187cf9f3869c12bc2444b0a
sha256sums = b739b0c99fb20dc44838ce137e254773b7be051f327eb67fd8cb1342a3ecf344
diff --git a/PKGBUILD b/PKGBUILD
index 15c63a279a2d..bd7b307166b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=vmware-workstation
pkgver=14.1.1
_buildver=7528167
_pkgver=${pkgver}_${_buildver}
-pkgrel=1
+pkgrel=2
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -112,8 +112,8 @@ sha256sums=(
'05e26d8b21d190ebabb7f693998114d9d5991d9dfb71acb4d990293a65b6b487'
'6ce902b1dab8fc69be253abd8e79017011985eca850ff7acc7282f9ab668e35d'
- '770dba99484b70eba0461441a8d122f183616c408a544a98499e443a6ee8fd05'
- '11304179df067e1e75f8268dd218f27db5a502f52b79b642f64f464d06bc3f7b'
+ '368b14c99a340b39f11af7534faa59da53837c3572c7f4e90544bc9434ec5029'
+ 'c2e981d5d6a4fab4d33d4e3df394bdb597834fae14ebb535a40271c3f2677f0d'
)
options=(!strip emptydirs)
diff --git a/vmmon.patch b/vmmon.patch
index a8d36efcc07d..d69f3135cb1b 100644
--- a/vmmon.patch
+++ b/vmmon.patch
@@ -14,129 +14,3 @@ index de8162e..6124a71 100644
# Header directory for the running kernel
ifdef LINUXINCLUDE
-diff --git a/vmmon/Makefile.kernel b/vmmon/Makefile.kernel
-index bf805e0..9aac585 100644
---- a/vmmon/Makefile.kernel
-+++ b/vmmon/Makefile.kernel
-@@ -22,7 +22,7 @@ CC_OPTS += -DVMMON -DVMCORE
- INCLUDE := -I$(SRCROOT)/include -I$(SRCROOT)/common -I$(SRCROOT)/linux \
- -I$(SRCROOT)/vmcore
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
-
- obj-m += $(DRIVER).o
-
-diff --git a/vmmon/include/compat_module.h b/vmmon/include/compat_module.h
-index 2af7372..729aedc 100644
---- a/vmmon/include/compat_module.h
-+++ b/vmmon/include/compat_module.h
-@@ -80,4 +80,13 @@ static const char __module_cat(tag, __LINE__)[] \
- typedef int compat_mod_param_bool;
- #endif
-
-+/*
-+ * Linux kernel >= 4.3.0 does not return anything from misc_deregister
-+ */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 3, 0)
-+#define compat_misc_deregister(misc) misc_deregister(misc)
-+#else
-+#define compat_misc_deregister(misc) ({misc_deregister(misc);0;})
-+#endif
-+
- #endif /* __COMPAT_MODULE_H__ */
-diff --git a/vmmon/linux/driver.c b/vmmon/linux/driver.c
-index 87cf45b..5390a93 100644
---- a/vmmon/linux/driver.c
-+++ b/vmmon/linux/driver.c
-@@ -109,7 +109,15 @@ static struct vm_operations_struct vmuser_mops = {
- .fault = LinuxDriverFault
- };
-
--static struct file_operations vmuser_fops;
-+static struct file_operations vmuser_fops = {
-+ .owner = THIS_MODULE,
-+ .unlocked_ioctl = LinuxDriver_Ioctl,
-+ .compat_ioctl = LinuxDriver_Ioctl,
-+ .open = LinuxDriver_Open,
-+ .release = LinuxDriver_Close,
-+ .mmap = LinuxDriverMmap
-+};
-+
- static struct timer_list tscTimer;
- static Atomic_uint32 tsckHz;
- static VmTimeStart tsckHzStartTime;
-@@ -293,20 +301,6 @@ init_module(void)
- linuxState.fastClockRate = 0;
- linuxState.swapSize = VMMON_UNKNOWN_SWAP_SIZE;
-
-- /*
-- * Initialize the file_operations structure. Because this code is always
-- * compiled as a module, this is fine to do it here and not in a static
-- * initializer.
-- */
--
-- memset(&vmuser_fops, 0, sizeof vmuser_fops);
-- vmuser_fops.owner = THIS_MODULE;
-- vmuser_fops.unlocked_ioctl = LinuxDriver_Ioctl;
-- vmuser_fops.compat_ioctl = LinuxDriver_Ioctl;
-- vmuser_fops.open = LinuxDriver_Open;
-- vmuser_fops.release = LinuxDriver_Close;
-- vmuser_fops.mmap = LinuxDriverMmap;
--
- #ifdef VMX86_DEVEL
- devel_init_module();
- linuxState.minor = 0;
-@@ -368,7 +362,9 @@ cleanup_module(void)
- #ifdef VMX86_DEVEL
- unregister_chrdev(linuxState.major, linuxState.deviceName);
- #else
-- misc_deregister(&linuxState.misc);
-+ if (compat_misc_deregister(&linuxState.misc)) {
-+ Warning("Module %s: error unregistering\n", linuxState.deviceName);
-+ }
- #endif
-
- Log("Module %s: unloaded\n", linuxState.deviceName);
-@@ -981,7 +977,7 @@ LinuxDriverReadTSC(void *data, // OUT: TSC values
- *-----------------------------------------------------------------------------
- */
-
--__attribute__((always_inline)) static Bool
-+inline __attribute__((always_inline)) static Bool
- LinuxDriverSyncReadTSCs(uint64 *delta) // OUT: TSC max - TSC min
- {
- TSCDelta tscDelta;
-diff --git a/vmmon/linux/hostif.c b/vmmon/linux/hostif.c
-index fd32013..583d6da 100644
---- a/vmmon/linux/hostif.c
-+++ b/vmmon/linux/hostif.c
-@@ -36,6 +36,9 @@
-
- #include <linux/vmalloc.h>
- #include <linux/slab.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+#include <linux/sched/signal.h>
-+#endif
-
- #include <linux/preempt.h>
- #include <linux/poll.h>
-@@ -51,6 +54,7 @@
- #include <linux/capability.h>
- #include <linux/kthread.h>
- #include <linux/wait.h>
-+#include <asm/apic.h>
- #include <linux/hrtimer.h>
- #include <linux/signal.h>
- #include <linux/taskstats_kern.h> // For linux/sched/signal.h without version check
-@@ -115,6 +149,10 @@
- */
- #define LOCKED_PAGE_SLACK 10000
-
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(4, 8, 0)
-+#define NR_ANON_PAGES NR_ANON_MAPPED
-+#endif
-+
- static struct {
- Atomic_uint64 uptimeBase;
- VersionedAtomic version;
diff --git a/vmnet.patch b/vmnet.patch
index 906dfc87d8c4..d2c620705ca3 100644
--- a/vmnet.patch
+++ b/vmnet.patch
@@ -14,88 +14,3 @@ index 459846e..cd29652 100644
# Header directory for the running kernel
ifdef LINUXINCLUDE
-diff --git a/vmnet/Makefile.kernel b/vmnet/Makefile.kernel
-index 2d8e6f6..a14166b 100644
---- a/vmnet/Makefile.kernel
-+++ b/vmnet/Makefile.kernel
-@@ -19,7 +19,7 @@
-
- INCLUDE := -I$(SRCROOT)
-
--EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE)
-+EXTRA_CFLAGS := $(CC_OPTS) $(INCLUDE) $(LINUXINCLUDE)
- EXTRA_CFLAGS += $(call vm_check_build, $(SRCROOT)/netif_trans_update.c,-DVMW_NETIF_TRANS_UPDATE, )
-
- obj-m += $(DRIVER).o
-diff --git a/vmnet/driver.c b/vmnet/driver.c
-index 7e7ad99..5f508f6 100644
---- a/vmnet/driver.c
-+++ b/vmnet/driver.c
-@@ -137,7 +137,16 @@ static ssize_t VNetFileOpWrite(struct file *filp, const char *buf, size_t count
- static long VNetFileOpUnlockedIoctl(struct file * filp,
- unsigned int iocmd, unsigned long ioarg);
-
--static struct file_operations vnetFileOps;
-+static struct file_operations vnetFileOps = {
-+ .owner = THIS_MODULE,
-+ .read = VNetFileOpRead,
-+ .write = VNetFileOpWrite,
-+ .poll = VNetFileOpPoll,
-+ .unlocked_ioctl = VNetFileOpUnlockedIoctl,
-+ .compat_ioctl = VNetFileOpUnlockedIoctl,
-+ .open = VNetFileOpOpen,
-+ .release = VNetFileOpClose
-+};
-
- /*
- * Utility functions
-@@ -317,22 +326,6 @@ init_module(void)
- goto err_proto;
- }
-
-- /*
-- * Initialize the file_operations structure. Because this code is always
-- * compiled as a module, this is fine to do it here and not in a static
-- * initializer.
-- */
--
-- memset(&vnetFileOps, 0, sizeof vnetFileOps);
-- vnetFileOps.owner = THIS_MODULE;
-- vnetFileOps.read = VNetFileOpRead;
-- vnetFileOps.write = VNetFileOpWrite;
-- vnetFileOps.poll = VNetFileOpPoll;
-- vnetFileOps.unlocked_ioctl = VNetFileOpUnlockedIoctl;
-- vnetFileOps.compat_ioctl = VNetFileOpUnlockedIoctl;
-- vnetFileOps.open = VNetFileOpOpen;
-- vnetFileOps.release = VNetFileOpClose;
--
- retval = register_chrdev(VNET_MAJOR_NUMBER, "vmnet", &vnetFileOps);
- if (retval) {
- LOG(0, (KERN_NOTICE "/dev/vmnet: could not register major device %d\n",
-diff --git a/vmnet/vm_device_version.h b/vmnet/vm_device_version.h
-index e2cb477..3dd7097 100644
---- a/vmnet/vm_device_version.h
-+++ b/vmnet/vm_device_version.h
-@@ -53,7 +53,9 @@
- * VMware HD Audio codec
- * VMware HD Audio controller
- */
-+#ifndef PCI_VENDOR_ID_VMWARE
- #define PCI_VENDOR_ID_VMWARE 0x15AD
-+#endif
- #define PCI_DEVICE_ID_VMWARE_SVGA2 0x0405
- #define PCI_DEVICE_ID_VMWARE_SVGA 0x0710
- #define PCI_DEVICE_ID_VMWARE_VGA 0x0711
-diff --git a/vmnet/vmnetInt.h b/vmnet/vmnetInt.h
-index 0ee52ec..4e3b923 100644
---- a/vmnet/vmnetInt.h
-+++ b/vmnet/vmnetInt.h
-@@ -48,7 +48,7 @@
- extern struct proto vmnet_proto;
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0) || defined(sk_net_refcnt)
- # define compat_sk_alloc(_bri, _pri) sk_alloc(&init_net, \
-- PF_NETLINK, _pri, &vmnet_proto, 1)
-+ PF_NETLINK, _pri, &vmnet_proto, 0)
- #else
- # define compat_sk_alloc(_bri, _pri) sk_alloc(&init_net, \
- PF_NETLINK, _pri, &vmnet_proto)