summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Marc Lenoir2017-12-08 11:00:54 +0100
committerJean-Marc Lenoir2017-12-08 11:00:54 +0100
commitc0e61a9dd91bb72427f7f49ef59d2a1a3302c421 (patch)
tree8178446979651de852146ed41deb531b25e783c4
parent985036e23b2c9d2a87f25600269fb42d919cf9bd (diff)
downloadaur-c0e61a9dd91bb72427f7f49ef59d2a1a3302c421.tar.gz
Update unlocker file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--[-rwxr-xr-x]unlocker.py15
3 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67e9317bf33e..75044e19b335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vmware-workstation
pkgdesc = The industry standard for running multiple operating systems as virtual machines on a single Linux PC.
pkgver = 14.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.vmware.com/products/workstation-for-linux.html
install = vmware-workstation.install
arch = x86_64
@@ -78,7 +78,7 @@ pkgbase = vmware-workstation
sha256sums = 4f07320c1f9e71e649cf3e98ec107ba5521d52e50ad781ccc9dc1b61817342ae
sha256sums = 3aeee4ddad2e94e5dbd8da3f995ad3f887f35a241d82e8c64a22f792c159cc44
sha256sums = 2c6076d55da659723fb7b7871baaee95df3bdcd90e448955ed1ec53df6a1f2d0
- sha256sums = 522203ef0fa9cc621a67ba3df9d2070bbc21d9fdc85536ed10ebd85b99b83251
+ sha256sums = b739b0c99fb20dc44838ce137e254773b7be051f327eb67fd8cb1342a3ecf344
pkgname = vmware-workstation
diff --git a/PKGBUILD b/PKGBUILD
index b76cdf8fe829..0a39c1166eed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ pkgname=vmware-workstation
pkgver=14.0.0
_buildver=6661328
_pkgver=${pkgver}_${_buildver}
-pkgrel=2
+pkgrel=3
pkgdesc='The industry standard for running multiple operating systems as virtual machines on a single Linux PC.'
arch=(x86_64)
url='https://www.vmware.com/products/workstation-for-linux.html'
@@ -135,7 +135,7 @@ source+=(
sha256sums+=(
'3aeee4ddad2e94e5dbd8da3f995ad3f887f35a241d82e8c64a22f792c159cc44'
'2c6076d55da659723fb7b7871baaee95df3bdcd90e448955ed1ec53df6a1f2d0'
- '522203ef0fa9cc621a67ba3df9d2070bbc21d9fdc85536ed10ebd85b99b83251'
+ 'b739b0c99fb20dc44838ce137e254773b7be051f327eb67fd8cb1342a3ecf344'
)
_fusion_isoimages=(darwin darwinPre15)
diff --git a/unlocker.py b/unlocker.py
index e89fb9b997b0..94d29e0964d3 100755..100644
--- a/unlocker.py
+++ b/unlocker.py
@@ -44,9 +44,10 @@ Offset Length Struct Type Description
from __future__ import print_function
import codecs
import os
-import sys
+import six
import struct
import subprocess
+import sys
if sys.version_info < (2, 7):
sys.stderr.write('You need Python 2.7 or later\n')
@@ -302,12 +303,8 @@ def patchbase(name):
# Entry to search for in GOS table
# Should work for 12 & 14 of Workstation...
- darwin = (
- '\x10\x00\x00\x00\x10\x00\x00\x00'
- '\x02\x00\x00\x00\x00\x00\x00\x00'
- '\x00\x00\x00\x00\x00\x00\x00\x00'
- '\x00\x00\x00\x00\x00\x00\x00\x00'
- )
+ darwin = b'\x10\x00\x00\x00\x10\x00\x00\x00\x02\x00\x00\x00\x00\x00\x00\x00' \
+ '\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00'
# Read file into string variable
base = f.read()
@@ -416,9 +413,9 @@ def main():
if vmwarebase != '':
patchbase(vmwarebase)
else:
- print('Patching vmwarebase is not required on this system')
+ pass
- # Now using sed in the local.sh script
+ # Patch libvmkctl to return Apple SMC present
if osname == 'vmkernel':
# Patch ESXi 6.0 and 6.5 32 bit .so
patchvmkctl(libvmkctl32)