summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Flament2017-08-26 15:27:08 +0200
committerDamien Flament2017-08-26 15:29:29 +0200
commit0f77acf61f8abc9ca2c64ffef0476dfb0db1e854 (patch)
tree18b756910f43e57972eff60a2d06242824e9ed5b
parent8a6275ba21e408b87d342539b862913ce2c355e5 (diff)
downloadaur-0f77acf61f8abc9ca2c64ffef0476dfb0db1e854.tar.gz
Added Desktop file and icon
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
-rw-r--r--voxelshop.desktop10
3 files changed, 43 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52948b9fdc57..c782d396d4eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = voxelshop
pkgdesc = An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.
pkgver = 1.8.11
- pkgrel = 1
+ pkgrel = 2
url = https://blackflux.com/node/11
arch = any
license = Apache
- depends = java-runtime=8
+ depends = java-runtime>=8
depends = bash
noextract = voxelshop-1.8.11.zip
source = voxelshop
+ source = voxelshop.desktop
+ source = voxelshop.png::https://raw.githubusercontent.com/simlu/voxelshop/1.8.11/resource/img/icons/application/logo.png
source = voxelshop-1.8.11.zip::https://github.com/simlu/voxelshop/releases/download/1.8.11/voxelshop-bin.zip
sha256sums = 1f1535bd452294f1f8261bdd0432e0100e43f41650ff25aa67d92cf786be7df8
+ sha256sums = 510d8a61c162af0cfed35548fbd5c5a7351ac9735ab27ff7da7a7dbb44346a15
+ sha256sums = 9117799a571cd29a0402bc43a58c2d3b7caf590a2bcf530347ab3f709e1ee25b
sha256sums = 913cc42e789f5914ab894ed6157be94bcedc5d5cb528481bf6e167b0e3d70354
pkgname = voxelshop
diff --git a/PKGBUILD b/PKGBUILD
index fe01ad945df6..6784cbea0abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,16 @@
# Maintainer: Andrew Dunai <andrew@dun.ai>
# Contributor: Damien Flament <damien.flament@gmx.com>
+
pkgname=voxelshop
pkgver=1.8.11
-pkgrel=1
+pkgrel=2
pkgdesc='An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.'
+
+_application_name="VoxelShop"
+_generic_name="Voxel Editor"
+_source_filename="${pkgname}-${pkgver}.zip"
+_icon_filename="${pkgname}.png"
+
url=https://blackflux.com/node/11
license=('Apache')
groups=()
@@ -17,11 +24,14 @@ backup=()
options=()
install=
changelog=
-_source_filename="${pkgname}-${pkgver}.zip"
-source=('voxelshop'
+source=("${pkgname}"
+ "${pkgname}.desktop"
+ "${_icon_filename}::https://raw.githubusercontent.com/simlu/${pkgname}/${pkgver}/resource/img/icons/application/logo.png"
"${_source_filename}::https://github.com/simlu/${pkgname}/releases/download/${pkgver}/${pkgname}-bin.zip")
noextract=("${_source_filename}")
sha256sums=('1f1535bd452294f1f8261bdd0432e0100e43f41650ff25aa67d92cf786be7df8'
+ '510d8a61c162af0cfed35548fbd5c5a7351ac9735ab27ff7da7a7dbb44346a15'
+ '9117799a571cd29a0402bc43a58c2d3b7caf590a2bcf530347ab3f709e1ee25b'
'913cc42e789f5914ab894ed6157be94bcedc5d5cb528481bf6e167b0e3d70354')
arch=('any')
@@ -30,9 +40,16 @@ prepare() {
msg2 "Generating startup script..."
sed -i "s/{{pkgname}}/${pkgname}/g" "${pkgname}"
+ msg2 "Generating Desktop file..."
+ sed -i -e "s/{{pkgname}}/${pkgname}/g" \
+ -e "s/{{pkgdesc}}/${pkgdesc}/g" \
+ -e "s/{{_application_name}}/${_application_name}/g" \
+ -e "s/{{_generic_name}}/${_generic_name}/g" \
+ "${pkgname}.desktop"
+
# Unzip the sources. This is usually done automatically by makepkg. But the
# extracted directory name conflicts with the startup script name.
- msg2 "Extracting sources..."
+ msg2 "Extracting sources manually..."
if [[ ! -d "${pkgname}-${pkgver}" ]]
then
mkdir "${pkgname}-${pkgver}"
@@ -46,7 +63,13 @@ prepare() {
package() {
msg2 "Installing startup script..."
install -D -t "${pkgdir}/usr/bin" "${pkgname}"
+
+ msg2 "Installing Desktop file..."
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "${pkgname}.desktop"
+ msg2 "Installing the icon..."
+ install -Dm644 -t "${pkgdir}/usr/share/pixmaps" "${_icon_filename}"
+
msg2 "Installing the jars..."
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/voxelshop.desktop b/voxelshop.desktop
new file mode 100644
index 000000000000..ffd35197bc85
--- /dev/null
+++ b/voxelshop.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name={{_application_name}}
+GenericName={{_generic_name}}
+Comment={{pkgdesc}}
+Exec=/usr/bin/{{pkgname}}
+Icon={{pkgname}}
+Terminal=false
+Categories=Graphics;3DGraphics;Java;