summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Dunai2016-08-03 07:46:25 -0400
committerAndrew Dunai2016-08-03 07:46:25 -0400
commit5dd714ed964c0189cb73533213d0a660b3507cac (patch)
treee1cb2d18d633eac9c9302536de9e64a0b5921ed1
downloadaur-5dd714ed964c0189cb73533213d0a660b3507cac.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
-rwxr-xr-xvoxelshop4
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26a4ca7807b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Wed Apr 22 17:22:11 UTC 2015
+pkgbase = voxelshop
+ pkgdesc = VoxelShop is an extremely intuitive and powerful cross-platform software to modify and create voxel objects was designed from the ground up in close collaboration with artists.
+ pkgver = 1.7.01
+ pkgrel = 1
+ url = http://blackflux.com/node/11
+ arch = i686
+ arch = x86_64
+ license = Free
+ depends = java-runtime-common
+ source = voxelshop
+ source = http://blackflux.com/software/vs/download/?file=VoxelShop.zip
+ sha256sums = 69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa
+ sha256sums = 86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3
+
+pkgname = voxelshop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..748079dfff8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andrew Dunai <andrew@dun.ai>
+pkgname=voxelshop
+_pkgname_upper=VoxelShop
+pkgver=1.7.01
+pkgrel=1
+pkgdesc='VoxelShop is an extremely intuitive and powerful cross-platform software to modify and create voxel objects was designed from the ground up in close collaboration with artists.'
+url=http://blackflux.com/node/11
+license=('Free')
+groups=()
+depends=('java-runtime-common')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+ 'voxelshop'
+ 'VoxelShop.zip::http://blackflux.com/software/vs/download/?file=VoxelShop.zip'
+)
+noextract=()
+sha256sums=('69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa'
+ '86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3')
+arch=('i686' 'x86_64')
+
+package() {
+ mkdir -p ${pkgdir}/opt/
+ chmod 755 ${srcdir}/${_pkgname_upper}/*.sh
+ cp -r ${srcdir}/${_pkgname_upper} ${pkgdir}/opt/${pkgname}
+ chown -R $USER:users ${pkgdir}/opt/${pkgname}
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ ln -s ${pkgname} ${pkgdir}/usr/bin/${_pkgname_upper}
+}
diff --git a/voxelshop b/voxelshop
new file mode 100755
index 000000000000..3d0d96f4bba2
--- /dev/null
+++ b/voxelshop
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/voxelshop/
+./start-linux.sh