summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ellison2018-11-01 18:34:28 -0400
committerMatt Ellison2018-11-01 18:34:28 -0400
commit80e17a356d0b632cad9674dee07a2aba01e43e12 (patch)
tree1f2fee9d1a1f612da3cd8f9d646252ed1892b0ea
parent4ba194d4a6ad4914f31f9987ba81c3e5fab759dc (diff)
downloadaur-vpp.tar.gz
v18.10-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--nasmlib.patch6
3 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8aedac41726..708bb9334466 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = vpp
pkgdesc = FD.io Vector Packet Processing
- pkgver = 18.07.1
+ pkgver = 18.10
pkgrel = 1
url = https://fd.io/
arch = x86_64
license = Apache
+ makedepends = ninja
makedepends = patchelf
depends = glibc
depends = gcc-libs
@@ -14,11 +15,12 @@ pkgbase = vpp
depends = python2
depends = python2-ply
provides = vpp
- source = git+https://gerrit.fd.io/r/vpp#tag=v18.07.1
+ provides = dpdk
+ source = git+https://gerrit.fd.io/r/vpp#tag=v18.10
source = nasmlib.patch
source = vpp.sysusers
sha256sums = SKIP
- sha256sums = 832ce99c89109f800eeec911a6a6a7a695cea140d3fe643ddfb32d8a5834325f
+ sha256sums = 38f4daaaba5b2e9b3f624f08b963725e004d8d3b27385f596f45f135f88748e7
sha256sums = 5e8a0d05f715816689479c9050bf0505c7a64252d53d16c5d5df5f4787e4295b
pkgname = vpp
diff --git a/PKGBUILD b/PKGBUILD
index e68811c31b0b..6f0006e4fb53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Matthew Ellison <matt(at)arroyo(dot)io>
pkgname=vpp
-pkgver=18.07.1
+pkgver=18.10
pkgrel=1
pkgdesc="FD.io Vector Packet Processing"
arch=('x86_64')
url="https://fd.io/"
license=('Apache')
depends=('glibc' 'gcc-libs' 'openssl' 'mbedtls' 'numactl' 'python2' 'python2-ply')
-makedepends=('patchelf')
-provides=("${pkgname}")
+makedepends=('ninja' 'patchelf')
+provides=("${pkgname}" 'dpdk')
source=("git+https://gerrit.fd.io/r/vpp#tag=v${pkgver}"
"nasmlib.patch"
"vpp.sysusers")
sha256sums=('SKIP'
- '832ce99c89109f800eeec911a6a6a7a695cea140d3fe643ddfb32d8a5834325f'
+ '38f4daaaba5b2e9b3f624f08b963725e004d8d3b27385f596f45f135f88748e7'
'5e8a0d05f715816689479c9050bf0505c7a64252d53d16c5d5df5f4787e4295b')
prepare() {
@@ -35,17 +35,13 @@ prepare() {
build() {
# (1) Build Release
- # Currently install into "fake" directory
- # since there is no clean install target.
- cd ${srcdir}/${pkgname}
- mkdir -p ${srcdir}/build
- make DESTDIR=${srcdir}/build build-release
+ make build-release
}
package() {
# (1) Find the Actual Install Root
# Currently DESTDIR installs the ABSOLUTE path.
- root=$(dirname $(dirname $(find ${srcdir}/build -iname vpp -type f -executable)))
+ root=$(dirname $(dirname $(find ${srcdir}/vpp/build-root/install-vpp-native -iname vpp -type f -executable)))
cd $root
# (2) Install VPP
@@ -53,7 +49,7 @@ package() {
mkdir ${pkgdir}/usr
cp -pr bin ${pkgdir}/usr/bin
cp -pr include ${pkgdir}/usr/include
- cp -pr lib64 ${pkgdir}/usr/lib
+ cp -pr lib ${pkgdir}/usr/lib
cp -pr share ${pkgdir}/usr/share
# (3) Fix RPATH
diff --git a/nasmlib.patch b/nasmlib.patch
index d8b81c255e7a..45843afc0356 100644
--- a/nasmlib.patch
+++ b/nasmlib.patch
@@ -1,5 +1,5 @@
---- ./build-root/build-vpp-native/dpdk/nasm-2.13.01/include/nasmlib.h.orig 2018-09-25 12:47:52.806000016 -0400
-+++ ./build-root/build-vpp-native/dpdk/nasm-2.13.01/include/nasmlib.h 2018-09-25 12:48:25.503037231 -0400
+--- ./build-root/build-vpp-native/external/src-nasm/include/nasmlib.h.orig 2018-11-01 18:00:15.456221458 -0400
++++ ./build-root/build-vpp-native/external/src-nasm/include/nasmlib.h 2018-11-01 18:02:15.617516579 -0400
@@ -188,10 +188,8 @@
int64_t readstrnum(char *str, int length, bool *warn);
@@ -7,7 +7,7 @@
- * seg_init: Initialise the segment-number allocator.
* seg_alloc: allocate a hitherto unused segment number.
*/
--void pure_func seg_init(void);
+-int32_t pure_func seg_init(void);
int32_t pure_func seg_alloc(void);
/*