summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIcelk2022-08-16 20:06:49 +0200
committerIcelk2022-08-16 20:06:49 +0200
commit0f54a6b8676c9a488c8a0d9748e8634cb162f7b7 (patch)
treebe30dce7fad33ee4a80f0781f6dadf28c9249863
parent8ea191d0e94e8605ae7d0805e70deada350fd6f9 (diff)
downloadaur-0f54a6b8676c9a488c8a0d9748e8634cb162f7b7.tar.gz
Fix downloads. This is highly temporary (will be changed next release with linux builds.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1681689829e..e8f1c999f108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vscodium-bin
pkgdesc = Binary releases of VS Code without MS branding/telemetry/licensing.
pkgver = 1.70.1.22228
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/VSCodium/vscodium
arch = x86_64
arch = aarch64
@@ -28,9 +28,9 @@ pkgbase = vscodium-bin
source = vscodium-bin-uri-handler.desktop
sha256sums = a665ef6e2a1711df2552d7ae49fd7f30f7a2d7e0dea71c7c5f4c90764d8c37ce
sha256sums = fd6b46c021e4f0b75d27fcf67481019dbbaa7059ea186437a47a6b6ae8bb574f
- source_x86_64 = https://github.com/VSCodium/vscodium/releases/download/1.70.1.22228/VSCodium-linux-x64-1.70.1.22228.tar.gz
+ source_x86_64 = https://github.com/VSCodium/vscodium/releases/download/1.70.1/VSCodium-linux-x64-1.70.1.tar.gz
sha256sums_x86_64 = 4fd509dd190887a874dae2b2d9ebbdbcbd1b0248fcecec522a49683944774829
- source_aarch64 = https://github.com/VSCodium/vscodium/releases/download/1.70.1.22228/VSCodium-linux-arm64-1.70.1.22228.tar.gz
+ source_aarch64 = https://github.com/VSCodium/vscodium/releases/download/1.70.1/VSCodium-linux-arm64-1.70.1.tar.gz
sha256sums_aarch64 = c3379f4829eb67e1524fe581d6c143efcd370809da414fff85194303e11adcb9
pkgname = vscodium-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1f41f1af7e4a..9df57c72181f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,9 @@
pkgname=vscodium-bin
_pkgname=VSCodium
pkgver=1.70.1.22228
-pkgrel=1
+# hack for the .xxxxx version scheme.
+_pkgver=${pkgver::-6}
+pkgrel=2
pkgdesc="Binary releases of VS Code without MS branding/telemetry/licensing."
arch=('x86_64' 'aarch64')
url="https://github.com/VSCodium/vscodium"
@@ -30,8 +32,8 @@ sha256sums_x86_64=('4fd509dd190887a874dae2b2d9ebbdbcbd1b0248fcecec522a4968394477
sha256sums_aarch64=('c3379f4829eb67e1524fe581d6c143efcd370809da414fff85194303e11adcb9')
source=('vscodium-bin.desktop'
'vscodium-bin-uri-handler.desktop')
-source_x86_64=("https://github.com/VSCodium/vscodium/releases/download/${pkgver}/${_pkgname}-linux-x64-${pkgver}.tar.gz")
-source_aarch64=("https://github.com/VSCodium/vscodium/releases/download/${pkgver}/${_pkgname}-linux-arm64-${pkgver}.tar.gz")
+source_x86_64=("https://github.com/VSCodium/vscodium/releases/download/${_pkgver}/${_pkgname}-linux-x64-${_pkgver}.tar.gz")
+source_aarch64=("https://github.com/VSCodium/vscodium/releases/download/${_pkgver}/${_pkgname}-linux-arm64-${_pkgver}.tar.gz")
shopt -s extglob
@@ -39,7 +41,7 @@ package() {
install -d -m755 ${pkgdir}/opt/${pkgname}
install -d -m755 ${pkgdir}/usr/bin
install -d -m755 ${pkgdir}/usr/share/{applications,pixmaps}
- cp -r ${srcdir}/!(vscodium-bin?(-uri-handler).desktop|${_pkgname}-linux-@(x|arm)64-${pkgver}.tar.gz) ${pkgdir}/opt/${pkgname}
+ cp -r ${srcdir}/!(vscodium-bin?(-uri-handler).desktop|${_pkgname}-linux-@(x|arm)64-${_pkgver}.tar.gz) ${pkgdir}/opt/${pkgname}
ln -s /opt/${pkgname}/bin/codium ${pkgdir}/usr/bin/codium
ln -s /opt/${pkgname}/bin/codium ${pkgdir}/usr/bin/vscodium
install -D -m644 ${srcdir}/vscodium-bin.desktop ${pkgdir}/usr/share/applications/codium.desktop