summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlague Doctor2019-06-11 20:50:18 +1000
committerPlague Doctor2019-06-11 20:50:18 +1000
commit3b6b32de4873e723846bc65c119eef9aa92be92d (patch)
tree77a7ac44e4a94c09bdb287730d454ec4565a2109
parent3653cd7d4b55a2912107a7b5dc565a407d7fc37e (diff)
downloadaur-3b6b32de4873e723846bc65c119eef9aa92be92d.tar.gz
Fix symlinks
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--vscodium-bin.desktop4
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 847bae1f1b19..50ac94de6e6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vscodium-bin
pkgdesc = Binary releases of VS Code without MS branding/telemetry/licensing.
pkgver = 1.35.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/VSCodium/vscodium
arch = x86_64
license = MIT
@@ -20,10 +20,10 @@ pkgbase = vscodium-bin
optdepends = gvfs: For move to trash functionality
optdepends = libdbusmenu-glib: For KDE global menu
provides = code
- noextract = vscodium-bin-1.35.0-1.tar.gz
+ noextract = vscodium-bin-1.35.0-2.tar.gz
source = vscodium-bin.desktop
- source = vscodium-bin-1.35.0-1.tar.gz::https://github.com/VSCodium/vscodium/releases/download/1.35.0/VSCodium-linux-x64-1.35.0.tar.gz
- sha256sums = 44c07450999d260672edfd34215fde0ca11829a38f89592f4d1f035e1dd5012a
+ source = vscodium-bin-1.35.0-2.tar.gz::https://github.com/VSCodium/vscodium/releases/download/1.35.0/VSCodium-linux-x64-1.35.0.tar.gz
+ sha256sums = 7275ddd94fc356374ca2a883bd1210863a8f2e5ad2f3e6194a42240941d119a4
sha256sums = ee95f23cc1526ba1444e9df392dee7ce7da1250c315ff0c04392c92ad941128b
pkgname = vscodium-bin
diff --git a/PKGBUILD b/PKGBUILD
index b5533402e966..33657f71d4c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vscodium-bin
pkgver=1.35.0
-pkgrel=1
+pkgrel=2
pkgdesc="Binary releases of VS Code without MS branding/telemetry/licensing."
arch=('x86_64')
url="https://github.com/VSCodium/vscodium"
@@ -21,7 +21,7 @@ source=(
${pkgname}-${pkgver}-${pkgrel}.tar.gz::${url}/releases/download/${pkgver}/VSCodium-linux-x64-${pkgver}.tar.gz
)
noextract=("${pkgname}-${pkgver}-${pkgrel}.tar.gz")
-sha256sums=('44c07450999d260672edfd34215fde0ca11829a38f89592f4d1f035e1dd5012a'
+sha256sums=('7275ddd94fc356374ca2a883bd1210863a8f2e5ad2f3e6194a42240941d119a4'
'ee95f23cc1526ba1444e9df392dee7ce7da1250c315ff0c04392c92ad941128b')
prepare() {
@@ -33,7 +33,8 @@ package() {
install -d -m755 ${pkgdir}/usr/bin
install -d -m755 ${pkgdir}/usr/share/{${pkgname},applications,pixmaps}
cp -r ${srcdir}/${pkgname} ${pkgdir}/usr/share
- ln -s /usr/share/${pkgname}/bin/vscodium ${pkgdir}/usr/bin/vscodium
+ ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/codium
+ ln -s /usr/share/${pkgname}/bin/codium ${pkgdir}/usr/bin/vscodium
install -D -m644 vscodium-bin.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
install -D -m644 ${srcdir}/${pkgname}/resources/app/resources/linux/code.png \
${pkgdir}/usr/share/pixmaps/vscodium.png
diff --git a/vscodium-bin.desktop b/vscodium-bin.desktop
index 93096288ef47..200ce9ecabfb 100644
--- a/vscodium-bin.desktop
+++ b/vscodium-bin.desktop
@@ -2,7 +2,7 @@
Name=VSCodium
Comment=Code Editing. Redefined.
GenericName=Text Editor
-Exec=/usr/share/vscodium-bin/vscodium --unity-launch %F
+Exec=/usr/share/vscodium-bin/codium --unity-launch %F
Icon=vscodium
Type=Application
StartupNotify=true
@@ -14,5 +14,5 @@ Keywords=vscode;
[Desktop Action new-empty-window]
Name=New Empty Window
-Exec=/usr/share/vscodium-bin/vscodium --new-window %F
+Exec=/usr/share/vscodium-bin/codium --new-window %F
Icon=vscodium