summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-04-05 15:42:09 -0700
committerLlewelyn Trahaearn2016-04-05 15:42:09 -0700
commit89f3646985c4d9ce28cfdadb2d0b930c1b2ccc00 (patch)
treee4a7778fdcc3fa567297825903a5d2f834389050
parent3c86f3fa1f8bef7bfce094a58eb9a547f7ad32e0 (diff)
downloadaur-89f3646985c4d9ce28cfdadb2d0b930c1b2ccc00.tar.gz
Migrate to the glfw3 branch.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16aef388d515..a8b2ccafe91b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 27 17:50:28 UTC 2016
+# Tue Apr 5 22:41:19 UTC 2016
pkgbase = vsxu-git
pkgdesc = A free to use program that lets you create and perform real-time audio visual presets.
- pkgver = 0.5.1.r0.g98bf097
+ pkgver = 0.5.1.r50.g4a34b08
pkgrel = 1
url = http://www.vsxu.com/
install = vsxu-git.install
@@ -17,7 +17,7 @@ pkgbase = vsxu-git
makedepends = jack
depends = desktop-file-utils
depends = glew
- depends = glfw2
+ depends = glfw
depends = libpng12
depends = opencv
depends = xdg-utils
@@ -27,6 +27,8 @@ pkgbase = vsxu-git
provides = vsxu
conflicts = vsxu
source = vsxu-git::git+https://github.com/vovoid/vsxu.git
+ source = cal3d::git+https://github.com/vovoid/cal3d.git
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = vsxu-git
diff --git a/PKGBUILD b/PKGBUILD
index 611b44f27b74..d7d84d249c8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: SpepS <dreamspepser at yahoo dot it>
pkgname=vsxu-git
-pkgver=0.5.1.r0.g98bf097
+pkgver=0.5.1.r50.g4a34b08
pkgrel=1
pkgdesc="A free to use program that lets you create and perform real-time audio visual presets."
arch=('i686' 'x86_64')
url="http://www.vsxu.com/"
license=('GPL' 'custom')
-depends=('desktop-file-utils' 'glew' 'glfw2' 'libpng12' 'opencv' 'xdg-utils')
+depends=('desktop-file-utils' 'glew' 'glfw' 'libpng12' 'opencv' 'xdg-utils')
makedepends=('alsa-lib' 'cmake' 'git' 'pulseaudio' 'jack')
optdepends=(
'alsa-lib: ALSA support.'
@@ -18,9 +18,11 @@ optdepends=(
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install=${pkgname}.install
-source=("${pkgname}::git+https://github.com/vovoid/vsxu.git")
-sha512sums=('SKIP')
-_branch=master
+source=("${pkgname}::git+https://github.com/vovoid/vsxu.git"
+ "cal3d::git+https://github.com/vovoid/cal3d.git")
+sha512sums=('SKIP'
+ 'SKIP')
+_branch=glfw3
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -35,12 +37,14 @@ prepare() {
cd "${pkgname}"
[[ -d build ]] || mkdir build
git checkout ${_branch}
+ git submodule init
+ git config submodule.plugins/src/mesh.importers/cal3d.url "${srcdir}/cal3d"
+ git submodule update plugins/src/mesh.importers/cal3d
}
build() {
cd "${pkgname}/build"
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DGLFW_LIBRARY=/usr/lib/libglfw2.so \
-DPNG_LIBRARY=/usr/lib/libpng12.so \
-DPNG_PNG_INCLUDE_DIR=/usr/include/libpng12
make