summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Hüsers2015-09-23 00:41:10 +0200
committerManuel Hüsers2015-09-23 00:41:10 +0200
commit8d060375e72875f1ded9028eb1a345e38570e66b (patch)
tree1f2818e53b43f9b00fc233fd65281981d510ebff
parent61181abdfccaafe897a0625e4bbac86b2df931ac (diff)
downloadaur-8d060375e72875f1ded9028eb1a345e38570e66b.tar.gz
Version 0.42.0
-rw-r--r--.SRCINFO16
-rw-r--r--0001-widget-Only-show-the-cursor-on-motion-if-moved.patch39
-rw-r--r--PKGBUILD13
-rw-r--r--vte291-command-notify.patch (renamed from vte-command-notify.patch)283
4 files changed, 231 insertions, 120 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 868fe5b0d7da..184e89858aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vte3-notification
pkgdesc = Virtual Terminal Emulator widget for use with GTK3
- pkgver = 0.41.90
+ pkgver = 0.42.0
pkgrel = 1
url = http://www.gnome.org
arch = i686
@@ -11,23 +11,25 @@ pkgbase = vte3-notification
makedepends = gtk3
makedepends = vala
makedepends = gperf
- source = https://download.gnome.org/sources/vte/0.41/vte-0.41.90.tar.xz
+ source = https://download.gnome.org/sources/vte/0.42/vte-0.42.0.tar.xz
+ source = 0001-widget-Only-show-the-cursor-on-motion-if-moved.patch
source = add-zsh-notfication-support.patch
- source = vte-command-notify.patch
- sha256sums = f1ee9d27962c97414e09dfeb886efe437006f557b068f39330e0ff3a2c301516
+ source = vte291-command-notify.patch
+ sha256sums = 2168f79d2043cbbe6d4375d01e54cebda71bb6f5d9dc8ad658b9a1dc1052de04
+ sha256sums = 4379593bdddbe7ebcf6efd808f6334ce86334426d07f7ad777a3aa2d1ee2c50d
sha256sums = 150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a
- sha256sums = d88e870c6f2232e5a06ae4b45d6308aae5fa564f5b82dca460a743c71781eba4
+ sha256sums = d7dce79b0950b35052f60cacc7ce835a6111a4f3e833a5406590ff141fb41825
pkgname = vte3-notification
depends = gtk3
depends = vte-notification-common
- provides = vte3=0.41.90
+ provides = vte3=0.42.0
conflicts = vte3
options = !emptydirs
pkgname = vte-notification-common
pkgdesc = Common files used by vte and vte3
depends = glibc
- provides = vte-common=0.41.90
+ provides = vte-common=0.42.0
conflicts = vte-common
diff --git a/0001-widget-Only-show-the-cursor-on-motion-if-moved.patch b/0001-widget-Only-show-the-cursor-on-motion-if-moved.patch
new file mode 100644
index 000000000000..5935eae80ea9
--- /dev/null
+++ b/0001-widget-Only-show-the-cursor-on-motion-if-moved.patch
@@ -0,0 +1,39 @@
+From f54c7051b61c0ab935fe64e6a69503ce3430bb9b Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Mon, 14 Sep 2015 14:22:35 +0200
+Subject: [PATCH] widget: Only show the cursor on motion if moved
+
+Some devices, like Wacom tablets, will emit mouse motion
+events even when the mouse doesn't move on the tablet. This
+means that the mouse cursor will show up on the screen very shortly
+after hiding.
+
+We now check the motion event against the last location of the
+mouse cursor to avoid this behaviour.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=688456
+---
+ src/vte.cc | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/vte.cc b/src/vte.cc
+index 55e57dd3270a..1ec07a945812 100644
+--- a/src/vte.cc
++++ b/src/vte.cc
+@@ -7321,8 +7321,11 @@ vte_terminal_motion_notify(GtkWidget *widget, GdkEventMotion *event)
+ } else {
+ /* Hilite any matches. */
+ vte_terminal_match_hilite(terminal, x, y);
+- /* Show the cursor. */
+- _vte_terminal_set_pointer_visible(terminal, TRUE);
++ /* Show the cursor if we moved. */
++ if (event->type != GDK_MOTION_NOTIFY ||
++ x != terminal->pvt->mouse_last_x ||
++ y != terminal->pvt->mouse_last_y)
++ _vte_terminal_set_pointer_visible(terminal, TRUE);
+ }
+
+ switch (event->type) {
+--
+2.1.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 125c39f4d5e9..71459a02176d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=vte3-notification
pkgname=(vte3-notification vte-notification-common)
-pkgver=0.41.90
+pkgver=0.42.0
pkgrel=1
pkgdesc="Virtual Terminal Emulator widget for use with GTK3"
arch=('i686' 'x86_64')
@@ -12,16 +12,19 @@ license=('LGPL')
makedepends=('intltool' 'gobject-introspection' 'gtk3' 'vala' 'gperf')
url="http://www.gnome.org"
source=("https://download.gnome.org/sources/vte/${pkgver::4}/vte-${pkgver}.tar.xz"
+ '0001-widget-Only-show-the-cursor-on-motion-if-moved.patch'
'add-zsh-notfication-support.patch'
- 'vte-command-notify.patch')
-sha256sums=('f1ee9d27962c97414e09dfeb886efe437006f557b068f39330e0ff3a2c301516'
+ 'vte291-command-notify.patch')
+sha256sums=('2168f79d2043cbbe6d4375d01e54cebda71bb6f5d9dc8ad658b9a1dc1052de04'
+ '4379593bdddbe7ebcf6efd808f6334ce86334426d07f7ad777a3aa2d1ee2c50d'
'150a151404ca565f70259044661b2ef5cda43142ca677e7da324614eef8cf45a'
- 'd88e870c6f2232e5a06ae4b45d6308aae5fa564f5b82dca460a743c71781eba4')
+ 'd7dce79b0950b35052f60cacc7ce835a6111a4f3e833a5406590ff141fb41825')
prepare () {
cd "vte-${pkgver}"
- patch -p1 -i ../vte-command-notify.patch
+ patch -p1 -i ../0001-widget-Only-show-the-cursor-on-motion-if-moved.patch
+ patch -p1 -i ../vte291-command-notify.patch
patch -p1 -i ../add-zsh-notfication-support.patch
}
diff --git a/vte-command-notify.patch b/vte291-command-notify.patch
index 75ad0186fcaf..70aa402a968a 100644
--- a/vte-command-notify.patch
+++ b/vte291-command-notify.patch
@@ -1,40 +1,46 @@
-diff -rupN vte-0.41.90/src/app.vala vte-0.41.90-patched/src/app.vala
---- vte-0.41.90/src/app.vala 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/app.vala 2015-09-15 19:38:39.999947051 +0200
-@@ -102,6 +102,8 @@ class Window : Gtk.ApplicationWindow
- if (App.Options.object_notifications)
- terminal.notify.connect(notify_cb);
-
-+ terminal.notification_received.connect(notification_received_cb);
-+
- /* Settings */
- if (App.Options.no_double_buffer)
- terminal.set_double_buffered(true);
-@@ -511,6 +513,11 @@ class Window : Gtk.ApplicationWindow
- set_title(terminal.get_window_title());
- }
-
-+ private void notification_received_cb(Vte.Terminal terminal, string summary, string? body)
-+ {
-+ print ("[%s]: %s\n", summary, body);
-+ }
-+
- } /* class Window */
-
- class App : Gtk.Application
-diff -rupN vte-0.41.90/src/caps.cc vte-0.41.90-patched/src/caps.cc
---- vte-0.41.90/src/caps.cc 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/caps.cc 2015-09-15 19:22:53.058742000 +0200
-@@ -254,6 +254,8 @@ const char _vte_xterm_capability_strings
+From fec7cd86ca4fe43d64f51af873fa9f81b6c7cf9f Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Wed, 7 Jan 2015 16:01:00 +0100
+Subject: [PATCH 1/3] emulation: Add sequences and signals for desktop
+ notification
+
+Add sequences
+ OSC 777 ; notify ; SUMMARY ; BODY BEL
+ OSC 777 ; notify ; SUMMARY BEL
+ OSC 777 ; notify ; SUMMARY ; BODY ST
+ OSC 777 ; notify ; SUMMARY ST
+
+that let terminal applications send a notification to the desktop
+environment.
+
+Based on Enlightenment's Terminology:
+https://phab.enlightenment.org/T1765
+
+https://bugzilla.gnome.org/show_bug.cgi?id=711059
+---
+ src/caps.cc | 4 +++
+ src/marshal.list | 1 +
+ src/vte.cc | 38 ++++++++++++++++++++++
+ src/vte/vteterminal.h | 3 +-
+ src/vteinternal.hh | 5 +++
+ src/vteseq-n.gperf | 1 +
+ src/vteseq.cc | 90 +++++++++++++++++++++++++++++++++++++++++++++++++++
+ 7 files changed, 141 insertions(+), 1 deletion(-)
+
+diff --git a/src/caps.cc b/src/caps.cc
+index 82078af3f405..e3514eb11f38 100644
+--- a/src/caps.cc
++++ b/src/caps.cc
+@@ -254,6 +254,8 @@ const char _vte_xterm_capability_strings[] =
ENTRY(OSC "117" BEL, "reset-highlight-background-color")
ENTRY(OSC "118" BEL, "reset-tek-cursor-color")
ENTRY(OSC "119" BEL, "reset-highlight-foreground-color")
-+ ENTRY(OSC "777;%s;%s;%s" BEL, "send-notification")
-+ ENTRY(OSC "777;%s;%s" BEL, "send-notification")
++ ENTRY(OSC "777;%s;%s;%s" BEL, "send-notification")
++ ENTRY(OSC "777;%s;%s" BEL, "send-notification")
COMMENT(/* Set text parameters, ST-terminated versions. */)
ENTRY(OSC ";%s" ST, "set-icon-and-window-title") COMMENT(/* undocumented default */)
-@@ -289,6 +291,8 @@ const char _vte_xterm_capability_strings
+@@ -289,6 +291,8 @@ const char _vte_xterm_capability_strings[] =
ENTRY(OSC "117" ST, "reset-highlight-background-color")
ENTRY(OSC "118" ST, "reset-tek-cursor-color")
ENTRY(OSC "119" ST, "reset-highlight-foreground-color")
@@ -43,38 +49,20 @@ diff -rupN vte-0.41.90/src/caps.cc vte-0.41.90-patched/src/caps.cc
COMMENT(/* These may be bogus, I can't find docs for them anywhere (#104154). */)
ENTRY(OSC "21;%s" BEL, "set-text-property-21")
-diff -rupN vte-0.41.90/src/marshal.list vte-0.41.90-patched/src/marshal.list
---- vte-0.41.90/src/marshal.list 2015-05-12 14:32:16.000000000 +0200
-+++ vte-0.41.90-patched/src/marshal.list 2015-09-15 19:23:57.632415651 +0200
+diff --git a/src/marshal.list b/src/marshal.list
+index 0276422ec6d4..2c35c685930a 100644
+--- a/src/marshal.list
++++ b/src/marshal.list
@@ -1,4 +1,5 @@
VOID:INT,INT
VOID:OBJECT,OBJECT
+VOID:STRING,STRING
VOID:STRING,UINT
VOID:UINT,UINT
-diff -rupN vte-0.41.90/src/vte/vteterminal.h vte-0.41.90-patched/src/vte/vteterminal.h
---- vte-0.41.90/src/vte/vteterminal.h 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/vte/vteterminal.h 2015-09-15 19:36:59.769458153 +0200
-@@ -78,6 +78,7 @@ struct _VteTerminalClass {
- void (*child_exited)(VteTerminal* terminal, int status);
- void (*encoding_changed)(VteTerminal* terminal);
- void (*char_size_changed)(VteTerminal* terminal, guint char_width, guint char_height);
-+ void (*notification_received)(VteTerminal* terminal, const gchar *summary, const gchar *body);
- void (*window_title_changed)(VteTerminal* terminal);
- void (*icon_title_changed)(VteTerminal* terminal);
- void (*selection_changed)(VteTerminal* terminal);
-@@ -111,7 +112,7 @@ struct _VteTerminalClass {
- void (*bell)(VteTerminal* terminal);
-
- /* Padding for future expansion. */
-- gpointer padding[16];
-+ gpointer padding[15];
-
- VteTerminalClassPrivate *priv;
- };
-diff -rupN vte-0.41.90/src/vte.cc vte-0.41.90-patched/src/vte.cc
---- vte-0.41.90/src/vte.cc 2015-08-20 14:27:19.000000000 +0200
-+++ vte-0.41.90-patched/src/vte.cc 2015-09-15 19:32:38.601546927 +0200
+diff --git a/src/vte.cc b/src/vte.cc
+index 5b70bd1bfa77..55e57dd3270a 100644
+--- a/src/vte.cc
++++ b/src/vte.cc
@@ -8898,6 +8898,9 @@ vte_terminal_finalize(GObject *object)
remove_update_timeout (terminal);
@@ -85,7 +73,7 @@ diff -rupN vte-0.41.90/src/vte.cc vte-0.41.90-patched/src/vte.cc
/* discard title updates */
g_free(terminal->pvt->window_title);
g_free(terminal->pvt->window_title_changed);
-@@ -10630,6 +10633,7 @@ vte_terminal_class_init(VteTerminalClass
+@@ -10630,6 +10633,7 @@ vte_terminal_class_init(VteTerminalClass *klass)
klass->child_exited = NULL;
klass->encoding_changed = NULL;
klass->char_size_changed = NULL;
@@ -93,32 +81,32 @@ diff -rupN vte-0.41.90/src/vte.cc vte-0.41.90-patched/src/vte.cc
klass->window_title_changed = NULL;
klass->icon_title_changed = NULL;
klass->selection_changed = NULL;
-@@ -10703,6 +10707,25 @@ vte_terminal_class_init(VteTerminalClass
- G_TYPE_NONE,
+@@ -10704,6 +10708,25 @@ vte_terminal_class_init(VteTerminalClass *klass)
1, G_TYPE_INT);
-+ /**
-+ * VteTerminal::notification-received:
-+ * @vteterminal: the object which received the signal
-+ * @summary: The summary
-+ * @body: (allow-none): Extra optional text
-+ *
-+ * Emitted when a process running in the terminal wants to
-+ * send a notification to the desktop environment.
-+ */
-+ g_signal_new(I_("notification-received"),
-+ G_OBJECT_CLASS_TYPE(klass),
-+ G_SIGNAL_RUN_LAST,
-+ G_STRUCT_OFFSET(VteTerminalClass, notification_received),
-+ NULL,
-+ NULL,
-+ _vte_marshal_VOID__STRING_STRING,
-+ G_TYPE_NONE,
-+ 2, G_TYPE_STRING, G_TYPE_STRING);
-+
/**
++ * VteTerminal::notification-received:
++ * @vteterminal: the object which received the signal
++ * @summary: The summary
++ * @body: (allow-none): Extra optional text
++ *
++ * Emitted when a process running in the terminal wants to
++ * send a notification to the desktop environment.
++ */
++ g_signal_new(I_("notification-received"),
++ G_OBJECT_CLASS_TYPE(klass),
++ G_SIGNAL_RUN_LAST,
++ G_STRUCT_OFFSET(VteTerminalClass, notification_received),
++ NULL,
++ NULL,
++ _vte_marshal_VOID__STRING_STRING,
++ G_TYPE_NONE,
++ 2, G_TYPE_STRING, G_TYPE_STRING);
++
++ /**
* VteTerminal::window-title-changed:
* @vteterminal: the object which received the signal
+ *
@@ -12720,6 +12743,16 @@ need_processing (VteTerminal *terminal)
return _vte_incoming_chunks_length (terminal->pvt->incoming) != 0;
}
@@ -127,16 +115,16 @@ diff -rupN vte-0.41.90/src/vte.cc vte-0.41.90-patched/src/vte.cc
+vte_terminal_emit_notification_received (VteTerminal *terminal)
+{
+ _vte_debug_print (VTE_DEBUG_SIGNALS,
-+ "Emitting `notification-received'.\n");
++ "Emitting `notification-received'.\n");
+ g_signal_emit_by_name (terminal, "notification-received",
-+ terminal->pvt->notification_summary,
-+ terminal->pvt->notification_body);
++ terminal->pvt->notification_summary,
++ terminal->pvt->notification_body);
+}
+
/* Emit an "icon-title-changed" signal. */
static void
vte_terminal_emit_icon_title_changed(VteTerminal *terminal)
-@@ -12767,6 +12800,11 @@ vte_terminal_emit_pending_signals(VteTer
+@@ -12767,6 +12800,11 @@ vte_terminal_emit_pending_signals(VteTerminal *terminal)
vte_terminal_emit_adjustment_changed (terminal);
@@ -148,25 +136,31 @@ diff -rupN vte-0.41.90/src/vte.cc vte-0.41.90-patched/src/vte.cc
if (terminal->pvt->window_title_changed) {
g_free (terminal->pvt->window_title);
terminal->pvt->window_title = terminal->pvt->window_title_changed;
-diff -rupN vte-0.41.90/src/vte.sh vte-0.41.90-patched/src/vte.sh
---- vte-0.41.90/src/vte.sh 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/vte.sh 2015-09-15 19:37:40.379655627 +0200
-@@ -50,9 +50,11 @@ __vte_osc7 () {
- }
+diff --git a/src/vte/vteterminal.h b/src/vte/vteterminal.h
+index dbe3ffed81ba..8b21635bea9e 100644
+--- a/src/vte/vteterminal.h
++++ b/src/vte/vteterminal.h
+@@ -78,6 +78,7 @@ struct _VteTerminalClass {
+ void (*child_exited)(VteTerminal* terminal, int status);
+ void (*encoding_changed)(VteTerminal* terminal);
+ void (*char_size_changed)(VteTerminal* terminal, guint char_width, guint char_height);
++ void (*notification_received)(VteTerminal* terminal, const gchar *summary, const gchar *body);
+ void (*window_title_changed)(VteTerminal* terminal);
+ void (*icon_title_changed)(VteTerminal* terminal);
+ void (*selection_changed)(VteTerminal* terminal);
+@@ -111,7 +112,7 @@ struct _VteTerminalClass {
+ void (*bell)(VteTerminal* terminal);
- __vte_prompt_command() {
-+ local command=$(HISTTIMEFORMAT= history 1 | sed 's/^ *[0-9]\+ *//')
-+ command="${command//;/ }"
- local pwd='~'
- [ "$PWD" != "$HOME" ] && pwd=${PWD/#$HOME\//\~\/}
-- printf "\033]0;%s@%s:%s\007%s" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
-+ printf "\033]777;notify;Command completed;%s\007\033]0;%s@%s:%s\007%s" "${command}" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
- }
+ /* Padding for future expansion. */
+- gpointer padding[16];
++ gpointer padding[15];
- case "$TERM" in
-diff -rupN vte-0.41.90/src/vteinternal.hh vte-0.41.90-patched/src/vteinternal.hh
---- vte-0.41.90/src/vteinternal.hh 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/vteinternal.hh 2015-09-15 19:43:58.858195797 +0200
+ VteTerminalClassPrivate *priv;
+ };
+diff --git a/src/vteinternal.hh b/src/vteinternal.hh
+index 4eeeddbc2e1f..b8575d02c99e 100644
+--- a/src/vteinternal.hh
++++ b/src/vteinternal.hh
@@ -367,6 +367,11 @@ public:
gboolean cursor_moved_pending;
gboolean contents_changed_pending;
@@ -179,18 +173,20 @@ diff -rupN vte-0.41.90/src/vteinternal.hh vte-0.41.90-patched/src/vteinternal.hh
/* window name changes */
gchar *window_title;
gchar *window_title_changed;
-diff -rupN vte-0.41.90/src/vteseq-n.gperf vte-0.41.90-patched/src/vteseq-n.gperf
---- vte-0.41.90/src/vteseq-n.gperf 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/vteseq-n.gperf 2015-09-15 19:34:10.725313524 +0200
+diff --git a/src/vteseq-n.gperf b/src/vteseq-n.gperf
+index ad5b6d99f938..287caa5b5928 100644
+--- a/src/vteseq-n.gperf
++++ b/src/vteseq-n.gperf
@@ -168,3 +168,4 @@ struct vteseq_n_struct {
#"reset-mouse-cursor-foreground-color", VTE_SEQUENCE_HANDLER_NULL
"set-current-directory-uri", VTE_SEQUENCE_HANDLER(vte_sequence_handler_set_current_directory_uri)
"set-current-file-uri", VTE_SEQUENCE_HANDLER(vte_sequence_handler_set_current_file_uri)
+"send-notification", VTE_SEQUENCE_HANDLER(vte_sequence_handler_send_notification)
-diff -rupN vte-0.41.90/src/vteseq.cc vte-0.41.90-patched/src/vteseq.cc
---- vte-0.41.90/src/vteseq.cc 2015-08-20 14:26:53.000000000 +0200
-+++ vte-0.41.90-patched/src/vteseq.cc 2015-09-15 20:52:23.771616988 +0200
-@@ -2227,6 +2227,97 @@ vte_sequence_handler_return_terminal_id
+diff --git a/src/vteseq.cc b/src/vteseq.cc
+index ffb00f689a0a..ec9370c7c37d 100644
+--- a/src/vteseq.cc
++++ b/src/vteseq.cc
+@@ -2227,6 +2227,96 @@ vte_sequence_handler_return_terminal_id (VteTerminal *terminal, GValueArray *par
vte_sequence_handler_send_primary_device_attributes (terminal, params);
}
@@ -284,7 +280,78 @@ diff -rupN vte-0.41.90/src/vteseq.cc vte-0.41.90-patched/src/vteseq.cc
+ g_free (option);
+}
+
-+
/* Send secondary device attributes. */
static void
vte_sequence_handler_send_secondary_device_attributes (VteTerminal *terminal, GValueArray *params)
+--
+2.1.0
+
+
+From 930f9e8252175ed3ca94f12af3d6c271637da947 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Thu, 29 Jan 2015 13:09:17 +0100
+Subject: [PATCH 2/3] vte.sh: Emit OSC 777 from PROMPT_COMMAND
+
+https://bugzilla.gnome.org/show_bug.cgi?id=711059
+---
+ src/vte.sh | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/vte.sh b/src/vte.sh
+index 2d211caa2f17..1c0543bd9d26 100644
+--- a/src/vte.sh
++++ b/src/vte.sh
+@@ -50,9 +50,11 @@ __vte_osc7 () {
+ }
+
+ __vte_prompt_command() {
++ local command=$(HISTTIMEFORMAT= history 1 | sed 's/^ *[0-9]\+ *//')
++ command="${command//;/ }"
+ local pwd='~'
+ [ "$PWD" != "$HOME" ] && pwd=${PWD/#$HOME\//\~\/}
+- printf "\033]0;%s@%s:%s\007%s" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
++ printf "\033]777;notify;Command completed;%s\007\033]0;%s@%s:%s\007%s" "${command}" "${USER}" "${HOSTNAME%%.*}" "${pwd}" "$(__vte_osc7)"
+ }
+
+ case "$TERM" in
+--
+2.1.0
+
+
+From 2b2ad252df1add231616f5024cdc572ef587771c Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@gnome.org>
+Date: Thu, 22 Jan 2015 16:37:10 +0100
+Subject: [PATCH 3/3] vteapp: Add a test for the notification-received signal
+
+---
+ src/app.vala | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/app.vala b/src/app.vala
+index e102e4618d81..cc2248009232 100644
+--- a/src/app.vala
++++ b/src/app.vala
+@@ -102,6 +102,8 @@ class Window : Gtk.ApplicationWindow
+ if (App.Options.object_notifications)
+ terminal.notify.connect(notify_cb);
+
++ terminal.notification_received.connect(notification_received_cb);
++
+ /* Settings */
+ if (App.Options.no_double_buffer)
+ terminal.set_double_buffered(true);
+@@ -511,6 +513,11 @@ class Window : Gtk.ApplicationWindow
+ set_title(terminal.get_window_title());
+ }
+
++ private void notification_received_cb(Vte.Terminal terminal, string summary, string? body)
++ {
++ print ("[%s]: %s\n", summary, body);
++ }
++
+ } /* class Window */
+
+ class App : Gtk.Application
+--
+2.1.0
+