summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2018-01-02 00:07:19 +0100
committerkpcyrd2018-01-02 00:07:19 +0100
commitea453012b5692a434aff490f0858c042ed3d71b5 (patch)
treefdcc7032e288dc0a3eca291381bc91e9c4b7264d
parent98309e1458af28af8495a066c8f323cd7811d3b9 (diff)
downloadaur-wasm-gc-git.tar.gz
Fix pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2dd2a26ab0a..a356714e52a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wasm-gc-git
pkgdesc = gc-sections for wasm
- pkgver = 0.0.0
- pkgrel = 2
+ pkgver = 0.1.0.r0.gfbdc8b1
+ pkgrel = 1
url = https://github.com/alexcrichton/wasm-gc
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 02d3a4a28e23..e9a288dc32c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_gitname=wasm-gc
pkgname=wasm-gc-git
-pkgver=0.0.0
-pkgrel=2
+pkgver=0.1.0.r0.gfbdc8b1
+pkgrel=1
pkgdesc="gc-sections for wasm"
url="https://github.com/alexcrichton/wasm-gc"
depends=('gcc-libs')
@@ -16,6 +16,11 @@ source=("git+https://github.com/alexcrichton/$_gitname.git")
sha256sums=('SKIP')
sha512sums=('SKIP')
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd "$_gitname"
cargo build --release