summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Pan2024-03-13 12:32:06 +0800
committerPaul Pan2024-03-13 12:32:06 +0800
commit7d9fb47b97c839df478363a038b321fd64844c80 (patch)
tree452c858be55cd0be519702dd7afc4f2586d02658
parentabc1e18ece11083f8eafd8ad1151ef0a8775ab3d (diff)
downloadaur-wasm-micro-runtime.tar.gz
update to 1.3.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--RELEASE_NOTES.md146
3 files changed, 154 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9039f4f4891..f3c783f6c33b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wasm-micro-runtime
pkgdesc = Standalone WebAssembly (WASM) runtime with small footprint
- pkgver = 1.3.0
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/bytecodealliance/wasm-micro-runtime
changelog = RELEASE_NOTES.md
@@ -13,7 +13,7 @@ pkgbase = wasm-micro-runtime
depends = llvm-libs
provides = wasm-micro-runtime
conflicts = wasm-micro-runtime-git
- source = https://github.com/bytecodealliance/wasm-micro-runtime/archive/WAMR-1.3.0.tar.gz
- sha512sums = b212208fbbf5613f169447e6d3a079edec7321c892c44e9c51734b41c1c9bd45a83afd38b16e01c0850252a5072b566cff45ab4cecd3eed19705bef3a616385f
+ source = https://github.com/bytecodealliance/wasm-micro-runtime/archive/WAMR-1.3.2.tar.gz
+ sha512sums = 8d39230e41b8acf0d69b1cc1968c1eaeaa06ea0083e0a910d731d30f50e5807bc1ed4b0f46545a02fe392fbd62fb867a585dc91ffddcfce1dd9b007957a6cc7a
pkgname = wasm-micro-runtime
diff --git a/PKGBUILD b/PKGBUILD
index ad477ad54644..f2c21da85661 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=wasm-micro-runtime
-pkgver=1.3.0
+pkgver=1.3.2
pkgrel=1
pkgdesc="Standalone WebAssembly (WASM) runtime with small footprint"
arch=('x86_64')
@@ -15,7 +15,7 @@ provides=("wasm-micro-runtime")
conflicts=("wasm-micro-runtime-git")
changelog="RELEASE_NOTES.md"
source=("$url/archive/WAMR-$pkgver.tar.gz")
-sha512sums=("b212208fbbf5613f169447e6d3a079edec7321c892c44e9c51734b41c1c9bd45a83afd38b16e01c0850252a5072b566cff45ab4cecd3eed19705bef3a616385f")
+sha512sums=('8d39230e41b8acf0d69b1cc1968c1eaeaa06ea0083e0a910d731d30f50e5807bc1ed4b0f46545a02fe392fbd62fb867a585dc91ffddcfce1dd9b007957a6cc7a')
prepare() {
sed -i 's/${LLVM_AVAILABLE_LIBS}/LLVM/g' "$pkgname-WAMR-$pkgver/product-mini/platforms/linux/CMakeLists.txt"
@@ -46,6 +46,9 @@ build() {
-DWAMR_BUILD_TAIL_CALL=1 \
-DWAMR_BUILD_SIMD=1 \
-DWAMR_BUILD_REF_TYPES=1 \
+ -DWAMR_BUILD_STATIC_PGO=1 \
+ -DWAMR_BUILD_MODULE_INST_CONTEXT=1 \
+ -DWAMR_BUILD_QUICK_AOT_ENTRY=1 \
"
cmake \
diff --git a/RELEASE_NOTES.md b/RELEASE_NOTES.md
index fbb97f5d756a..3fcfaf4bc587 100644
--- a/RELEASE_NOTES.md
+++ b/RELEASE_NOTES.md
@@ -1,3 +1,149 @@
+## WAMR-1.3.2
+
+### Breaking Changes
+
+### New Features
+- Implement Exception Handling for classic interpreter (#3096)
+ - Use `cmake -DWAMR_BUILD_EXCE_HANDLING=1/0` option to enable/disable
+ the feature, and by default it is disabled
+ - It is still in highly experimental stage
+
+### Bug Fixes
+- Fix build errors when initializing wasm_val_t values with macros (#3007)
+- fix(wasm-c-api): Do not clone stack frames if there's no trap (#3008)
+- classic-interp: Handle SIMD opcode when JIT is enabled (#3046)
+- fast-interp: Fix dynamic offset error issue in else branch (#3058)
+- wasm_cluster_destroy_spawned_exec_env: Avoid "invalid exec env" trap (#3068)
+- thread-mgr: Fix locking problems around aux stack allocation (#3073)
+- cosmopolitan: Update compiler and update platform_internal.h (#3079)
+- wasi: Apply wasm_runtime_begin_blocking_op to poll as well (#3080)
+- Fix memory/table segment checks in memory.init/table.init (#3081)
+- perf profiling: Adjust the calculation of execution time (#3089)
+- aot: Fix LLVMSetTailCallKind check (#3099)
+- fast-interp: Fix stack recovery for else branch (#3100)
+- fast-interp: Fix frame_offset pop order (#3101)
+- Fix AOT compilation on MacOS (#3102)
+- fast-interp: Fix block with parameter in polymorphic stack issue (#3112)
+- Fix read and validation of misc/simd/atomic sub opcodes (#3115)
+
+### Enhancements
+- Clear compilation warning and dead code (#3002)
+- aot debug: Try to use a bit more appropriate file names (#3000)
+- Increase default app thread stack size (#3010)
+- Rename rwlock_init to avoid conflict (#3016)
+- nuttx: Use larger alignment for os_mmap and comment why (#3017)
+- Allow using mmap for shared memory if hw bound check is disabled (#3029)
+- Don't redefine D_INO if already defined (#3036)
+- Enhancements on wasm function execution time statistic (#2985)
+- wamr-compiler: Fix non-x86{_64} host builds (#3037)
+- Disable quick aot entry for interp and fast-jit (#3039)
+- nuttx: Add option to enable quick aot entry (#3040)
+- Set CONFIG_HAS_CAP_ENTER to support posix file api for freertos (#3041)
+- Revert "Enable MAP_32BIT for macOS (#2992)" (#3032)
+- Enable quick aot entry when hw bound check is disabled (#3044)
+- Do not inherit WASM_SUSPEND_FLAG_BLOCKING from the parent thread (#3051)
+- wasm_runtime_begin_blocking_op: A comment about usage expectation (#3056)
+- Check arguments before calling bh_hash_map_find (#3055)
+- Fix aot large model (--size-level=0) with LLVM 18 (#3057)
+- Add flag to control Winsocket initialization (#3060)
+- nuttx: If STACK_GUARD_SIZE is not set, leave it to config.h (#2927)
+- Enhance setting write gs base with cmake variable (#3066)
+- aot_reloc_x86_64.c: Suggest to try --size-level=0 as well (#3067)
+- Fix some issues reported by CodeQL (#3064)
+- Remove a lot of "unused parameter" warnings (#3075)
+- Forward log and log level to custom bh_log callback (#3070)
+- Fix inconsistent code style in aot_loader.c (#3082)
+- freertos: Thread exit more common (#3094)
+- Fix windows build error and compilation warnings (#3095)
+
+### Others
+- Fix nightly-run CI failure (#3014)
+- Build samples in debug mode (#3019)
+- Remove deprecated tests in language-bindings python (#3018)
+- Avoid unused thread_id warning and recompile multi-module sample (#3033)
+- samples/terminate: Add a sample to demonstrate wasm_runtime_terminate (#3043)
+- Bump NuttX version to 12.4.x in CI (#3047)
+- perf_tune.md: Add refine the calling processes between host and wasm (#3065)
+- build_wamr.md: Update the document (#3074)
+- Fix download link for wasi-sdk (#3077)
+- README.md: Fix typo tunning to tuning (#3078)
+- Update outdated reference link in multi_module.md (#3092)
+- Add comments to suppress warning from clang-tidy (#3088)
+- CI: Update version of checkout to suppress warnings (#3093)
+- test_wamr.sh: Allow using test script on different platforms (#3098)
+
+---
+
+## WAMR-1.3.1
+
+### Breaking Changes
+- In multi-threading, when an exception was thrown in wasm_func_call(),
+ the trap returned contains the stack frames of the thread where the
+ exception occurs, but not the stack frames of the main thread.
+- Disable emitting custom name section to AOT file with
+ `wamrc --enable-dump-call-stack` option, instead, use
+ `wamrc --emit-custom-sections=name` to emit it and make it clear.
+
+### New Features
+- Enable AOT linux perf support (#2930)
+
+### Bug Fixes
+- Corrects Zephyr include files for current versions of Zephyr (#2881)
+- Fix possible dead lock in wasm_cluster_spawn_exec_env (#2882)
+- Handle ambiguous fstflags on fd_filestat_set_times (#2892)
+- Fix memory size not updating after growing in interpreter (#2898)
+- fixed(freertos): Fix crash when wasm app call pthread_exit(NULL) (#2970)
+- fast-jit: Fix const shift and const i64 compare issues (#2969)
+- Fix ref.is_null processing in fast-interp loader (#2971)
+- simd-128: The input lanes of integer-to-integer narrowing ops should be interpreted as signed (#2850)
+- Fix ref.func function declared check in wasm loader (#2972)
+- Fix fast-interp polymorphic stack processing (#2974)
+- Fix potential recursive lock in pthread_create_wrapper (#2980)
+- Fix build failure on esp-idf platform (#2991)
+- Return stack frames of crashed thread when using wasm-c-api (#2908)
+- Fix compilation error on iOS due to macOS-specific API (#2995)
+- Fix a bug when emit the custom name section to aot file (#2987)
+- Fix linux-sgx build error when libc-wasi is disabled (#2997)
+
+### Enhancements
+- fix command-reactor: Look for _initialize only if _start not found (#2891)
+- Refactor reloc symbols for riscv (#2894)
+- Avoid memory import failure when wasi-threads is enabled (#2893)
+- interpreter: Simplify memory.grow a bit (#2899)
+- Avoid reporting timestamp if custom logger is used (#2905)
+- Expose API to set log level in embedder (#2907)
+- Add a script to translate jitted function names in flamegraph (#2906)
+- Refine wasm-c-api wasm_func_call (#2922)
+- Add VectorCombine pass for JIT and AOT (#2923)
+- Enable wasm_runtime_terminate for single-threading (#2924)
+- nuttx: Add CONFIG_INTERPRETERS_WAMR_DEBUG_AOT (#2929)
+- Allow to control built-in libraries for wamrc from command line options (#2928)
+- Fix a bug that appends '_precheck' to aot_func (#2936)
+- freertos: Add os_cond_broadcast for pthread wrapper (#2937)
+- Append .aot to .wasm as a custom section named "aot" (#2933)
+- fix(sgx-ra): Fix building when enclave is built without librats ahead (#2968)
+- Refine LLVM JIT function call process (#2925)
+- Refine AOT function call process (#2940)
+- Allow to set segue flags for wasm-c-api JIT (#2926)
+- freertos: Minor changes for freertos libc_wasi build adaption (#2973)
+- freertos: Change ssp_config.h due to clock_nanosleep() not supported in freertos (#2979)
+- aot compiler: Some updates for LLVM 18 (#2981)
+- Enable MAP_32BIT for macOS (#2992)
+- Register quick call entries to speedup the aot/jit func call process (#2978)
+- Refine AOT/JIT code call wasm-c-api import process (#2982)
+
+### Others
+- compilation_on_nuttx.yml: Use docker image to simplify env setup (#2878)
+- samples/spawn-thread: Disable libc and pthread (#2883)
+- Add arm64 to nuttx compilation test (#2886)
+- samples/spawn-thread: Tweak to expose a bug (#2888)
+- Fix typo in CI config and suppress STORE_U8 in TSAN (#2802)
+- Using docker image for nuttx spectest (#2887)
+- doc: Separate source_debugging.md into two files (#2932)
+- doc/build_wasm_app.md: Add a note about aot abi compatibility (#2993)
+
+---
+
## WAMR-1.3.0
### Breaking Changes