summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiodrag Tokić2018-01-08 19:50:29 +0100
committerMiodrag Tokić2018-01-08 19:50:29 +0100
commit908b263abfa5f30d688d99919eeb4ec0d29a297f (patch)
tree09316ed042ac2e69618134f5e61b3780afb3a652
parent1d4bb67ca1bfd1660d50747550f04d2e5329a2df (diff)
downloadaur-908b263abfa5f30d688d99919eeb4ec0d29a297f.tar.gz
Fix broken setup process
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--setup.py.patch13
3 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c210a82cf643..58967c1a0ff6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = watson
pkgdesc = A wonderful CLI to track your time!
pkgver = 1.5.2
- pkgrel = 2
+ pkgrel = 3
url = https://tailordev.github.io/Watson/
arch = any
license = MIT
@@ -12,7 +12,9 @@ pkgbase = watson
depends = python-requests
options = !emptydirs
source = watson-1.5.2.tar.gz::https://github.com/TailorDev/Watson/archive/1.5.2.tar.gz
+ source = setup.py.patch
sha256sums = 4285335ead5c772864f3750522571404133d76bbffb00f1e739e7dd6d96416ce
+ sha256sums = 5c8c6882ed4ad90a79a20ef3e41cda7abadaff52219dee737de37920096017b4
pkgname = watson
diff --git a/PKGBUILD b/PKGBUILD
index a98f343f4379..ca8e5dfd69bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=watson
pkgver=1.5.2
-pkgrel=2
+pkgrel=3
pkgdesc='A wonderful CLI to track your time!'
arch=('any')
url='https://tailordev.github.io/Watson/'
@@ -11,8 +11,19 @@ depends=('python' 'python-arrow' 'python-click' 'python-requests')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/TailorDev/Watson/archive/$pkgver.tar.gz")
-sha256sums=('4285335ead5c772864f3750522571404133d76bbffb00f1e739e7dd6d96416ce')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/TailorDev/Watson/archive/$pkgver.tar.gz"
+ "setup.py.patch"
+)
+sha256sums=(
+ '4285335ead5c772864f3750522571404133d76bbffb00f1e739e7dd6d96416ce'
+ '5c8c6882ed4ad90a79a20ef3e41cda7abadaff52219dee737de37920096017b4'
+)
+
+prepare() {
+ cd "$srcdir/Watson-$pkgver"
+ patch -N -p1 -i "$srcdir/setup.py.patch"
+}
build() {
cd "$srcdir/Watson-$pkgver"
diff --git a/setup.py.patch b/setup.py.patch
new file mode 100644
index 000000000000..125016895664
--- /dev/null
+++ b/setup.py.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 13b4f87..89cf44f 100644
+--- a/setup.py
++++ b/setup.py
+@@ -32,7 +32,7 @@ def parse_requirements(requirements, ignore=('setuptools',)):
+ pkg = line.strip()
+ if pkg not in ignore:
+ packages.add(pkg)
+- return packages
++ return tuple(packages)
+
+
+ setup(