summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanct122021-09-12 10:32:39 +0700
committerDanct122021-09-12 10:32:39 +0700
commit35cdc5985a45490aec62d5de9841f454e4073bb7 (patch)
tree3140fd413b4f927460924c268d275fffdf9bcd71
downloadaur-35cdc5985a45490aec62d5de9841f454e4073bb7.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--gbinder.conf2
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46ad26fadcd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = waydroid
+ pkgdesc = A container-based approach to boot a full Android system on a regular Linux system
+ pkgver = r26.ecd0da2
+ pkgrel = 1
+ url = https://github.com/waydroid
+ arch = any
+ makedepends = git
+ depends = lxc
+ depends = python
+ depends = python-gbinder
+ depends = python-requests
+ optdepends = waydroid-image: Android image for use with waydroid
+ source = waydroid::git+https://github.com/waydroid/waydroid.git#commit=ecd0da2948b65184c759104de9d2a3e46257508f
+ source = gbinder.conf
+ sha256sums = SKIP
+ sha256sums = 87a21d401281735ea026d715ea79b36e01f9af084198de2761b32d5b58a343dd
+
+pkgname = waydroid
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efb0aab85371
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Danct12 <danct12@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+
+pkgname=waydroid
+pkgver=r26.ecd0da2
+pkgrel=1
+pkgdesc="A container-based approach to boot a full Android system on a regular Linux system"
+arch=('any')
+url='https://github.com/waydroid'
+depends=('lxc' 'python' 'python-gbinder' 'python-requests')
+makedepends=('git')
+optdepends=('waydroid-image: Android image for use with waydroid')
+_commit="ecd0da2948b65184c759104de9d2a3e46257508f"
+source=("waydroid::git+https://github.com/waydroid/waydroid.git#commit=$_commit"
+ gbinder.conf)
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd waydroid
+ install -dm755 "$pkgdir/usr/lib/waydroid"
+ install -dm755 "$pkgdir/usr/share/applications"
+ install -dm755 "$pkgdir/usr/bin"
+ cp -r tools data "$pkgdir/usr/lib/waydroid/"
+ mv "$pkgdir/usr/lib/waydroid/data/Waydroid.desktop" "$pkgdir/usr/share/applications"
+ cp waydroid.py "$pkgdir/usr/lib/waydroid/"
+ ln -s /usr/lib/waydroid/waydroid.py "$pkgdir/usr/bin/waydroid"
+
+ install -Dm644 -t "$pkgdir/etc" "$srcdir/gbinder.conf"
+ install -Dm644 -t "$pkgdir/etc/gbinder.d" gbinder/anbox.conf
+ install -Dm644 -t "$pkgdir/usr/lib/systemd/system" debian/waydroid-container.service
+}
+
+sha256sums=('SKIP'
+ '87a21d401281735ea026d715ea79b36e01f9af084198de2761b32d5b58a343dd')
diff --git a/gbinder.conf b/gbinder.conf
new file mode 100644
index 000000000000..a95692feb37f
--- /dev/null
+++ b/gbinder.conf
@@ -0,0 +1,2 @@
+[General]
+ApiLevel = 29