summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanct122021-10-01 01:11:47 +0700
committerDanct122021-10-01 01:11:47 +0700
commitab9f4d515b3f70ce644cb5ba15cf71a8cea24e8d (patch)
tree6b96f9d364fadcf8ef5c91f3de9122c4e85c80a1
parent8105579f9f534571d9b905ad374a0fe694368165 (diff)
downloadaur-ab9f4d515b3f70ce644cb5ba15cf71a8cea24e8d.tar.gz
upgrade to 1.1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4682bbd10ab..2032f865a852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = waydroid
pkgdesc = A container-based approach to boot a full Android system on a regular Linux system
- pkgver = 1.1.0
- pkgrel = 2
+ pkgver = 1.1.1
+ pkgrel = 1
url = https://github.com/waydroid
arch = any
license = GPL
@@ -14,11 +14,9 @@ pkgbase = waydroid
depends = dnsmasq
optdepends = waydroid-image: Android image for use with waydroid
optdepends = python-pyclip: share clipboard with container
- source = waydroid::git+https://github.com/waydroid/waydroid.git#commit=58504aa086ef84daae11e4a8a25f05f5f562695a
- source = https://github.com/waydroid/waydroid/commit/9cec7cac9481750a4955c5bbc6c68a218d4635db.patch
+ source = waydroid::git+https://github.com/waydroid/waydroid.git#commit=96204ad92421fd3e1a17b3555e7057d05255046e
source = gbinder.conf
sha256sums = SKIP
- sha256sums = 8ee208705b92c85b945705105317d6ce3ab1a4224024c93406192edd7ec94762
sha256sums = 87a21d401281735ea026d715ea79b36e01f9af084198de2761b32d5b58a343dd
pkgname = waydroid
diff --git a/PKGBUILD b/PKGBUILD
index 8cde6998382d..e349514dad67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
pkgname=waydroid
-pkgver=1.1.0
-pkgrel=2
+pkgver=1.1.1
+pkgrel=1
pkgdesc="A container-based approach to boot a full Android system on a regular Linux system"
arch=('any')
url='https://github.com/waydroid'
@@ -11,22 +11,16 @@ license=('GPL')
depends=('lxc' 'python' 'python-gbinder' 'python-gobject' 'nftables' 'dnsmasq')
makedepends=('git')
optdepends=('waydroid-image: Android image for use with waydroid'
- 'python-pyclip: share clipboard with container')
-_commit="58504aa086ef84daae11e4a8a25f05f5f562695a" # tags/1.1.0
+ 'python-pyclip: share clipboard with container')
+_commit="96204ad92421fd3e1a17b3555e7057d05255046e" # tags/1.1.1
source=("waydroid::git+https://github.com/waydroid/waydroid.git#commit=$_commit"
- https://github.com/waydroid/waydroid/commit/9cec7cac9481750a4955c5bbc6c68a218d4635db.patch
- gbinder.conf)
+ gbinder.conf)
pkgver() {
cd "$pkgname"
git describe --tags | sed 's/^v//;s/-/+/g'
}
-prepare() {
- cd waydroid
- patch -p1 < ../9cec7cac9481750a4955c5bbc6c68a218d4635db.patch
-}
-
package() {
cd waydroid
install -dm755 "$pkgdir/usr/lib/waydroid"
@@ -43,5 +37,4 @@ package() {
}
sha256sums=('SKIP'
- '8ee208705b92c85b945705105317d6ce3ab1a4224024c93406192edd7ec94762'
'87a21d401281735ea026d715ea79b36e01f9af084198de2761b32d5b58a343dd')