summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorabbypan2024-11-07 16:11:17 +0800
committerabbypan2024-11-07 16:11:17 +0800
commit6227323cb1ab1a598baf63dd369810da279e3ee7 (patch)
tree4ebfdc7b547dccec6fa9318cba61ddf9ed0433b6
downloadaur-wdns-git.tar.gz
wdns
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe2c273b3027
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = wdns-git
+ pkgdesc = wdns is a low-level C library for dealing with wire-format dns packets.
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/farsightsec/wdns/
+ arch = any
+ license = MIT
+ makedepends = libpcap
+ makedepends = tcpdump
+ makedepends = pkgconf
+
+pkgname = wdns-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e88871d8b07e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pan Lanlan <abbypan@gmail.com>
+pkgname=wdns-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc='wdns is a low-level C library for dealing with wire-format dns packets.'
+arch=('any')
+license=('MIT')
+makedepends=('libpcap' 'tcpdump' 'pkgconf')
+url="https://github.com/farsightsec/wdns/"
+
+build() {
+ git clone --recursive $url
+ cd wdns
+ ./autogen.sh
+ ./configure
+ make
+ make check
+}
+
+package() {
+ cd wdns
+ make install DESTDIR=$pkgdir
+}