summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-08-05 18:00:51 -0400
committerKevin MacMartin2015-08-05 18:00:51 -0400
commit8035a8d781466fc195e68518249cc0ac96803232 (patch)
tree50f360a1241f40cf1974e81113cd97095924d2d1
parent3c0556d63e672bfd40ade1455bfa35f77a3ac1d0 (diff)
downloadaur-8035a8d781466fc195e68518249cc0ac96803232.tar.gz
Improve bash standards used in the PKGBUILD and add .gitignore
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..066054d8d3fa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+weatherspect_v1.11.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b595eada8b7c..4837c45e4640 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,21 @@
pkgname=weatherspect
pkgver=1.11
pkgrel=2
-pkgdesc="A weather simulator using ASCII animations"
+pkgdesc='A weather simulator using ASCII animations'
arch=('any')
-url="http://robobunny.com/projects/weatherspect/html/"
+url='http://robobunny.com/projects/weatherspect/html/'
license=('GPL')
depends=('perl-term-animation' 'perl-weather-underground')
-source=("http://robobunny.com/projects/${pkgname}/${pkgname}_v${pkgver}.tar.gz" "${pkgname}.1")
-sha512sums=('02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b' '0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5')
+source=(
+ "http://robobunny.com/projects/$pkgname/${pkgname}_v$pkgver.tar.gz"
+ "$pkgname.1"
+)
+sha512sums=(
+ '02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b'
+ '0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5'
+)
package() {
- install -Dm644 ${pkgname}.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
- install -Dm755 ${pkgname}_v${pkgver}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm755 ${pkgname}_v$pkgver/$pkgname "$pkgdir/usr/bin/$pkgname"
}