summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:18:27 +0100
committerDaniel Peukert2024-01-28 00:18:27 +0100
commit902000dc4e9aa3330b1d99bbb385fecad47c0641 (patch)
tree8a0b64aeec4b0cafd97996b198a8fed22fbd5864
parent63d3c8fdbcc1b85ba51e282fe263ed12ef3d6bf7 (diff)
downloadaur-902000dc4e9aa3330b1d99bbb385fecad47c0641.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD12
3 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12f378169004..8612b8f4bccd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,13 @@ pkgbase = weatherspect
pkgrel = 2
url = https://github.com/AnotherFoxGuy/weatherspect
arch = any
- license = GPL2
+ license = GPL-2.0-only
depends = perl
depends = perl-compass-points
depends = perl-json
depends = perl-term-animation
- source = weatherspect-2.0-2::https://github.com/AnotherFoxGuy/weatherspect/raw/2.0/weatherspect
- source = weatherspect-2.0-2.diff::https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff
+ source = weatherspect-2.0::https://github.com/AnotherFoxGuy/weatherspect/raw/2.0/weatherspect
+ source = weatherspect-2.0-fix-w-bug.diff::https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff
source = devendor.diff
source = weatherspect.1
sha512sums = 39c277f933f9764df11ff6267bbf3dbd322a1fa83404190417c5e022dae0bf1b8f5d35b363759da5a2aaa1959c61f3f50315c8cf72abe7965aafb7190b5e7c60
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index d35bf82fe1e5..ae9efa50ee0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,11 +8,11 @@ pkgrel='2'
pkgdesc='A virtual weather environment in ASCII'
arch=('any')
url="https://github.com/AnotherFoxGuy/$pkgname"
-license=('GPL2')
+license=('GPL-2.0-only')
depends=('perl' 'perl-compass-points' 'perl-json' 'perl-term-animation')
source=(
- "$pkgname-$pkgver-$pkgrel::$url/raw/$pkgver/$pkgname"
- "$pkgname-$pkgver-$pkgrel.diff::$url/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff"
+ "$pkgname-$pkgver::$url/raw/$pkgver/$pkgname"
+ "$pkgname-$pkgver-fix-w-bug.diff::$url/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff"
'devendor.diff'
"$pkgname.1"
)
@@ -25,14 +25,14 @@ prepare() {
cd "$srcdir/"
# Devendor perl-compass-points
- patch --follow-symlinks --forward -p1 "$pkgname-$pkgver-$pkgrel" < 'devendor.diff'
+ patch --follow-symlinks --forward -p1 "$pkgname-$pkgver" < 'devendor.diff'
# https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58
- patch --follow-symlinks --forward -p1 "$pkgname-$pkgver-$pkgrel" < "$pkgname-$pkgver-$pkgrel.diff"
+ patch --follow-symlinks --forward -p1 "$pkgname-$pkgver" < "$pkgname-$pkgver-fix-w-bug.diff"
}
package() {
cd "$srcdir/"
- install -Dm755 "$pkgname-$pkgver-$pkgrel" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}