summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2019-12-30 16:56:30 +0100
committerDaniel Peukert2019-12-30 16:56:30 +0100
commitdf4c555e30362720b4e4578d24558e0814644d18 (patch)
tree8a9d980048391bdfb6b7481f4945f07a9c103f9f
parent6cf8cdddc5359f40bd795ffcfa0d61569323b45a (diff)
downloadaur-df4c555e30362720b4e4578d24558e0814644d18.tar.gz
Added weatherspect
-rw-r--r--.SRCINFO21
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD44
-rw-r--r--README.md36
-rw-r--r--weatherspect.1107
6 files changed, 116 insertions, 118 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fcc04c8f059..b400355e9004 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = weatherspect
- pkgdesc = A weather simulator using ASCII animations
- pkgver = 1.11
- pkgrel = 2
- url = http://robobunny.com/projects/weatherspect/html/
+ pkgdesc = A virtual weather environment in ASCII
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://github.com/AnotherFoxGuy/weatherspect
arch = any
- license = GPL
+ license = GPL2
+ depends = perl
depends = perl-term-animation
- depends = perl-weather-underground
- source = http://robobunny.com/projects/weatherspect/weatherspect_v1.11.tar.gz
+ source = weatherspect-2.0-1::https://github.com/AnotherFoxGuy/weatherspect/raw/2.0/weatherspect
+ source = weatherspect-2.0-1.diff::https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff
source = weatherspect.1
- sha512sums = 02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b
- sha512sums = 0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5
+ sha256sums = e4ddd43d566a98b1d2ec136bf613f22f689ef2938479e23ca0082b84ebd6247c
+ sha256sums = b8685b9d4e9552d538b68aa31400d0970d4e4ffa0eeda981d9fde32210a2ba5a
+ sha256sums = 8b0d7bb995e44190cc005ec3b604f147dcb233744a262cbbf9a9ad8f9214ab0c
pkgname = weatherspect
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
index 95bf68c87eed..82b3c183d5d4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,14 @@
-*.pkg.tar.xz
-pkg
-src
-weatherspect_v*.tar.gz
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 4837c45e4640..7a5e441d6e9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
-# Maintainer: Prurigro
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Kevin MacMartin <prurigro at gmail dot com>
# Contributor: Lara Maia <lara@craft.net.br>
-
-pkgname=weatherspect
-pkgver=1.11
-pkgrel=2
-pkgdesc='A weather simulator using ASCII animations'
+# Contributor: archlinux.info:tdy
+pkgname='weatherspect'
+pkgver='2.0'
+pkgrel='1'
+pkgdesc='A virtual weather environment in ASCII'
arch=('any')
-url='http://robobunny.com/projects/weatherspect/html/'
-license=('GPL')
-depends=('perl-term-animation' 'perl-weather-underground')
-source=(
- "http://robobunny.com/projects/$pkgname/${pkgname}_v$pkgver.tar.gz"
- "$pkgname.1"
-)
-sha512sums=(
- '02bef58a31f7ca6e428d0efca7948160bc0a2283ea9329f433f2e3295f9e0190b0412e49632f1820fd744b68d5ab79bcbb04f5a914b023e3f94800fb4802362b'
- '0f3f75418bae698d788d6ef7db373a8fe03ab289752083068f549add4af71daf2fa414a5ee9d640d6f7546f61719221bf003402b3a3a68813e0fd3edfb09c9d5'
-)
+url="https://github.com/AnotherFoxGuy/$pkgname"
+license=('GPL2')
+depends=('perl' 'perl-term-animation')
+source=("$pkgname-$pkgver-$pkgrel::$url/raw/$pkgver/$pkgname"
+ "$pkgname-$pkgver-$pkgrel.diff::$url/commit/b7ac28234c1e93e537787d163ac80361296aaf58.diff"
+ "$pkgname.1")
+sha256sums=('e4ddd43d566a98b1d2ec136bf613f22f689ef2938479e23ca0082b84ebd6247c'
+ 'b8685b9d4e9552d538b68aa31400d0970d4e4ffa0eeda981d9fde32210a2ba5a'
+ '8b0d7bb995e44190cc005ec3b604f147dcb233744a262cbbf9a9ad8f9214ab0c')
+
+prepare() {
+ cd "$srcdir/"
+ # https://github.com/AnotherFoxGuy/weatherspect/commit/b7ac28234c1e93e537787d163ac80361296aaf58
+ patch --follow-symlinks --forward -p1 "$pkgname-$pkgver-$pkgrel" < "$pkgname-$pkgver-$pkgrel.diff"
+}
package() {
- install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
- install -Dm755 ${pkgname}_v$pkgver/$pkgname "$pkgdir/usr/bin/$pkgname"
+ cd "$srcdir/"
+ install -Dm755 "$pkgname-$pkgver-$pkgrel" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname.1" "$pkgdir/usr/share/man/man1/$pkgname.1"
}
diff --git a/README.md b/README.md
deleted file mode 100644
index b170dab0f2e0..000000000000
--- a/README.md
+++ /dev/null
@@ -1,36 +0,0 @@
-# WeatherSpect v1.11 #
-
-## Description ##
-
-WeatherSpect provides a reasonably accurate simulation of what the weather looks like outside, in ASCII art. It includes rain, snow, lightning, sleet, and hail. The windspeed and cloudiness are reflected in the velocity and quantity of clouds. There are trees that age, reproduce and die over the course of an hour, and a sun and moon that follow the actual sun and moonrise. There's also a dancing turtle.
-
-## Requirements ##
-
-You must have the Term::Animation module, which you can get from http://www.cpan.org. The Term::Animation module also requires the Curses module, which you can also get from CPAN.
-
-## Usage ##
-
-Before weatherspect will work, you have to create a config file for it. Running it with the -c option will prompt you for info to create a config file in ~/.weatherspect.
-
- weatherspect -h: Print this help message
- weatherspect -f <file>: Supply a config file to use instead of the default
- weatherspect -c: Generate a config file
-
-While weatherspect is running, the following commands are available:
-
- q: Quit
- h: Toggle the help window
- w: Toggle the detailed weather info window
- d: Toggle the debug window
- u: Force an update of weather data
- r: Redraw. This will remove all objects and recreate them, probably in different places.
-
-## Credits ##
-
-by Kirk Baucom <kbaucom@schizoid.com> [http://www.robobunny.com](http://www.robobunny.com)
-
-* Kevin Ferree (http://chavo-one.com): All art in the code marked with 'kf'
-* Hayley Wakenshaw (http://www.bornsquishy.com/flump/index.html): All art in the code marked with 'hjw'
-* Joan Stark (http://www.geocities.com/SoHo/7373/): All art in the code marked with 'jgs'
-
-You can grep for ATTRIB in the code to get a list of credits for all the ASCII art.
diff --git a/weatherspect.1 b/weatherspect.1
index 49bec70da754..1fd52c138dee 100644
--- a/weatherspect.1
+++ b/weatherspect.1
@@ -1,60 +1,69 @@
-.\" generated with Ronn/v0.7.3
-.\" http://github.com/rtomayko/ronn/tree/0.7.3
-.
-.TH "WEATHERSPECT" "" "May 2014" "" "weatherspect"
-.
-.SH "Description"
-WeatherSpect provides a reasonably accurate simulation of what the weather looks like outside, in ASCII art\. It includes rain, snow, lightning, sleet, and hail\. The windspeed and cloudiness are reflected in the velocity and quantity of clouds\. There are trees that age, reproduce and die over the course of an hour, and a sun and moon that follow the actual sun and moonrise\. There\'s also a dancing turtle\.
-.
-.SH "Requirements"
-You must have the Term::Animation module, which you can get from http://www\.cpan\.org\. The Term::Animation module also requires the Curses module, which you can also get from CPAN\.
-.
-.SH "Usage"
-Before weatherspect will work, you have to create a config file for it\. Running it with the \-c option will prompt you for info to create a config file in ~/\.weatherspect\.
-.
-.IP "" 4
-.
-.nf
-
-weatherspect \-h: Print this help message
-weatherspect \-f <file>: Supply a config file to use instead of the default
-weatherspect \-c: Generate a config file
-.
-.fi
-.
-.IP "" 0
-.
-.P
-While weatherspect is running, the following commands are available:
-.
-.IP "" 4
-.
-.nf
-
-q: Quit
-h: Toggle the help window
-w: Toggle the detailed weather info window
-d: Toggle the debug window
-u: Force an update of weather data
-r: Redraw\. This will remove all objects and recreate them, probably in different places\.
-.
-.fi
-.
-.IP "" 0
+.TH "WEATHERSPECT" "1" "2019-12-30"
+.
+.SH "NAME"
+weatherspect \- a virtual weather environment in ASCII
+.
+.SH SYNOPSIS
+\fBweatherspect\fR [\fB\-f\fR \fIFILE\fR]
+.PP
+\fBweatherspect\fR \fB\-c\fR [\fB\-f\fR \fIFILE\fR]
+.PP
+\fBweatherspect\fR \fB\-h\fR
+.
+.SH "DESCRIPTION"
+\fBweatherspect\fR provides a reasonably accurate simulation of what the weather looks like outside, in ASCII art\. It includes rain, snow, lightning, sleet, and hail\. The windspeed and cloudiness are reflected in the velocity and quantity of clouds\. There are trees that age, reproduce and die over the course of an hour, and a sun and moon that follow the actual sun and moonrise\. There\'s also a dancing turtle\.
+.
+.SH "OPTIONS"
+.TP
+\fB\-f\fR \fIFILE\fR
+Supply a config file to use instead of the default
+.TP
+\fB\-c\fR
+Generate a config file
+.TP
+\fB\-h\fR
+Print a help message
+.
+.SH "USAGE"
+Before \fBweatherspect\fR will work, you have to create a config file for it\. Running it with the \fB\-c\fR option will prompt you for info to create a config file in \fI~/\.weatherspect\fR\.
+.PP
+While \fBweatherspect\fR is running, the following commands are available:
+.TP
+\fBq\fR
+Quit
+.TP
+\fBh\fR
+Toggle the help window
+.TP
+\fBw\fR
+Toggle the detailed weather info window
+.TP
+\fBd\fR
+Toggle the debug window
+.TP
+\fBu\fR
+Force an update of weather data
+.TP
+\fBr\fR
+Redraw. This will remove all objects and recreate them, probably in different places.
+.
+.SH "CREDITS"
+.IP "\(bu" 4
+Kirk Baucom \<\fIkbaucom@schizoid\.com\fR\> \- \fIhttp://www\.robobunny\.com\fR
.
-.SH "Credits"
-by Kirk Baucom \fIkbaucom@schizoid\.com\fR \fIhttp://www\.robobunny\.com\fR
+.IP "\(bu" 4
+Kevin Ferree \- \fIhttp://chavo\-one\.com\fR: All art in the code marked with \'kf\'
.
.IP "\(bu" 4
-Kevin Ferree (http://chavo\-one\.com): All art in the code marked with \'kf\'
+Hayley Wakenshaw \- \fIhttp://www\.bornsquishy\.com/flump/index\.html\fR: All art in the code marked with \'hjw\'
.
.IP "\(bu" 4
-Hayley Wakenshaw (http://www\.bornsquishy\.com/flump/index\.html): All art in the code marked with \'hjw\'
+Joan Stark \- \fIhttp://www\.geocities\.com/SoHo/7373/\fR: All art in the code marked with \'jgs\'
.
.IP "\(bu" 4
-Joan Stark (http://www\.geocities\.com/SoHo/7373/): All art in the code marked with \'jgs\'
+AnotherFoxGuy \- \fIhttp://anotherfoxguy.com\fR: Replaced Underground with OpenWeatherMap
.
.IP "" 0
.
-.P
+.PP
You can grep for ATTRIB in the code to get a list of credits for all the ASCII art\.