summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2023-08-14 12:50:38 +0300
committerkevku2023-08-14 12:50:38 +0300
commitfa57ba2927c2a68ced063cb9e01c27dfa48e2e6d (patch)
tree8b5a929c9a56b30211e083f466092dce94920f39
parent40571999ecd822216cbb9adfa3e96c9fcb7d6959 (diff)
downloadaur-web-eid.tar.gz
update 2.4.0.639
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 850cf2dc4e5f..7c56e334685a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = web-eid
- pkgver = 2.3.1.619
+ pkgver = 2.4.0.639
pkgrel = 1
url = https://www.id.ee/
arch = x86_64
@@ -13,20 +13,22 @@ pkgbase = web-eid
depends = qt6-base
depends = qt6-svg
depends = pcsclite
+ depends = ccid
depends = hicolor-icon-theme
conflicts = chrome-token-signing
- source = web-eid::git+https://github.com/web-eid/web-eid-app.git?signed#tag=v2.3.1
+ noextract = web_eid_webextension-2.2.1.xpi
+ source = web-eid::git+https://github.com/web-eid/web-eid-app.git?signed#tag=v2.4.0
source = web-eid-libelectronic-id::git+https://github.com/web-eid/libelectronic-id.git
source = web-eid-libpcsc-cpp::git+https://github.com/web-eid/libpcsc-cpp.git
source = web-eid-libpcsc-mock::git+https://github.com/web-eid/libpcsc-mock.git
- source = pcsc-mock-gcc13-cstdint.patch
+ source = https://addons.mozilla.org/firefox/downloads/file/4079746/web_eid_webextension-2.2.1.xpi
validpgpkeys = 1282B0F8809D0DC632C85A3F86B611CE24492160
validpgpkeys = D1EBC666EFCBFBD3CFC2EBAA90C0B5E75C3B195D
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 9562b20ad20fe45ef13d61e6ac71438a64a3a4acb990ff976d1428200b2db175
+ sha256sums = 392666581a3e71130307eb94f9010b4ca843829f592db9a093ad68fc00ca59ba
pkgname = web-eid-native
pkgdesc = Web eID native application
diff --git a/PKGBUILD b/PKGBUILD
index cce7c3756242..4a1573d91855 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: kevku <kevku@gmx.com>
pkgbase=web-eid
pkgname=("web-eid-native" "web-eid-firefox" "web-eid-chrome")
-pkgver=2.3.1.619
-_rls_tag=v2.3.1
+pkgver=2.4.0.639
+_rls_tag=v2.4.0
+_ext_ver=2.2.1
pkgrel=1
arch=('x86_64')
url="https://www.id.ee/"
license=('MIT')
conflicts=('chrome-token-signing')
-depends=('openssl' 'qt6-base' 'qt6-svg' 'pcsclite' 'hicolor-icon-theme')
+depends=('openssl' 'qt6-base' 'qt6-svg' 'pcsclite' 'ccid' 'hicolor-icon-theme')
makedepends=('git' 'qt6-tools' 'gtest' 'gmock' 'cmake')
source=("$pkgbase::git+https://github.com/web-eid/web-eid-app.git?signed#tag=$_rls_tag"
"web-eid-libelectronic-id::git+https://github.com/web-eid/libelectronic-id.git"
"web-eid-libpcsc-cpp::git+https://github.com/web-eid/libpcsc-cpp.git"
"web-eid-libpcsc-mock::git+https://github.com/web-eid/libpcsc-mock.git"
- "pcsc-mock-gcc13-cstdint.patch")
+ "https://addons.mozilla.org/firefox/downloads/file/4079746/web_eid_webextension-$_ext_ver.xpi")
+noextract=("web_eid_webextension-$_ext_ver.xpi")
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '9562b20ad20fe45ef13d61e6ac71438a64a3a4acb990ff976d1428200b2db175')
+ '392666581a3e71130307eb94f9010b4ca843829f592db9a093ad68fc00ca59ba')
validpgpkeys=(
'1282B0F8809D0DC632C85A3F86B611CE24492160' # Mart Somermaa https://github.com/mrts.gpg
'D1EBC666EFCBFBD3CFC2EBAA90C0B5E75C3B195D' # Raul Metsma
@@ -43,8 +45,6 @@ prepare() {
git submodule init
git config submodule.tests/lib/libpcsc-mock.url $srcdir/web-eid-libpcsc-mock
git -c protocol.file.allow=always submodule update
- cd "tests/lib/libpcsc-mock"
- patch -p1 -i "$srcdir/pcsc-mock-gcc13-cstdint.patch"
}
build() {
@@ -81,7 +81,7 @@ package_web-eid-firefox() {
cd "$srcdir/$pkgbase/$pkgbase-build"
install -Dm644 "src/app/eu.webeid.firefox.json" \
"$pkgdir/usr/lib/mozilla/native-messaging-hosts/eu.webeid.json"
- install -Dm644 "src/app/{e68418bc-f2b0-4459-a9ea-3e72b6751b07}.xpi" \
+ install -Dm644 "$srcdir/web_eid_webextension-$_ext_ver.xpi" \
"$pkgdir/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{e68418bc-f2b0-4459-a9ea-3e72b6751b07}.xpi"
install -Dm644 "../LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}