summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Kamiński2017-10-23 16:55:05 +0800
committerBartłomiej Kamiński2017-10-23 16:55:05 +0800
commit9d27746bef5b1ef1e7f2366900e99116a56b39ba (patch)
tree07743d6e33d1c4bf517b2274a6e45f059fdb51f7
downloadaur-web-hosting-manager.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0eeef71fae8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = web-hosting-manager
+ pkgdesc = A tutorial app showcasing how to create and manage web services for Public ID on SAFE Network.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/maidsafe/safe_examples
+ arch = i686
+ arch = x86_64
+ groups = maidsafe
+ license = GPL3
+ makedepends = nvm
+ makedepends = yarn
+ depends = safe-browser
+ source = https://github.com/maidsafe/safe_examples/archive/alpha-2.tar.gz
+ md5sums = 9f2fd11606650443355a3641e8ba8cd6
+
+pkgname = web-hosting-manager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cbcc3ffe58e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Bartłomiej Kamiński <bartlomiej.kaminski@maidsafe.net>
+pkgname=web-hosting-manager
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A tutorial app showcasing how to create and manage web services for Public ID on SAFE Network."
+arch=('i686' 'x86_64')
+url="https://github.com/maidsafe/safe_examples"
+license=('GPL3')
+groups=('maidsafe')
+depends=('safe-browser')
+makedepends=('nvm' 'yarn')
+optdepends=()
+install=
+changelog=
+source=('https://github.com/maidsafe/safe_examples/archive/alpha-2.tar.gz')
+md5sums=('9f2fd11606650443355a3641e8ba8cd6')
+
+build() {
+ # use nvm
+ . /usr/share/nvm/nvm.sh
+
+ # prepare nvm dir
+ mkdir -p $HOME/.nvm-tmp
+ export NVM_DIR=$HOME/.nvm-tmp
+ nvm install 7.10.0
+
+ # load dependencies for safe-browser
+ cd "safe_examples-alpha-2/web_hosting_manager"
+ yarn
+ yarn run package
+
+ nvm unload
+ rm -rf $HOME/.nvm-tmp
+}
+
+package() {
+ cd "safe_examples-alpha-2/web_hosting_manager/release"
+ mkdir -p "$pkgdir/opt/maidsafe"
+ mkdir -p "$pkgdir/usr/bin"
+ mv linux-unpacked "$pkgdir/opt/maidsafe/$pkgname-$pkgver"
+ ln -s "/opt/maidsafe/$pkgname-$pkgver/web-hosting-manager" "$pkgdir/usr/bin/web-hosting-manager"
+}