summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Grousset/tuxayo2016-04-15 14:39:27 +0200
committerVictor Grousset/tuxayo2016-04-15 14:39:27 +0200
commit299e82a604d6f8d9c830759ca4d6190ddb950743 (patch)
tree3e91ebeef881a3d3ee26b4bf6f753feebfdd362b
parente6a1982c65982277157ef77d8da463108dccf65d (diff)
downloadaur-299e82a604d6f8d9c830759ca4d6190ddb950743.tar.gz
include lessons because now they are in a separate repository
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6961f6fed73..fbf5b6fe1c25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webgoat
pkgdesc = Deliberately insecure J2EE web application designed to teach web application security concepts
pkgver = 7.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://webgoat.github.io/
install = webgoat.install
arch = i686
@@ -13,8 +13,10 @@ pkgbase = webgoat
optdepends = paros: MitM HTTP/HTTPS proxy, spider, XSS and injection scanner + more, used to help solve WebGoat lessons
source = webgoat-7.0.1.tar.gz::https://github.com/WebGoat/WebGoat/archive/7.0.1.tar.gz
source = webgoat.sh
+ source = git://github.com/WebGoat/WebGoat-Lessons.git
sha256sums = 8d044f63470eb07be848566cf7cbb7058e7ba89221e00cc8289aeeea8e70d87f
sha256sums = 3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c
+ sha256sums = SKIP
pkgname = webgoat
diff --git a/PKGBUILD b/PKGBUILD
index 910e431eefd4..c8caf3885ad8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: tuxayo < victor (replace by @) tuxayo DOT net >
pkgname=webgoat
pkgver=7.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Deliberately insecure J2EE web application designed to teach web application security concepts'
arch=('i686' 'x86_64')
url='https://webgoat.github.io/'
@@ -15,12 +15,18 @@ makedepends=('maven')
optdepends=('webscarab: proxy for analyzing applications that communicate using the HTTP and HTTPS protocols, used to help solve most WebGoat lessons'
'paros: MitM HTTP/HTTPS proxy, spider, XSS and injection scanner + more, used to help solve WebGoat lessons')
source=("$pkgname-$pkgver.tar.gz::https://github.com/WebGoat/WebGoat/archive/${pkgver}.tar.gz"
- "webgoat.sh")
+ "webgoat.sh"
+ "git://github.com/WebGoat/WebGoat-Lessons.git")
sha256sums=('8d044f63470eb07be848566cf7cbb7058e7ba89221e00cc8289aeeea8e70d87f'
- '3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c')
+ '3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c'
+ 'SKIP')
install="$pkgname.install"
build() {
+ cd "$srcdir/WebGoat-Lessons"
+ mvn package
+ cp target/plugins/*.jar "$srcdir/WebGoat-$pkgver/webgoat-container/src/main/webapp/plugin_lessons/"
+
cd "$srcdir/WebGoat-$pkgver"
# Needed to fix issues with maven
echo "<settings><localRepository>$srcdir</localRepository></settings>" > "$srcdir/maven-settings.xml"