summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrejs Mivreņiks2015-08-31 21:46:49 +0300
committerAndrejs Mivreņiks2015-08-31 21:46:49 +0300
commitb995362a7acc0aa5b27fe0b34f59d39e207f7a38 (patch)
tree9b9327472302b2bf823165d8821eb99a32150c9e
parent7b2d15584ffa60e5969bbbd5f19b212318e08129 (diff)
downloadaur-b995362a7acc0aa5b27fe0b34f59d39e207f7a38.tar.gz
Clean up the PKGBUILD a bit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5fdb1f5e1cd..ebcb03fb67ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v7
+# Mon Aug 31 18:46:38 UTC 2015
pkgbase = webgoat
pkgdesc = Deliberately insecure J2EE web application designed to teach web application security concepts
pkgver = 6.0.1
@@ -11,7 +13,7 @@ pkgbase = webgoat
depends = java-runtime
optdepends = webscarab: proxy for analyzing applications that communicate using the HTTP and HTTPS protocols, used to help solve most WebGoat lessons
optdepends = paros: MitM HTTP/HTTPS proxy, spider, XSS and injection scanner + more, used to help solve WebGoat lessons
- source = https://github.com/WebGoat/WebGoat/archive/v6.0.1.tar.gz
+ source = webgoat-6.0.1.tar.gz::https://github.com/WebGoat/WebGoat/archive/v6.0.1.tar.gz
source = webgoat.sh
sha256sums = 0fe10011df18b2ebb7ee0658026b29d0ae9a0c1ea9a68cf511ef40fb48930964
sha256sums = 3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c
diff --git a/PKGBUILD b/PKGBUILD
index 6b82948d07bc..8b331448af5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,24 +12,23 @@ depends=('java-runtime')
makedepends=('maven')
optdepends=('webscarab: proxy for analyzing applications that communicate using the HTTP and HTTPS protocols, used to help solve most WebGoat lessons'
'paros: MitM HTTP/HTTPS proxy, spider, XSS and injection scanner + more, used to help solve WebGoat lessons')
-source=("https://github.com/WebGoat/WebGoat/archive/v${pkgver}.tar.gz"
- "${pkgname}.sh")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/WebGoat/WebGoat/archive/v${pkgver}.tar.gz"
+ "webgoat.sh")
sha256sums=('0fe10011df18b2ebb7ee0658026b29d0ae9a0c1ea9a68cf511ef40fb48930964'
'3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c')
-install="${pkgname}.install"
+install="$pkgname.install"
build() {
- cd ${srcdir}/WebGoat-$pkgver
+ cd "$srcdir/WebGoat-$pkgver"
# Needed to fix issues with maven
- echo "<settings><localRepository>$srcdir</localRepository></settings>" > $srcdir/maven-settings.xml
+ echo "<settings><localRepository>$srcdir</localRepository></settings>" > "$srcdir/maven-settings.xml"
mvn -s $srcdir/maven-settings.xml clean package
}
package() {
- install -D -m755 webgoat.sh $pkgdir/usr/bin/webgoat
- cd ${srcdir}/WebGoat-$pkgver
- install -d $pkgdir/opt/$pkgname/
+ cd "$srcdir/WebGoat-$pkgver"
+ install -Dm755 ../webgoat.sh "$pkgdir/usr/bin/webgoat"
+ install -d "$pkgdir/opt/$pkgname"
cp -r doc $pkgdir/opt/$pkgname/doc
- install -D -m644 target/WebGoat-$pkgver-war-exec.jar $pkgdir/opt/$pkgname/webgoat.jar
+ install -Dm644 "target/WebGoat-$pkgver-war-exec.jar" "$pkgdir/opt/$pkgname/webgoat.jar"
}
-# vim:set ts=2 sw=2 et: