summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Grousset/tuxayo2016-04-14 20:50:49 +0200
committerVictor Grousset/tuxayo2016-04-14 20:50:49 +0200
commite6a1982c65982277157ef77d8da463108dccf65d (patch)
treeaac6d4767585180b895d05745225586cf9277648
parente923579910428cf5b0ad848032b87af7b3768aa6 (diff)
downloadaur-e6a1982c65982277157ef77d8da463108dccf65d.tar.gz
Update from legacy version to 7.0.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9934925913e3..d6961f6fed73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v7
-# Mon Aug 31 18:49:41 UTC 2015
pkgbase = webgoat
pkgdesc = Deliberately insecure J2EE web application designed to teach web application security concepts
- pkgver = 6.0.1
- pkgrel = 3
+ pkgver = 7.0.1
+ pkgrel = 1
url = https://webgoat.github.io/
install = webgoat.install
arch = i686
@@ -13,9 +11,9 @@ pkgbase = webgoat
depends = java-runtime
optdepends = webscarab: proxy for analyzing applications that communicate using the HTTP and HTTPS protocols, used to help solve most WebGoat lessons
optdepends = paros: MitM HTTP/HTTPS proxy, spider, XSS and injection scanner + more, used to help solve WebGoat lessons
- source = webgoat-6.0.1.tar.gz::https://github.com/WebGoat/WebGoat-Legacy/archive/v6.0.1.tar.gz
+ source = webgoat-7.0.1.tar.gz::https://github.com/WebGoat/WebGoat/archive/7.0.1.tar.gz
source = webgoat.sh
- sha256sums = 21945864691f444824b70222018d43591010603d256f097c12b0885ce3c70779
+ sha256sums = 8d044f63470eb07be848566cf7cbb7058e7ba89221e00cc8289aeeea8e70d87f
sha256sums = 3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c
pkgname = webgoat
diff --git a/PKGBUILD b/PKGBUILD
index 13c3145a14f5..910e431eefd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
-# Maintainer: Andrejs Mivreņiks <gim at fastmail dot fm>
+# Maintainer: tuxayo < victor (replace by @) tuxayo DOT net >
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: fnord0 < fnord0 AT riseup DOT net >
+# Contributor: Andrejs Mivreņiks <gim at fastmail dot fm>
+# Contributor: tuxayo < victor (replace by @) tuxayo DOT net >
pkgname=webgoat
-pkgver=6.0.1
-pkgrel=3
+pkgver=7.0.1
+pkgrel=1
pkgdesc='Deliberately insecure J2EE web application designed to teach web application security concepts'
arch=('i686' 'x86_64')
url='https://webgoat.github.io/'
@@ -12,23 +14,22 @@ depends=('java-runtime')
makedepends=('maven')
optdepends=('webscarab: proxy for analyzing applications that communicate using the HTTP and HTTPS protocols, used to help solve most WebGoat lessons'
'paros: MitM HTTP/HTTPS proxy, spider, XSS and injection scanner + more, used to help solve WebGoat lessons')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/WebGoat/WebGoat-Legacy/archive/v${pkgver}.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/WebGoat/WebGoat/archive/${pkgver}.tar.gz"
"webgoat.sh")
-sha256sums=('21945864691f444824b70222018d43591010603d256f097c12b0885ce3c70779'
+sha256sums=('8d044f63470eb07be848566cf7cbb7058e7ba89221e00cc8289aeeea8e70d87f'
'3615a09c64eb07709bede9b22782bedeffe7c7097cde1c6bcc2a07adcd28712c')
install="$pkgname.install"
build() {
- cd "$srcdir/WebGoat-Legacy-$pkgver"
+ cd "$srcdir/WebGoat-$pkgver"
# Needed to fix issues with maven
echo "<settings><localRepository>$srcdir</localRepository></settings>" > "$srcdir/maven-settings.xml"
mvn -s $srcdir/maven-settings.xml clean package
}
package() {
- cd "$srcdir/WebGoat-Legacy-$pkgver"
+ cd "$srcdir/WebGoat-$pkgver"
install -Dm755 ../webgoat.sh "$pkgdir/usr/bin/webgoat"
install -d "$pkgdir/opt/$pkgname"
- cp -r doc "$pkgdir/opt/$pkgname/doc"
- install -Dm644 "target/WebGoat-$pkgver-war-exec.jar" "$pkgdir/opt/$pkgname/webgoat.jar"
+ install -Dm644 "webgoat-container/target/webgoat-container-$pkgver-war-exec.jar" "$pkgdir/opt/$pkgname/webgoat.jar"
}