summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav N. aka pztrn2019-06-26 14:24:06 +0500
committerStanislav N. aka pztrn2019-06-26 14:24:06 +0500
commit7831ac890bf4e76fcaf5300ba3eddab981f52f2a (patch)
tree9e62c2fab9fc1669059d9c561803391bb7f0a4c3
parent25b35443dcd774ea60fb3e27d785f2817e525600 (diff)
downloadaur-webissues-client.tar.gz
Added patch to remove QPallete definition at issue dialogs, fixes dark themes LnF.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--remove-qpallete-from-issues-dialogs.patch15
3 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e8e002b4ca6..51d2313b87e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webissues-client
pkgdesc = An open source, multi-platform system for issue tracking and team collaboration.
pkgver = 1.1.5
- pkgrel = 2
+ pkgrel = 3
url = http://webissues.mimec.org/
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 04a98a606fe7..106ab207c903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=webissues-client
pkgver=1.1.5
-pkgrel=2
+pkgrel=3
pkgdesc="An open source, multi-platform system for issue tracking and team collaboration."
arch=("x86_64")
url="http://webissues.mimec.org/"
@@ -17,6 +17,8 @@ sha256sums=("7781b26ffefb6fcd05acc7d0b6a02ec237007496d85eb78b185701c245fca895")
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch --forward --strip=1 --input="../../remove-qpallete-from-issues-dialogs.patch"
+
./configure -prefix /usr -destdir "$pkgdir" -system-sqlite
make
}
diff --git a/remove-qpallete-from-issues-dialogs.patch b/remove-qpallete-from-issues-dialogs.patch
new file mode 100644
index 000000000000..a3a90fa79c6d
--- /dev/null
+++ b/remove-qpallete-from-issues-dialogs.patch
@@ -0,0 +1,15 @@
+diff --git a/src/dialogs/issuedialogs.cpp b/src/dialogs/issuedialogs.cpp
+index 3e64fb7..4507f5d 100644
+--- a/src/dialogs/issuedialogs.cpp
++++ b/src/dialogs/issuedialogs.cpp
+@@ -159,10 +159,6 @@ bool IssueDialog::initialize( int typeId, int projectId, Flags flags )
+ attributeScroll->setWidgetResizable( true );
+ attributeLayout->addWidget( attributeScroll );
+
+- QPalette scrollPalette = palette();
+- scrollPalette.setColor( QPalette::Window, QColor::fromRgb( 255, 255, 255 ) );
+- attributeScroll->setPalette( scrollPalette );
+-
+ QWidget* attributePanel = new QWidget( attributeScroll );
+ attributeScroll->setWidget( attributePanel );
+