summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Schantl2023-05-10 17:06:10 +0000
committerMichael Schantl2023-05-10 17:06:10 +0000
commit9dd5378ecdaffac89159385c4bfac24ae6b9d363 (patch)
tree9b5f38e51e5cff808bbe0f5acc13a42d0fb206ea
parente043e95507fc89175d96c045efc3602252768486 (diff)
downloadaur-9dd5378ecdaffac89159385c4bfac24ae6b9d363.tar.gz
Add patch for incorrect upstream versioning
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD5
-rw-r--r--weewx-version.patch39
3 files changed, 44 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
index d52a539b7d64..8363df399f28 100644
--- a/.gitignore
+++ b/.gitignore
@@ -16,4 +16,5 @@
!weewx.service
!weewxd
!wunderfixer
+!weewx-version.patch
!pillow-rect.patch
diff --git a/PKGBUILD b/PKGBUILD
index 13f8f44e6ba9..3c489351bedf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,8 @@ source=("$pkgname-$pkgver.tar.xz::$(_dl_url $_MAJOR $_MINOR $_PATCH)"
"weewxd"
"wunderfixer"
"weewx.service"
- "pillow-rect.patch")
+ "pillow-rect.patch"
+ "weewx-version.patch")
sha512sums=('8fca9cd7720a29687a0d900e4d89ec2ce5ca5d2aa36bc5b5909ea14ecb849cdbdb6e699cf1c3a0d5505c89ad8c309517db32fd8dc4a0ae4704dfd5ed0cc5747f'
'SKIP'
'SKIP'
@@ -53,11 +54,13 @@ sha512sums=('8fca9cd7720a29687a0d900e4d89ec2ce5ca5d2aa36bc5b5909ea14ecb849cdbdb6
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
_watch="http://www.weewx.com/downloads/"
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
+ patch --strip=1 --input="$srcdir/weewx-version.patch"
patch --strip=1 --input="$srcdir/pillow-rect.patch"
}
diff --git a/weewx-version.patch b/weewx-version.patch
new file mode 100644
index 000000000000..22d99178e79a
--- /dev/null
+++ b/weewx-version.patch
@@ -0,0 +1,39 @@
+diff --git a/bin/weewx/__init__.py b/bin/weewx/__init__.py
+index e97c4d8b..436fd783 100644
+--- a/bin/weewx/__init__.py
++++ b/bin/weewx/__init__.py
+@@ -7,7 +7,7 @@
+ from __future__ import absolute_import
+ import time
+
+-__version__="4.10.1"
++__version__="4.10.2"
+
+ # Holds the program launch time in unix epoch seconds:
+ # Useful for calculating 'uptime.'
+diff --git a/setup.py b/setup.py
+index 93e295b9..256b303e 100755
+--- a/setup.py
++++ b/setup.py
+@@ -32,7 +32,7 @@ from distutils.command.install_lib import install_lib
+ from distutils.core import setup
+ from distutils.debug import DEBUG
+
+-VERSION = "4.10.1"
++VERSION = "4.10.2"
+
+ if sys.version_info < (2, 7):
+ log.fatal('WeeWX requires Python V2.7 or greater.')
+diff --git a/weewx.conf b/weewx.conf
+index 517af0b9..cd98bac6 100644
+--- a/weewx.conf
++++ b/weewx.conf
+@@ -20,7 +20,7 @@ log_success = True
+ log_failure = True
+
+ # Do not modify this. It is used when installing and updating weewx.
+-version = 4.10.1
++version = 4.10.2
+
+ ##############################################################################
+