summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Dray2016-03-29 13:41:53 +1000
committerJustin Dray2016-03-29 13:41:53 +1000
commite2db90ec4159c5e2055630d4c1a6552d183ad4dd (patch)
treebca8ba15e0661abde74a3d20d3fedba90adb9ab1
downloadaur-wemux.tar.gz
Update to: 3.2.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD38
-rw-r--r--wemux.install9
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..048a35658dad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wemux
+ pkgdesc = Multi-user Tmux made easy
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = https://github.com/zolrath/wemux
+ install = wemux.install
+ arch = any
+ license = MIT
+ depends = tmux
+ depends = lsof
+ depends = openssh
+ backup = etc/wemux/wemux.conf
+ source = https://github.com/zolrath/wemux/archive/v3.2.0.zip
+ md5sums = c83c5ee88d3784d79449c05a8e55da70
+
+pkgname = wemux
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..181b3460e424
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.desktop
+!*.install
+!*.service
+!*.sh
+!*.conf
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f8465f45736
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Tristan Webb <tristanjwebb@gmail.com>
+pkgname=wemux
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Multi-user Tmux made easy"
+url="https://github.com/zolrath/wemux"
+arch=('any')
+license=('MIT')
+depends=('tmux' 'lsof' 'openssh')
+backup=('etc/wemux/wemux.conf')
+install='wemux.install'
+md5sums=('c83c5ee88d3784d79449c05a8e55da70')
+source=("https://github.com/zolrath/wemux/archive/v${pkgver}.zip")
+
+package(){
+ cd wemux-$pkgver
+ install -dm755 $pkgdir/usr/share
+
+ sed -i -e "s|usr/local/etc|etc/wemux|g" ./wemux
+
+ #install manpage
+ install -Dm644 ./man/wemux.1 $pkgdir/usr/share/man/man1/wemux.1
+
+
+ #install binary and readme
+ install -Dm755 ./wemux $pkgdir/usr/bin/wemux
+ install -Dm644 ./README.md $pkgdir/usr/share/wemux/README.md
+
+ #install conf
+ install -Dm644 ./wemux.conf.example $pkgdir/etc/wemux/wemux.conf
+
+ #install licence
+ install -Dm644 ./MIT-LICENSE $pkgdir/usr/share/licenses/wemux/LICENSE
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/wemux.install b/wemux.install
new file mode 100644
index 000000000000..8b02dd50051f
--- /dev/null
+++ b/wemux.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "#####################################################################"
+ echo "# IMPORTANT: #"
+ echo "# In order to use wemux you must set a user to be a wemux host by #"
+ echo "# adding their username to the host_list in /etc/wemux/wemux.conf. #"
+ echo "#####################################################################"
+}
+
+# vim:set ts=2 sw=2 et: