summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-12-26 18:29:11 +0100
committerSeverin Glöckner2018-12-26 21:45:16 +0100
commitddee12237248cca9e6f891de1644a7cbe399e011 (patch)
tree5453f90d97504850f090f0880ce812c5e3003c95
parentff56b2422690e1c1059b86974b27827e3b1a400b (diff)
downloadaur-ddee12237248cca9e6f891de1644a7cbe399e011.tar.gz
switch to branch version, as it contains no translation breakages, but additional fixes
-rw-r--r--PKGBUILD42
1 files changed, 22 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce3a3d53741a..4b86c297ca16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,42 +8,44 @@
# and $srcdir as well as $stardir would be the place where you have your files)
pkgname=wesnoth-1.12
-pkgver=1.12.6
-pkgrel=11
+pkgver=1.12.6+dev
+pkgrel=9
pkgdesc="Turn-based strategy game on a fantasy world (oldstable)"
arch=('i686' 'x86_64')
url="https://www.wesnoth.org"
license=('GPL')
depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_ttf' 'sdl_net' 'boost-libs' 'bzip2' 'zlib' 'libvorbis' 'pango' 'cairo' 'fontconfig' 'dbus' 'fribidi')
-makedepends=('boost' 'cmake')
+makedepends=('boost' 'cmake' 'git')
# package names on Debian / Ubuntu / Mint:
# libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev libsdl-net1.2-dev libboost-filesystem-dev libboost-locale-dev libboost-iostreams-dev libboost-regex-dev libboost-serialization-dev libasio-dev libboost-program-options-dev libboost-system-dev zlib1g-dev libpango1.0-dev libcairo2-dev libvorbis-dev libfontconfig1-dev libdbus-1-dev libfribidi-dev gettext-base cmake make pkgconf gcc g++ git
options=('!emptydirs')
-source=("https://downloads.sourceforge.net/sourceforge/wesnoth/wesnoth-1.12.6.tar.bz2"
- "wesnoth-1.12.desktop"
+source=("wesnoth-1.12.desktop"
"wesnothd-1.12.tmpfiles.conf"
"wesnothd-1.12.service"
- "wesnoth-1.12.appdata.xml"
- "wesnoth-boost.patch::https://github.com/wesnoth/wesnoth/commit/789588d11e3512b3494b4aeac11b44f1c38ad86d.patch"
- "wesnoth-cve.patch::https://github.com/wesnoth/wesnoth/commit/e764257c3e91dfe7d26da2287b57b01158d213c0.patch")
+ "wesnoth-1.12.appdata.xml")
# Not finding some files? https://aur.archlinux.org/packages/wesnoth-1.12
# Rest assured, they are optional. Things like a launcher for your convenience…
-sha256sums=('a50f384cead15f68f31cfa1a311e76a12098428702cb674d3521eb169eb92e4e'
- 'f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877'
+sha256sums=('f765499315d6650fe91424c0818cc57fc9fd06108c29e78c2db987c148dbf877'
'4d11e481ad8610bb2ad65290d2b3d1bf2d058485deaa9016325499b113e0f89f'
'bbc1a80412d3e880d695cf0e818969da90c578501b455d0a6a81a45568cd8231'
- 'e5b0bd418e97d5f8cfc9392045dc749941c71e9cf805ef6f343c318022088384'
- '74bfc9187b3cdd1744477ca509344a516a94c9992a4c6273ed8a9f370d96600a'
- 'be21d7fd38b18238edeb38c52206a4d9a26ec09fe0d1a7333785df63023707a6')
+ 'e5b0bd418e97d5f8cfc9392045dc749941c71e9cf805ef6f343c318022088384')
PKGEXT='.pkg.tar'
prepare() {
- cd wesnoth-1.12
-
- patch -Np1 < ${srcdir}/wesnoth-boost.patch
- patch -Np1 < ${srcdir}/wesnoth-cve.patch
+ cd "$startdir"
+
+ # get a shallow clone of the git repo and store it outside the srcdir
+ if [ ! -d "wesnoth-1.12-git" ] ; then
+ git clone https://github.com/wesnoth/wesnoth -b 1.12 --shallow-exclude=1.12.6 wesnoth-1.12-git
+ msg "Git checkout done (or server timeout)"
+ fi
+
+ # Archlinux specific (hide the usage of the $startdir variable)
+ if [ ! -e "$srcdir/wesnoth-1.12-git" ] ; then
+ ln -s "$startdir/wesnoth-1.12-git" "$srcdir/wesnoth-1.12-git"
+ fi
}
build() {
@@ -61,7 +63,7 @@ build() {
# below, and edit the start command in the file wesnothd-1.12.service.
rm -rf build && mkdir build && cd build
- cmake ../wesnoth-1.12 \
+ cmake ../wesnoth-1.12-git \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBINARY_SUFFIX=-1.12 \
-DDATADIRNAME=wesnoth-1.12 \
@@ -104,8 +106,8 @@ package() {
# placing relevant packaging files (launcher, icons, systemd and appdata files)
install -D -m644 "$srcdir/wesnoth-1.12.desktop" "$pkgdir/usr/share/applications/wesnoth-1.12.desktop"
- install -D -m644 "$srcdir/wesnoth-1.12/images/game-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/wesnoth-1.12-icon.png"
- install -D -m644 "$srcdir/wesnoth-1.12/data/core/images/wesnoth-icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/wesnoth-1.12-icon.png"
+ install -D -m644 "$srcdir/wesnoth-1.12-git/images/game-icon.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/wesnoth-1.12-icon.png"
+ install -D -m644 "$srcdir/wesnoth-1.12-git/data/core/images/wesnoth-icon.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/wesnoth-1.12-icon.png"
install -D -m644 "$srcdir/wesnoth-1.12.appdata.xml" "$pkgdir/usr/share/metainfo/wesnoth-1.12.appdata.xml"