summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Le Moal2015-06-21 18:16:03 +0200
committerOlivier Le Moal2015-06-21 18:16:03 +0200
commit62565e7bbc9fd15ab1148352a65d25817a868e2b (patch)
tree5382d83cf01e531cd2b420ccb271a9dbf391ba1b
downloadaur-62565e7bbc9fd15ab1148352a65d25817a868e2b.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56f9a8f51369
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wfuzz
+ pkgdesc = Utility to bruteforce web applications to find their not linked resources
+ pkgver = 2.1beta
+ pkgrel = 1
+ url = https://github.com/xmendez/wfuzz
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2-pycurl
+ source = https://github.com/xmendez/wfuzz/releases/download/v2.1-beta/wfuzz-2.1.beta.tar.gz
+ md5sums = 8aa60e900483553223fd989922c05b91
+
+pkgname = wfuzz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c11cb578039
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Contributor: Olivier Le Moal <mail at olivierlemoal dot fr>
+#Maintainer: Dawid Wrobel <cromo@klej.net>
+#Maintainer: Sébastien Duquette <ekse.0x@gmail.com>
+#Maintainer: onny <onny@project-insanity.org>
+
+pkgname=wfuzz
+pkgver=2.1beta
+pkgrel=1
+pkgdesc="Utility to bruteforce web applications to find their not linked resources"
+url="https://github.com/xmendez/wfuzz"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('python2-pycurl')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("https://github.com/xmendez/wfuzz/releases/download/v2.1-beta/${pkgname}-2.1.beta.tar.gz")
+md5sums=('8aa60e900483553223fd989922c05b91')
+package() {
+ mkdir -p ${pkgdir}/opt/wfuzz
+ mkdir -p ${pkgdir}/usr/bin
+ cp -r ${srcdir}/wfuzz-2.1-beta/* ${pkgdir}/opt/wfuzz/
+ echo -e "#!/bin/bash\n\ncd /opt/wfuzz\npython2.7 /opt/wfuzz/wfuzz.py \$@" > ${pkgdir}/usr/bin/wfuzz
+ sed -i '0,/RE/s/python/python2/' ${pkgdir}/opt/wfuzz/wfuzz.py
+ chmod a+x ${pkgdir}/usr/bin/wfuzz
+}